summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 20:56:25 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 20:56:25 +0000
commit6108d13ce7958f9444c85dd78149590514ff16ff (patch)
treed33090314c27a4e2996a83678ebc86520dc10d57 /app-text/antiword/antiword-0.37.ebuild
parentInitial import, #252981 (diff)
downloadgentoo-2-6108d13ce7958f9444c85dd78149590514ff16ff.tar.gz
gentoo-2-6108d13ce7958f9444c85dd78149590514ff16ff.tar.bz2
gentoo-2-6108d13ce7958f9444c85dd78149590514ff16ff.zip
QA: Respect CC (bug 243708), respect LDFLAGS
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-text/antiword/antiword-0.37.ebuild')
-rw-r--r--app-text/antiword/antiword-0.37.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/app-text/antiword/antiword-0.37.ebuild b/app-text/antiword/antiword-0.37.ebuild
index 788772f60587..163c28508204 100644
--- a/app-text/antiword/antiword-0.37.ebuild
+++ b/app-text/antiword/antiword-0.37.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/antiword-0.37.ebuild,v 1.9 2007/10/25 20:22:19 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/antiword-0.37.ebuild,v 1.10 2008/12/30 20:56:25 angelos Exp $
inherit eutils
@@ -18,19 +18,21 @@ KEYWORDS="alpha amd64 ~hppa ppc ppc64 sparc x86"
PATCHDIR=${WORKDIR}/gentoo-antiword/patches
src_unpack() {
- unpack ${A} ; cd ${S}
+ unpack ${A}
+ cd "${S}"
EPATCH_SUFFIX="diff" \
epatch ${PATCHDIR}
}
src_compile() {
- emake OPT="${CFLAGS}" || die
+ emake OPT="${CFLAGS}" CC="$(tc-getCC)" LD="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {
- make DESTDIR=${D} global_install || die
+ make DESTDIR="${D}" global_install || die
- use kde || rm -f ${D}/usr/bin/kantiword
+ use kde || rm -f "${D}"/usr/bin/kantiword
insinto /usr/share/${PN}/examples
doins Docs/testdoc.doc Docs/antiword.php