summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2005-12-05 16:39:15 +0000
committerJeroen Roovers <jer@gentoo.org>2005-12-05 16:39:15 +0000
commit07a0935ed5197e3713d0bccefd88b38ac7005f61 (patch)
tree39a34089046604a351a5e41fc03df67548841cbf /app-text/an
parentBumping the 2.0.1 cycle, due to a bug in the reiserfs-quota handling of vserver (diff)
downloadgentoo-2-07a0935ed5197e3713d0bccefd88b38ac7005f61.tar.gz
gentoo-2-07a0935ed5197e3713d0bccefd88b38ac7005f61.tar.bz2
gentoo-2-07a0935ed5197e3713d0bccefd88b38ac7005f61.zip
Made warning notice about sys-apps/miscfiles conditional.
(Portage version: 2.0.53)
Diffstat (limited to 'app-text/an')
-rw-r--r--app-text/an/ChangeLog5
-rw-r--r--app-text/an/an-0.93.ebuild24
-rw-r--r--app-text/an/an-0.95.3.ebuild23
3 files changed, 31 insertions, 21 deletions
diff --git a/app-text/an/ChangeLog b/app-text/an/ChangeLog
index 64ee58852c5a..3e0aeacad3fe 100644
--- a/app-text/an/ChangeLog
+++ b/app-text/an/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/an
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/an/ChangeLog,v 1.9 2005/12/01 20:37:50 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/an/ChangeLog,v 1.10 2005/12/05 16:34:28 jer Exp $
+
+ 05 Dec 2005; Jeroen Roovers <jer@gentoo.org> an-0.95.3.ebuild:
+ Made warning notice about sys-apps/miscfiles conditional.
01 Dec 2005; Luis Medinas <metalgod@gentoo.org> an-0.93.ebuild,
an-0.95.3.ebuild:
diff --git a/app-text/an/an-0.93.ebuild b/app-text/an/an-0.93.ebuild
index 03cd28b7c01a..a12922348dea 100644
--- a/app-text/an/an-0.93.ebuild
+++ b/app-text/an/an-0.93.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/an/an-0.93.ebuild,v 1.5 2005/12/01 20:37:50 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/an/an-0.93.ebuild,v 1.6 2005/12/05 16:39:15 jer Exp $
inherit toolchain-funcs
@@ -38,15 +38,19 @@ src_install() {
}
pkg_postinst() {
- ewarn "If you merged sys-apps/miscfiles with USE=minimal,"
- ewarn "an will NOT work properly, as /usr/share/dict/words"
- ewarn "will then be a symlink to a gzipped file. an currently"
- ewarn "does not support gzipped dictionary files and will"
- ewarn "only produce garbage."
- ewarn "Do 'USE=-minimal emerge sys-apps/miscfiles', or run an"
- ewarn "with the -d /path/to/dictionary option, perhaps using"
- ewarn "one of the files mentioned below."
- echo
+ if has_version sys-apps/miscfiles && \
+ built_with_use sys-apps/miscfiles minimal; then
+ ewarn "If you merged sys-apps/miscfiles with USE=minimal,"
+ ewarn "an will NOT work properly, as /usr/share/dict/words"
+ ewarn "will then be a symlink to a gzipped file. an currently"
+ ewarn "does not support gzipped dictionary files and will"
+ ewarn "only produce garbage."
+ ewarn "Do 'USE=-minimal emerge sys-apps/miscfiles', or run an"
+ ewarn "with the -d /path/to/dictionary option, perhaps using"
+ ewarn "one of the files mentioned below."
+ echo
+ fi
+
einfo "Helpful note from an's author:"
einfo " If you do not have a dictionary you can obtain one from the"
einfo " following site: ftp://ftp.funet.fi/pub/doc/dictionaries/"
diff --git a/app-text/an/an-0.95.3.ebuild b/app-text/an/an-0.95.3.ebuild
index 9a1d9cfc1da1..a49aeb6beeb3 100644
--- a/app-text/an/an-0.95.3.ebuild
+++ b/app-text/an/an-0.95.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/an/an-0.95.3.ebuild,v 1.4 2005/12/01 20:37:50 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/an/an-0.95.3.ebuild,v 1.5 2005/12/05 16:34:28 jer Exp $
inherit eutils toolchain-funcs versionator
@@ -57,15 +57,18 @@ src_install() {
}
pkg_postinst() {
- ewarn "If you merged sys-apps/miscfiles with USE=minimal,"
- ewarn "an will NOT work properly, as /usr/share/dict/words"
- ewarn "will then be a symlink to a gzipped file. an currently"
- ewarn "does not support gzipped dictionary files and will"
- ewarn "only produce garbage."
- ewarn "Do 'USE=-minimal emerge sys-apps/miscfiles', or run an"
- ewarn "with the -d /path/to/dictionary option, perhaps using"
- ewarn "one of the files mentioned below."
- echo
+ if has_version sys-apps/miscfiles && \
+ built_with_use sys-apps/miscfiles minimal; then
+ ewarn "If you merged sys-apps/miscfiles with USE=minimal,"
+ ewarn "an will NOT work properly, as /usr/share/dict/words"
+ ewarn "will then be a symlink to a gzipped file. an currently"
+ ewarn "does not support gzipped dictionary files and will"
+ ewarn "only produce garbage."
+ ewarn "Do 'USE=-minimal emerge sys-apps/miscfiles', or run an"
+ ewarn "with the -d /path/to/dictionary option, perhaps using"
+ ewarn "one of the files mentioned below."
+ echo
+ fi
einfo "Helpful note from an's author:"
einfo " If you do not have a dictionary you can obtain one from the"