summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2003-06-15 13:40:12 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2003-06-15 13:40:12 +0000
commit0a03e4b8cb9f49ae056adf9e3522d8b1922b893b (patch)
tree9256711bac0411387c2beb5a5208aa9020e51334 /app-text/agrep/agrep-2.04.ebuild
parentInitial import. (diff)
downloadgentoo-2-0a03e4b8cb9f49ae056adf9e3522d8b1922b893b.tar.gz
gentoo-2-0a03e4b8cb9f49ae056adf9e3522d8b1922b893b.tar.bz2
gentoo-2-0a03e4b8cb9f49ae056adf9e3522d8b1922b893b.zip
Initial import.
Diffstat (limited to 'app-text/agrep/agrep-2.04.ebuild')
-rw-r--r--app-text/agrep/agrep-2.04.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/agrep/agrep-2.04.ebuild b/app-text/agrep/agrep-2.04.ebuild
new file mode 100644
index 000000000000..ac9ac15ebc4e
--- /dev/null
+++ b/app-text/agrep/agrep-2.04.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/agrep/agrep-2.04.ebuild,v 1.1 2003/06/15 13:40:07 jhhudso Exp $
+
+DESCRIPTION="agrep is a tool for the fast searching of text allowing for errors in the search pattern."
+HOMEPAGE="ftp://ftp.cs.arizona.edu/agrep/README"
+SRC_URI="ftp://ftp.cs.arizona.edu/agrep/${P}.tar.Z"
+LICENSE="AGREP"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # Remove first occurace of CFLAGS so we grab the user CFLAGS
+ sed -i -e 's/^CFLAGS.*//' Makefile
+ emake || die
+}
+
+src_install() {
+ dobin agrep
+ doman agrep.1
+ dodoc README agrep.algorithms agrep.chronicle COPYRIGHT \
+ contribution.list
+}