summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-03-31 07:00:51 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-03-31 07:00:51 +0000
commitfcceefeb4aaf2170d644184de51ca3e7aa797460 (patch)
treee5d518ec5dfae43a5d949e3fdd78141d934bdcb3 /app-shells
parentBump to latest official patch release (diff)
downloadgentoo-2-fcceefeb4aaf2170d644184de51ca3e7aa797460.tar.gz
gentoo-2-fcceefeb4aaf2170d644184de51ca3e7aa797460.tar.bz2
gentoo-2-fcceefeb4aaf2170d644184de51ca3e7aa797460.zip
Bump to latest official patch release
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog10
-rw-r--r--app-shells/bash/bash-4.3_p8.ebuild (renamed from app-shells/bash/bash-4.3-r3.ebuild)11
-rw-r--r--app-shells/bash/files/bash-4.3-compound-array-empty-value.patch14
-rw-r--r--app-shells/bash/files/bash-4.3-debug-trap.patch34
-rw-r--r--app-shells/bash/files/bash-4.3-extglob-skipname.patch156
-rw-r--r--app-shells/bash/files/bash-4.3-jobs-exit.patch19
-rw-r--r--app-shells/bash/files/bash-4.3-parse-ansi-expand.patch19
7 files changed, 12 insertions, 251 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 2e8af4f7fb06..24906fe9cb33 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.358 2014/03/28 02:10:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.359 2014/03/31 07:00:51 polynomial-c Exp $
+
+*bash-4.3_p8 (31 Mar 2014)
+
+ 31 Mar 2014; Lars Wendler <polynomial-c@gentoo.org> -bash-4.3-r3.ebuild,
+ +bash-4.3_p8.ebuild, -files/bash-4.3-compound-array-empty-value.patch,
+ -files/bash-4.3-debug-trap.patch, -files/bash-4.3-extglob-skipname.patch,
+ -files/bash-4.3-jobs-exit.patch, -files/bash-4.3-parse-ansi-expand.patch:
+ Bump to latest official patch release.
*bash-4.3-r3 (28 Mar 2014)
diff --git a/app-shells/bash/bash-4.3-r3.ebuild b/app-shells/bash/bash-4.3_p8.ebuild
index df77a5657db1..cf20b7e155cf 100644
--- a/app-shells/bash/bash-4.3-r3.ebuild
+++ b/app-shells/bash/bash-4.3_p8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3-r3.ebuild,v 1.1 2014/03/28 02:10:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3_p8.ebuild,v 1.1 2014/03/31 07:00:51 polynomial-c Exp $
EAPI="4"
@@ -83,13 +83,8 @@ src_prepare() {
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/*
- epatch "${FILESDIR}"/${P}-debug-trap.patch
- epatch "${FILESDIR}"/${P}-jobs-exit.patch
- epatch "${FILESDIR}"/${P}-parse-ansi-expand.patch
- epatch "${FILESDIR}"/${P}-pcomplete-dequote.patch
- epatch "${FILESDIR}"/${P}-extglob-skipname.patch
- epatch "${FILESDIR}"/${P}-compound-array-empty-value.patch
- epatch "${FILESDIR}"/${P}-input-line-realloc.patch
+ epatch "${FILESDIR}"/${PN}-4.3-pcomplete-dequote.patch
+ epatch "${FILESDIR}"/${PN}-4.3-input-line-realloc.patch
epatch_user
}
diff --git a/app-shells/bash/files/bash-4.3-compound-array-empty-value.patch b/app-shells/bash/files/bash-4.3-compound-array-empty-value.patch
deleted file mode 100644
index 46ffa15f3e8b..000000000000
--- a/app-shells/bash/files/bash-4.3-compound-array-empty-value.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-*** ../bash-4.3/arrayfunc.c 2013-08-02 16:19:59.000000000 -0400
---- arrayfunc.c 2014-03-18 11:08:15.000000000 -0400
-***************
-*** 598,601 ****
---- 598,606 ----
- {
- val = expand_assignment_string_to_string (val, 0);
-+ if (val == 0)
-+ {
-+ val = (char *)xmalloc (1);
-+ val[0] = '\0'; /* like do_assignment_internal */
-+ }
- free_val = 1;
- }
diff --git a/app-shells/bash/files/bash-4.3-debug-trap.patch b/app-shells/bash/files/bash-4.3-debug-trap.patch
deleted file mode 100644
index 9f8d5d73af32..000000000000
--- a/app-shells/bash/files/bash-4.3-debug-trap.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-fix from upstream
-
-https://lists.gnu.org/archive/html/bug-bash/2014-02/msg00090.html
-
-*** ../bash-4.3/trap.c 2014-02-05 10:03:21.000000000 -0500
---- trap.c 2014-02-28 09:51:43.000000000 -0500
-***************
-*** 921,925 ****
-
- #if defined (JOB_CONTROL)
-! save_pipeline (1); /* XXX only provides one save level */
- #endif
-
---- 921,926 ----
-
- #if defined (JOB_CONTROL)
-! if (sig != DEBUG_TRAP) /* run_debug_trap does this */
-! save_pipeline (1); /* XXX only provides one save level */
- #endif
-
-***************
-*** 941,945 ****
-
- #if defined (JOB_CONTROL)
-! restore_pipeline (1);
- #endif
-
---- 942,947 ----
-
- #if defined (JOB_CONTROL)
-! if (sig != DEBUG_TRAP) /* run_debug_trap does this */
-! restore_pipeline (1);
- #endif
-
diff --git a/app-shells/bash/files/bash-4.3-extglob-skipname.patch b/app-shells/bash/files/bash-4.3-extglob-skipname.patch
deleted file mode 100644
index 9461d697da3e..000000000000
--- a/app-shells/bash/files/bash-4.3-extglob-skipname.patch
+++ /dev/null
@@ -1,156 +0,0 @@
-*** ../bash-4.3/lib/glob/gmisc.c 2013-10-28 14:45:25.000000000 -0400
---- lib/glob/gmisc.c 2014-03-19 09:16:08.000000000 -0400
-***************
-*** 211,214 ****
---- 211,215 ----
- case '!':
- case '@':
-+ case '?':
- return (pat[1] == LPAREN);
- default:
-*** ../bash-4.3/lib/glob/glob.c 2014-01-31 21:43:51.000000000 -0500
---- lib/glob/glob.c 2014-03-20 09:01:26.000000000 -0400
-***************
-*** 180,202 ****
- int flags;
- {
-! char *pp, *pe, *t;
-! int n, r;
-
- pp = pat + 2;
-! pe = pp + strlen (pp) - 1; /*(*/
-! if (*pe != ')')
-! return 0;
-! if ((t = strchr (pp, '|')) == 0) /* easy case first */
- {
- *pe = '\0';
- r = skipname (pp, dname, flags); /*(*/
- *pe = ')';
- return r;
- }
- while (t = glob_patscan (pp, pe, '|'))
- {
- n = t[-1];
- t[-1] = '\0';
- r = skipname (pp, dname, flags);
- t[-1] = n;
- if (r == 0) /* if any pattern says not skip, we don't skip */
---- 180,215 ----
- int flags;
- {
-! char *pp, *pe, *t, *se;
-! int n, r, negate;
-
-+ negate = *pat == '!';
- pp = pat + 2;
-! se = pp + strlen (pp) - 1; /* end of string */
-! pe = glob_patscan (pp, se, 0); /* end of extglob pattern (( */
-! /* we should check for invalid extglob pattern here */
-! /* if pe != se we have more of the pattern at the end of the extglob
-! pattern. Check the easy case first ( */
-! if (pe == se && *pe == ')' && (t = strchr (pp, '|')) == 0)
- {
- *pe = '\0';
-+ #if defined (HANDLE_MULTIBYTE)
-+ r = mbskipname (pp, dname, flags);
-+ #else
- r = skipname (pp, dname, flags); /*(*/
-+ #endif
- *pe = ')';
- return r;
- }
-+
-+ /* check every subpattern */
- while (t = glob_patscan (pp, pe, '|'))
- {
- n = t[-1];
- t[-1] = '\0';
-+ #if defined (HANDLE_MULTIBYTE)
-+ r = mbskipname (pp, dname, flags);
-+ #else
- r = skipname (pp, dname, flags);
-+ #endif
- t[-1] = n;
- if (r == 0) /* if any pattern says not skip, we don't skip */
-***************
-*** 205,219 ****
- } /*(*/
-
-! if (pp == pe) /* glob_patscan might find end of pattern */
- return r;
-
-! *pe = '\0';
-! # if defined (HANDLE_MULTIBYTE)
-! r = mbskipname (pp, dname, flags); /*(*/
-! # else
-! r = skipname (pp, dname, flags); /*(*/
-! # endif
-! *pe = ')';
-! return r;
- }
- #endif
---- 218,227 ----
- } /*(*/
-
-! /* glob_patscan might find end of pattern */
-! if (pp == se)
- return r;
-
-! /* but if it doesn't then we didn't match a leading dot */
-! return 0;
- }
- #endif
-***************
-*** 278,289 ****
- {
- #if EXTENDED_GLOB
-! wchar_t *pp, *pe, *t, n;
-! int r;
-
- pp = pat + 2;
-! pe = pp + wcslen (pp) - 1; /*(*/
-! if (*pe != L')')
-! return 0;
-! if ((t = wcschr (pp, L'|')) == 0)
- {
- *pe = L'\0';
---- 286,298 ----
- {
- #if EXTENDED_GLOB
-! wchar_t *pp, *pe, *t, n, *se;
-! int r, negate;
-
-+ negate = *pat == L'!';
- pp = pat + 2;
-! se = pp + wcslen (pp) - 1; /*(*/
-! pe = glob_patscan_wc (pp, se, 0);
-!
-! if (pe == se && *pe == ')' && (t = wcschr (pp, L'|')) == 0)
- {
- *pe = L'\0';
-***************
-*** 292,295 ****
---- 301,306 ----
- return r;
- }
-+
-+ /* check every subpattern */
- while (t = glob_patscan_wc (pp, pe, '|'))
- {
-***************
-*** 306,313 ****
- return r;
-
-! *pe = L'\0';
-! r = wchkname (pp, dname); /*(*/
-! *pe = L')';
-! return r;
- #else
- return (wchkname (pat, dname));
---- 317,322 ----
- return r;
-
-! /* but if it doesn't then we didn't match a leading dot */
-! return 0;
- #else
- return (wchkname (pat, dname));
diff --git a/app-shells/bash/files/bash-4.3-jobs-exit.patch b/app-shells/bash/files/bash-4.3-jobs-exit.patch
deleted file mode 100644
index 96cc3b19cd1f..000000000000
--- a/app-shells/bash/files/bash-4.3-jobs-exit.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-fix from upstream
-
-https://lists.gnu.org/archive/html/bug-bash/2014-03/msg00017.html
-
-*** ../bash-4.3/jobs.c 2014-01-10 09:05:34.000000000 -0500
---- jobs.c 2014-03-02 18:05:09.000000000 -0500
-***************
-*** 4375,4379 ****
- end_job_control ()
- {
-! if (interactive_shell) /* XXX - should it be interactive? */
- {
- terminate_stopped_jobs ();
---- 4375,4379 ----
- end_job_control ()
- {
-! if (interactive_shell || job_control) /* XXX - should it be just job_control? */
- {
- terminate_stopped_jobs ();
diff --git a/app-shells/bash/files/bash-4.3-parse-ansi-expand.patch b/app-shells/bash/files/bash-4.3-parse-ansi-expand.patch
deleted file mode 100644
index 26eda37fe385..000000000000
--- a/app-shells/bash/files/bash-4.3-parse-ansi-expand.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-fix from upstream
-
-https://lists.gnu.org/archive/html/bug-bash/2014-03/msg00040.html
-
-*** ../bash-4.3/parse.y 2014-02-11 09:42:10.000000000 -0500
---- parse.y 2014-03-07 20:57:15.000000000 -0500
-***************
-*** 3399,3403 ****
- unescaped double-quotes or single-quotes, if any, shall occur." */
- /* This was changed in Austin Group Interp 221 */
-! if MBTEST(posixly_correct && shell_compatibility_level > 41 && dolbrace_state != DOLBRACE_QUOTE && (flags & P_DQUOTE) && (flags & P_DOLBRACE) && ch == '\'')
- continue;
-
---- 3399,3403 ----
- unescaped double-quotes or single-quotes, if any, shall occur." */
- /* This was changed in Austin Group Interp 221 */
-! if MBTEST(posixly_correct && shell_compatibility_level > 41 && dolbrace_state != DOLBRACE_QUOTE && dolbrace_state != DOLBRACE_QUOTE2 && (flags & P_DQUOTE) && (flags & P_DOLBRACE) && ch == '\'')
- continue;
-