summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-13 13:45:25 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-13 13:45:25 +0000
commitabf9b07be250858adc9c42e35aa5c793f0f77dbe (patch)
tree4c62a4d11c6265d119b002d42d0e2c68879054b0 /app-shells
parentUSE fixees (diff)
downloadgentoo-2-abf9b07be250858adc9c42e35aa5c793f0f77dbe.tar.gz
gentoo-2-abf9b07be250858adc9c42e35aa5c793f0f77dbe.tar.bz2
gentoo-2-abf9b07be250858adc9c42e35aa5c793f0f77dbe.zip
Added USE perl for optional html doc generation
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/tcsh/files/digest-tcsh-6.10-r11
-rw-r--r--app-shells/tcsh/tcsh-6.10-r1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-shells/tcsh/files/digest-tcsh-6.10-r1 b/app-shells/tcsh/files/digest-tcsh-6.10-r1
new file mode 100644
index 000000000000..a75616c35624
--- /dev/null
+++ b/app-shells/tcsh/files/digest-tcsh-6.10-r1
@@ -0,0 +1 @@
+MD5 f459c423074d85dfaa55439eb908a053 tcsh-6.10.tar.gz
diff --git a/app-shells/tcsh/tcsh-6.10-r1.ebuild b/app-shells/tcsh/tcsh-6.10-r1.ebuild
new file mode 100644
index 000000000000..9545a62692b0
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.10-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.10-r1.ebuild,v 1.1 2001/04/13 13:45:25 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}.00
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+#ugh, astron.com doesn't support passive ftp... maybe another source?
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${A}"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ perl? ( sys-devel/perl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff
+}
+
+src_compile() {
+
+ try ./configure --prefix=/ --mandir=/usr/share/man --host=${CHOST}
+ try make
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install install.man
+ if [ "`use perl`" ]
+ then
+ try perl tcsh.man2html
+ docinto html
+ dodoc tcsh.html/*.html
+ fi
+ dosym tcsh /bin/csh
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+}
+
+
+