summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-07 06:10:35 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-07 06:10:35 +0000
commita5c2040140027e1f40c426d5a6e5cb836d8f6a6b (patch)
tree84bc61ddda6167e4f47dd06f4dafd4888a17de48 /app-shells
parentold (diff)
downloadgentoo-2-a5c2040140027e1f40c426d5a6e5cb836d8f6a6b.tar.gz
gentoo-2-a5c2040140027e1f40c426d5a6e5cb836d8f6a6b.tar.bz2
gentoo-2-a5c2040140027e1f40c426d5a6e5cb836d8f6a6b.zip
Misc cleanups and add support for bash modules.
(Portage version: 2.1.3)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/bash-3.2_p17-r1.ebuild169
-rw-r--r--app-shells/bash/files/bash-3.2-loadables.patch239
-rw-r--r--app-shells/bash/files/digest-bash-3.2_p17-r154
4 files changed, 469 insertions, 1 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 5992a0508de3..654b023a34ae 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.155 2007/07/24 16:07:29 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.156 2007/08/07 06:10:35 vapier Exp $
+
+*bash-3.2_p17-r1 (07 Aug 2007)
+
+ 07 Aug 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/bash-3.2-loadables.patch, +bash-3.2_p17-r1.ebuild:
+ Misc cleanups and add support for bash modules.
24 Jul 2007; Steve Dibb <beandog@gentoo.org> bash-3.2_p17.ebuild:
amd64 stable, bug 186168
diff --git a/app-shells/bash/bash-3.2_p17-r1.ebuild b/app-shells/bash/bash-3.2_p17-r1.ebuild
new file mode 100644
index 000000000000..4917a0582dc5
--- /dev/null
+++ b/app-shells/bash/bash-3.2_p17-r1.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p17-r1.ebuild,v 1.1 2007/08/07 06:10:35 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+# Official patchlevel
+# See ftp://ftp.cwru.edu/pub/bash/bash-3.2-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+READLINE_VER=5.2
+READLINE_PLEVEL=0 # both readline patches are also released as bash patches
+
+DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
+ ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz
+ $(for ((i=1; i<=PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ done)
+ $(for ((i=1; i<=READLINE_PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${READLINE_VER} ${READLINE_VER/\.} ${i}
+ printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${READLINE_VER} ${READLINE_VER/\.} ${i}
+ done)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="afs bashlogger nls plugins vanilla"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if is-flag -malign-double ; then #7332
+ eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
+ eerror "as it breaks LFS (struct stat64) on x86."
+ die "remove -malign-double from your CFLAGS mr ricer"
+ fi
+}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd "${S}"
+
+ # Include official patches
+ local i
+ for ((i=1; i<=PLEVEL; i++)); do
+ epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
+ done
+ cd lib/readline
+ for ((i=1; i<=READLINE_PLEVEL; i++)); do
+ epatch "${DISTDIR}"/readline${READLINE_VER/\.}-$(printf '%03d' ${i})
+ done
+ cd ../..
+
+ if ! use vanilla ; then
+ epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-3.2-loadables.patch
+
+ # Fix process substitution on BSD.
+ epatch "${FILESDIR}"/${PN}-3.2-process-subst.patch
+
+ epatch "${FILESDIR}"/${PN}-3.2-ulimit.patch
+ # Don't barf on handled signals in scripts
+ epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
+ epatch "${FILESDIR}"/${PN}-3.2-dev-fd-test-as-user.patch #131875
+ # Log bash commands to syslog #91327
+ if use bashlogger ; then
+ echo
+ ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
+ ewarn "This will log ALL output you enter into the shell, you have been warned."
+ ebeep
+ epause
+ epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
+ fi
+ fi
+
+ epatch "${FILESDIR}"/${PN}-3.0-configs.patch
+}
+
+src_compile() {
+ local myconf=
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #myconf="${myconf} $(use_with !readline installed-readline)"
+ myconf="${myconf} --without-installed-readline"
+
+ # Don't even think about building this statically without
+ # reading Bug 7714 first. If you still build it statically,
+ # don't come crying to use with bugs ;).
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses
+ myconf="${myconf} --with-curses"
+
+ use plugins && append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
+ econf \
+ $(use_with afs) \
+ --disable-profiling \
+ --without-gnu-malloc \
+ ${myconf} || die
+ emake || die "make failed"
+
+ if use plugins ; then
+ emake -C examples/loadables all others || die
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodir /bin
+ mv "${D}"/usr/bin/bash "${D}"/bin/ || die
+ dosym bash /bin/rbash
+
+ insinto /etc/bash
+ doins "${FILESDIR}"/{bashrc,bash_logout}
+ insinto /etc/skel
+ for f in bash{_logout,_profile,rc} ; do
+ newins "${FILESDIR}"/dot-${f} .${f}
+ done
+
+ sed -i -e "s:#${USERLAND}#@::" "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
+ sed -i -e '/#@/d' "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
+
+ if use plugins ; then
+ exeinto /usr/$(get_libdir)/bash
+ doexe $(echo examples/loadables/*.o | sed 's:\.o::g') || die
+ fi
+
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
+ dosym bash.info /usr/share/info/bashref.info
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
+ mkdir -p "${ROOT}"/etc/bash
+ mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
+ fi
+
+ # our bash_logout is just a place holder so dont
+ # force users to go through etc-update all the time
+ if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
+ rm -f "${D}"/etc/bash/bash_logout
+ fi
+
+ # If /bin/sh does not exist or is bash, then provide it
+ # Otherwise leave it alone
+ if [[ ! -e ${ROOT}/bin/sh ]] ; then
+ ln -s bash "${ROOT}"/bin/sh
+ elif [[ -L ${ROOT}/bin/sh ]] ; then
+ case $(readlink "${ROOT}"/bin/sh) in
+ bash|/bin/bash) cp -pPR "${ROOT}"/bin/sh "${D}"/bin/ ;;
+ esac
+ fi
+}
diff --git a/app-shells/bash/files/bash-3.2-loadables.patch b/app-shells/bash/files/bash-3.2-loadables.patch
new file mode 100644
index 000000000000..cd0e1e1a8e9e
--- /dev/null
+++ b/app-shells/bash/files/bash-3.2-loadables.patch
@@ -0,0 +1,239 @@
+--- bash-3.2/examples/loadables/basename.c
++++ bash-3.2/examples/loadables/basename.c
+@@ -11,6 +11,7 @@
+ #include <stdio.h>
+ #include "builtins.h"
+ #include "shell.h"
++#include "common.h"
+
+ basename_builtin (list)
+ WORD_LIST *list;
+--- bash-3.2/examples/loadables/cut.c
++++ bash-3.2/examples/loadables/cut.c
+@@ -63,6 +63,7 @@
+ #include "builtins.h"
+ #include "shell.h"
+ #include "bashgetopt.h"
++#include "common.h"
+
+ #if !defined (errno)
+ extern int errno;
+--- bash-3.2/examples/loadables/dirname.c
++++ bash-3.2/examples/loadables/dirname.c
+@@ -11,6 +11,7 @@
+ #include <stdio.h>
+ #include "builtins.h"
+ #include "shell.h"
++#include "common.h"
+
+ dirname_builtin (list)
+ WORD_LIST *list;
+--- bash-3.2/examples/loadables/finfo.c
++++ bash-3.2/examples/loadables/finfo.c
+@@ -12,6 +12,7 @@
+ #include <pwd.h>
+ #include <grp.h>
+ #include <errno.h>
++#include <time.h>
+
+ #include "bashansi.h"
+ #include "shell.h"
+--- bash-3.2/examples/loadables/head.c
++++ bash-3.2/examples/loadables/head.c
+@@ -21,6 +21,7 @@
+ #include "builtins.h"
+ #include "shell.h"
+ #include "bashgetopt.h"
++#include "common.h"
+
+ #if !defined (errno)
+ extern int errno;
+--- bash-3.2/examples/loadables/ln.c
++++ bash-3.2/examples/loadables/ln.c
+@@ -18,6 +18,7 @@
+ #include "builtins.h"
+ #include "shell.h"
+ #include "bashgetopt.h"
++#include "common.h"
+
+ #if !defined (errno)
+ extern int errno;
+--- bash-3.2/examples/loadables/logname.c
++++ bash-3.2/examples/loadables/logname.c
+@@ -11,6 +11,7 @@
+
+ #include "builtins.h"
+ #include "shell.h"
++#include "common.h"
+
+ #if !defined (errno)
+ extern int errno;
+--- bash-3.2/examples/loadables/mkdir.c
++++ bash-3.2/examples/loadables/mkdir.c
+@@ -16,6 +16,7 @@
+ #include "builtins.h"
+ #include "shell.h"
+ #include "bashgetopt.h"
++#include "common.h"
+
+ #if !defined (errno)
+ extern int errno;
+--- bash-3.2/examples/loadables/pathchk.c
++++ bash-3.2/examples/loadables/pathchk.c
+@@ -45,6 +45,7 @@
+ #include "stdc.h"
+ #include "bashgetopt.h"
+ #include "maxpath.h"
++#include "common.h"
+
+ #if !defined (errno)
+ extern int errno;
+--- bash-3.2/examples/loadables/print.c
++++ bash-3.2/examples/loadables/print.c
+@@ -17,6 +17,8 @@
+ #include "builtins.h"
+ #include "stdc.h"
+ #include "bashgetopt.h"
++#include "builtext.h"
++#include "common.h"
+
+ #if !defined (errno)
+ extern int errno;
+--- bash-3.2/examples/loadables/printenv.c
++++ bash-3.2/examples/loadables/printenv.c
+@@ -11,6 +11,7 @@
+ #include "builtins.h"
+ #include "shell.h"
+ #include "bashgetopt.h"
++#include "common.h"
+
+ extern char **export_env;
+
+--- bash-3.2/examples/loadables/push.c
++++ bash-3.2/examples/loadables/push.c
+@@ -11,6 +11,7 @@
+ #include "shell.h"
+ #include "jobs.h"
+ #include "bashgetopt.h"
++#include "common.h"
+
+ #ifndef errno
+ extern int errno;
+--- bash-3.2/examples/loadables/realpath.c
++++ bash-3.2/examples/loadables/realpath.c
+@@ -34,6 +34,7 @@
+ #include "builtins.h"
+ #include "shell.h"
+ #include "bashgetopt.h"
++#include "common.h"
+
+ #ifndef errno
+ extern int errno;
+@@ -67,14 +68,14 @@
+ vflag = 1;
+ break;
+ default:
+- usage();
++ builtin_usage();
+ }
+ }
+
+ list = loptend;
+
+ if (list == 0)
+- usage();
++ builtin_usage();
+
+ for (es = EXECUTION_SUCCESS; list; list = list->next) {
+ p = list->word->word;
+--- bash-3.2/examples/loadables/rmdir.c
++++ bash-3.2/examples/loadables/rmdir.c
+@@ -8,6 +8,7 @@
+ #include <errno.h>
+ #include "builtins.h"
+ #include "shell.h"
++#include "common.h"
+
+ #if !defined (errno)
+ extern int errno;
+--- bash-3.2/examples/loadables/sleep.c
++++ bash-3.2/examples/loadables/sleep.c
+@@ -27,6 +27,7 @@
+
+ #include "shell.h"
+ #include "builtins.h"
++#include "common.h"
+
+ #define RETURN(x) \
+ do { \
+--- bash-3.2/examples/loadables/tee.c
++++ bash-3.2/examples/loadables/tee.c
+@@ -22,6 +22,7 @@
+ #include "builtins.h"
+ #include "shell.h"
+ #include "bashgetopt.h"
++#include "common.h"
+
+ #if !defined (errno)
+ extern int errno;
+--- bash-3.2/examples/loadables/truefalse.c
++++ bash-3.2/examples/loadables/truefalse.c
+@@ -1,5 +1,7 @@
+ /* true and false builtins */
+
++#include <config.h>
++
+ #include "bashtypes.h"
+ #include "shell.h"
+ #include "builtins.h"
+--- bash-3.2/examples/loadables/tty.c
++++ bash-3.2/examples/loadables/tty.c
+@@ -8,6 +8,7 @@
+ #include "builtins.h"
+ #include "shell.h"
+ #include "bashgetopt.h"
++#include "common.h"
+
+ extern char *ttyname ();
+
+--- bash-3.2/examples/loadables/uname.c
++++ bash-3.2/examples/loadables/uname.c
+@@ -27,6 +27,7 @@
+ #include "builtins.h"
+ #include "shell.h"
+ #include "bashgetopt.h"
++#include "common.h"
+
+ #define FLAG_SYSNAME 0x01 /* -s */
+ #define FLAG_NODENAME 0x02 /* -n */
+--- bash-3.2/examples/loadables/unlink.c
++++ bash-3.2/examples/loadables/unlink.c
+@@ -14,6 +14,7 @@
+
+ #include "builtins.h"
+ #include "shell.h"
++#include "common.h"
+
+ #ifndef errno
+ extern int errno;
+--- bash-3.2/examples/loadables/whoami.c
++++ bash-3.2/examples/loadables/whoami.c
+@@ -8,6 +8,7 @@
+ #include "builtins.h"
+ #include "shell.h"
+ #include "bashgetopt.h"
++#include "common.h"
+
+ whoami_builtin (list)
+ WORD_LIST *list;
+--- bash-3.2/examples/loadables/Makefile.in
++++ bash-3.2/examples/loadables/Makefile.in
+@@ -68,7 +68,7 @@
+ SHOBJ_CC = @SHOBJ_CC@
+ SHOBJ_CFLAGS = @SHOBJ_CFLAGS@
+ SHOBJ_LD = @SHOBJ_LD@
+-SHOBJ_LDFLAGS = @SHOBJ_LDFLAGS@
++SHOBJ_LDFLAGS = @SHOBJ_LDFLAGS@ @LDFLAGS@
+ SHOBJ_XLDFLAGS = @SHOBJ_XLDFLAGS@
+ SHOBJ_LIBS = @SHOBJ_LIBS@
+ SHOBJ_STATUS = @SHOBJ_STATUS@
diff --git a/app-shells/bash/files/digest-bash-3.2_p17-r1 b/app-shells/bash/files/digest-bash-3.2_p17-r1
new file mode 100644
index 000000000000..4bd94e31212a
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-3.2_p17-r1
@@ -0,0 +1,54 @@
+MD5 00bfa16d58e034e3c2aa27f390390d30 bash-3.2.tar.gz 2529838
+RMD160 a73f790817d98be375a36def567737498e33aaf1 bash-3.2.tar.gz 2529838
+SHA256 26c99025b59e30779300b68adb764f824974d267a4d7cc1b347d14a2393f9fb4 bash-3.2.tar.gz 2529838
+MD5 d8e10c754f477e3f3a581af566b89301 bash32-001 1539
+RMD160 633f6eb6b2b48345234c442b835abb94d10e0dad bash32-001 1539
+SHA256 beda60ce6186fafa36cd0a98db9ced42cff68daee4342cca73167fb0f2f43eaa bash32-001 1539
+MD5 d38a5288b2f0ea6c9ac76b66cc74ef7d bash32-002 1524
+RMD160 5d0f0dab859197784b15c683d54e7a505a8434c3 bash32-002 1524
+SHA256 a0ca49a3c47678ad074c990bdc871fcec680749b7f04f2def6527f04c589c40a bash32-002 1524
+MD5 0b90d37911827d8cb95f3b4353cc225e bash32-003 4599
+RMD160 efdcb4f8d6c800b5a3dab7bae37f95861bf186d8 bash32-003 4599
+SHA256 7ec9e5e7e402e43b12bfd3a9237f4f171029fc7f58e59335abf3ccb455a5a84d bash32-003 4599
+MD5 8062f3a59631f58d78b180d83759b68a bash32-004 2585
+RMD160 0ec49a8b414f283aefc00c5ee63de913c96a7a21 bash32-004 2585
+SHA256 3de0938673637089c3b0f0f355de377bb2be2d3fca68053dda267ca11b5998f2 bash32-004 2585
+MD5 585b5943fadf0875ced243b245adde58 bash32-005 5910
+RMD160 8597b22136a294dc2cf1103a5c9ab100b75d16f5 bash32-005 5910
+SHA256 e7fecdecb12320cd6fe9aca83fab1828b76aeb5313b991883764cb9139d845b7 bash32-005 5910
+MD5 1d5732e01ea938aeed42f3def131fa4d bash32-006 1298
+RMD160 d8193a69956064e9fb4e64e13132b1c1b2cb8d43 bash32-006 1298
+SHA256 8f14f81ced32bc057bc10abf6842f4a5ac172816631f2b87a5a3be4f01c0847d bash32-006 1298
+MD5 dcd0cc5d801607827f7c851e72b0eabc bash32-007 1375
+RMD160 332cb936851e156c9231236541b78e651fd4ab5a bash32-007 1375
+SHA256 6863a712e5a68eccfb77162a9f947ffd80af648f0124c38f795ebba2be12eff8 bash32-007 1375
+MD5 bb3c7dd11198c0ab93d0e960bebf6256 bash32-008 1302
+RMD160 44558cabad6b05a53217c17419c2477a29ebe7da bash32-008 1302
+SHA256 ccf303b4d199d89d5efc659235f8a645376e86d294260dda4becbb61ec06667b bash32-008 1302
+MD5 434a6f29b0ca5f1ab784b2437ae8eaed bash32-009 1882
+RMD160 5a20bc86d04a156cdbcb22f36b6c68c7318e9bab bash32-009 1882
+SHA256 ef30c579419106b4b4a2d0064ef7e57ceee6cdf657f4ccd7b89c8e4fd70560d8 bash32-009 1882
+MD5 2efff04dd246fcf63bd4b99f77c9a081 bash32-010 6293
+RMD160 51b4c18b7939f663ee72861a522d7fb1d1afaa30 bash32-010 6293
+SHA256 bb7df9fefe88d62ee371353edf62402a667cffba6ea202aa1c8b220308a0c612 bash32-010 6293
+MD5 1dd104342f6920dfaf5efb3131e922e0 bash32-011 4776
+RMD160 030404aabf09b8aa295f241d1d96bdba12a1f8cb bash32-011 4776
+SHA256 85bf656cfc49b1447b061341a4b1cb93ba89a41d8d1699a65aa971d1853ba472 bash32-011 4776
+MD5 4f24b696ab78bdfae4f9cb7eb59b835d bash32-012 2555
+RMD160 c2011d3d8a8004acd58112568e611511f9bde5ff bash32-012 2555
+SHA256 45ef4ad98f2f218aa3acec15842ae1b833769c1dbe2f90c9bba00bbe4949fc43 bash32-012 2555
+MD5 7c40addbf1187a26ae1c8373ed383442 bash32-013 1852
+RMD160 4ddfeafea7e451376c56d17836079a963298df06 bash32-013 1852
+SHA256 9fbf893c383f45d25e5bc5c9eae8d2b349521f288945b3bd21c781784b81f693 bash32-013 1852
+MD5 28e88c9f8679e99ac590d4a4a8227c56 bash32-014 8141
+RMD160 cf47a705b00039bdc2cc5cd37dd20a58b029af33 bash32-014 8141
+SHA256 62bb1a4d70f6f7938ca70a6aa7fe6f4b377ab5f450c7756b22b41de3bbd98ed6 bash32-014 8141
+MD5 7c17d29675bd0d49470f162774385f80 bash32-015 2293
+RMD160 6535eb24b8d30ce9756b1e7c0d21c0946b1d354e bash32-015 2293
+SHA256 de40425e83628eb7431f39340ac09b42b5fcf484a565352851961b3e917d8771 bash32-015 2293
+MD5 a1edaa98b4449fe2205fa75448b7b105 bash32-016 1620
+RMD160 cfded7fc1b9bc328c4fb1167c536fcbd28756615 bash32-016 1620
+SHA256 7abf66bbba3ebd6b6428190f3ebca59abdc0bfa3957f1a725489de7391c2d9f1 bash32-016 1620
+MD5 889ed119bbf9d363660b9a0127f35efa bash32-017 2611
+RMD160 7366ea8c0109b41a9bf5a369aa5fa56f4b8792f1 bash32-017 2611
+SHA256 951aa2a07b38db8eea8e7368d3ac36af60af7f5ade455215006229ce3815dfe0 bash32-017 2611