summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-02 16:17:49 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-02 16:17:49 +0000
commit7db25ab95e79025d3911d0d71a331c098a1a5988 (patch)
tree5365f8d265e326ff94fec752318ad328aa6cd5c7 /app-shells
parentMask gstreamer. (diff)
downloadgentoo-2-7db25ab95e79025d3911d0d71a331c098a1a5988.tar.gz
gentoo-2-7db25ab95e79025d3911d0d71a331c098a1a5988.tar.bz2
gentoo-2-7db25ab95e79025d3911d0d71a331c098a1a5988.zip
dont export CLICOLOR for everyone as it is BSD-only cruft and drop USE=build
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-3.1_p17.ebuild21
-rw-r--r--app-shells/bash/files/dot-bashrc5
2 files changed, 12 insertions, 14 deletions
diff --git a/app-shells/bash/bash-3.1_p17.ebuild b/app-shells/bash/bash-3.1_p17.ebuild
index 792a2de6859c..09738e52624a 100644
--- a/app-shells/bash/bash-3.1_p17.ebuild
+++ b/app-shells/bash/bash-3.1_p17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p17.ebuild,v 1.3 2006/08/01 19:59:06 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p17.ebuild,v 1.4 2006/08/02 16:17:49 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -33,7 +33,7 @@ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="afs nls build bashlogger"
+IUSE="afs nls bashlogger"
DEPEND=">=sys-libs/ncurses-5.2-r2"
@@ -126,17 +126,16 @@ src_install() {
newins "${FILESDIR}"/dot-${f} .${f}
done
- if use userland_GNU; then
- sed -i -e 's:^#GNU#::' "${D}/etc/skel/.bashrc"
+ if use userland_GNU ; then
+ sed -i -e 's:^#GNU#@::' "${D}"/etc/skel/.bashrc
+ elif use userland_BSD ; then
+ sed -i -e 's:^#BSD#@::' "${D}"/etc/skel/.bashrc
fi
+ sed -i -e '/#@/d' "${D}"/etc/skel/.bashrc
- if use build ; then
- rm -rf "${D}"/usr
- else
- doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
- dosym bash.info.gz /usr/share/info/bashref.info.gz
- fi
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
+ dosym bash.info.gz /usr/share/info/bashref.info.gz
}
pkg_preinst() {
diff --git a/app-shells/bash/files/dot-bashrc b/app-shells/bash/files/dot-bashrc
index 0191f878323c..0211a6b72b9e 100644
--- a/app-shells/bash/files/dot-bashrc
+++ b/app-shells/bash/files/dot-bashrc
@@ -21,9 +21,8 @@ elif [[ -f /etc/DIR_COLORS ]] ; then
eval $(dircolors -b /etc/DIR_COLORS)
fi
-export CLICOLOR=1 # For FreeBSD
-
-#GNU#alias ls='ls --color=auto'
+#BSD#@export CLICOLOR=1
+#GNU#@alias ls='ls --color=auto'
alias grep='grep --colour=auto'
# Change the window title of X terminals