summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-02-21 20:29:09 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-02-21 20:29:09 +0000
commit638b41ef67e7930f9d073386d7e15e42a6d87d0a (patch)
tree2d63f1b0234712904c3dfe779118c205e4cb65c2 /app-shells
parentClean up old ebuilds/files. (diff)
downloadgentoo-2-638b41ef67e7930f9d073386d7e15e42a6d87d0a.tar.gz
gentoo-2-638b41ef67e7930f9d073386d7e15e42a6d87d0a.tar.bz2
gentoo-2-638b41ef67e7930f9d073386d7e15e42a6d87d0a.zip
Now use the 'eselect way' for gentoo-bashcomp. This is desired for future development of the gentoo bash-completion modules
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/gentoo-bashcomp/ChangeLog11
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20080521-r1.ebuild33
2 files changed, 42 insertions, 2 deletions
diff --git a/app-shells/gentoo-bashcomp/ChangeLog b/app-shells/gentoo-bashcomp/ChangeLog
index d43536a455ad..4038952a5351 100644
--- a/app-shells/gentoo-bashcomp/ChangeLog
+++ b/app-shells/gentoo-bashcomp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/gentoo-bashcomp
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.20 2008/05/21 19:00:17 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.21 2009/02/21 20:29:09 darkside Exp $
+
+*gentoo-bashcomp-20080521-r1 (21 Feb 2009)
+
+ 21 Feb 2009; Jeremy Olexa <darkside@gentoo.org>
+ +gentoo-bashcomp-20080521-r1.ebuild:
+ Now use the 'eselect way' for gentoo-bashcomp. This is desired for future
+ development of the gentoo bash-completion modules
*gentoo-bashcomp-20080521 (21 May 2008)
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20080521-r1.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20080521-r1.ebuild
new file mode 100644
index 000000000000..6a4659723692
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20080521-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/gentoo-bashcomp-20080521-r1.ebuild,v 1.1 2009/02/21 20:29:09 darkside Exp $
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="app-shells/bash-completion"
+
+src_install() {
+ insinto /usr/share/bash-completion
+ doins gentoo || die "doins failed"
+ dodoc AUTHORS ChangeLog NEWS TODO
+}
+
+pkg_postinst() {
+ # can't use bash-completion.eclass.
+ elog "To enable command-line completion for ${PN}, run:"
+ elog
+ elog " eselect bashcomp enable gentoo"
+ elog
+ elog "to install locally, or"
+ elog
+ elog " eselect bashcomp enable --global gentoo"
+ elog
+ elog "to install system-wide."
+}