summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
commitaa6a19ea25bbed130cef956ef1bd6005cd95bd7e (patch)
tree22f7a92ee079fc4d76db2128cc7ee5a31a028184 /app-shells/sash
parentUpdate (diff)
downloadgentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.tar.gz
gentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.tar.bz2
gentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.zip
dependencie, fhs and use fixes
Diffstat (limited to 'app-shells/sash')
-rw-r--r--app-shells/sash/sash-3.4-r3.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/app-shells/sash/sash-3.4-r3.ebuild b/app-shells/sash/sash-3.4-r3.ebuild
index 005b2e3f1139..6189d27cd41e 100644
--- a/app-shells/sash/sash-3.4-r3.ebuild
+++ b/app-shells/sash/sash-3.4-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r3.ebuild,v 1.1 2001/04/13 13:28:45 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r3.ebuild,v 1.2 2001/05/29 17:28:19 achim Exp $
P=sash-3.4
A="${P}.tar.gz sash-3.x-readline.diff.gz"
@@ -12,7 +12,10 @@ SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 )"
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
+if [ "`use static`" ] ; then
+RDEPEND=""
+fi
HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${A}"
@@ -25,8 +28,10 @@ src_unpack() {
gzip -dc ${DISTDIR}/sash-3.x-readline.diff.gz | patch -p1
cp Makefile Makefile.orig
- sed -e "s:-O3:${CFLAGS}:" \
- -e "s:-ltermcap:-lncurses:" Makefile.orig > Makefile
+ sed -e "s:-O2:${CFLAGS}:" -e "s:-ltermcap:-lncurses:" Makefile.orig > Makefile
+ else
+ cp Makefile Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" Makefile.orig > Makefile
fi
}
src_compile() {