summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-05-13 04:32:47 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-05-13 04:32:47 +0000
commit9241aa144cea295e9e1290711d71f395bad69f48 (patch)
tree4997714d41a0879b744d2754e6157e3418bcd5a1 /app-shells/rrs
parentversion bumped. This isn't stable yet and crashes on selecting the schema ta... (diff)
downloadgentoo-2-9241aa144cea295e9e1290711d71f395bad69f48.tar.gz
gentoo-2-9241aa144cea295e9e1290711d71f395bad69f48.tar.bz2
gentoo-2-9241aa144cea295e9e1290711d71f395bad69f48.zip
Initial import thanks Sven Wegener <sven.wegener@stealer.net> for the ebuild in bug #50897
Diffstat (limited to 'app-shells/rrs')
-rw-r--r--app-shells/rrs/ChangeLog11
-rw-r--r--app-shells/rrs/Manifest3
-rw-r--r--app-shells/rrs/files/1.50-include-string.h.patch10
-rw-r--r--app-shells/rrs/files/digest-rrs-1.501
-rw-r--r--app-shells/rrs/metadata.xml12
-rw-r--r--app-shells/rrs/rrs-1.50.ebuild36
6 files changed, 73 insertions, 0 deletions
diff --git a/app-shells/rrs/ChangeLog b/app-shells/rrs/ChangeLog
new file mode 100644
index 000000000000..15fc1fbbf734
--- /dev/null
+++ b/app-shells/rrs/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-shells/rrs
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rrs/ChangeLog,v 1.1 2004/05/13 04:32:47 dragonheart Exp $
+
+*rrs-1.50 (13 May 2004)
+
+ 13 May 2004; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+ +files/1.50-include-string.h.patch, +rrs-1.50.ebuild:
+ Initial import thanks Sven Wegener <sven.wegener@stealer.net> for the ebuild
+ in bug #50897
+
diff --git a/app-shells/rrs/Manifest b/app-shells/rrs/Manifest
new file mode 100644
index 000000000000..d041741706f5
--- /dev/null
+++ b/app-shells/rrs/Manifest
@@ -0,0 +1,3 @@
+MD5 b85107cee0bc28de5fda9dbf9e3bcf7a rrs-1.50.ebuild 656
+MD5 55729988ea19ac7dfc4a35622cd0d43b files/1.50-include-string.h.patch 320
+MD5 3faef8b43111fd788fee0ab7bef0fe7c files/digest-rrs-1.50 59
diff --git a/app-shells/rrs/files/1.50-include-string.h.patch b/app-shells/rrs/files/1.50-include-string.h.patch
new file mode 100644
index 000000000000..6d2440193e0e
--- /dev/null
+++ b/app-shells/rrs/files/1.50-include-string.h.patch
@@ -0,0 +1,10 @@
+--- farm9crypt.cc.orig 2004-05-13 01:16:03.393590404 +0000
++++ farm9crypt.cc 2004-05-13 01:16:13.903000361 +0000
+@@ -26,6 +26,7 @@
+ //#include <sys/socket.h> /* basics, SO_ and AF_ defs, sockaddr, ... */
+ #include <unistd.h>
+ #include <stdlib.h>
++#include <string.h>
+ #else
+ #include <fcntl.h>
+ #include <io.h>
diff --git a/app-shells/rrs/files/digest-rrs-1.50 b/app-shells/rrs/files/digest-rrs-1.50
new file mode 100644
index 000000000000..c5bfdabdca1a
--- /dev/null
+++ b/app-shells/rrs/files/digest-rrs-1.50
@@ -0,0 +1 @@
+MD5 1cb69c3d65060ed767fa6dadd87eb816 rrs-1.50.tar.gz 42575
diff --git a/app-shells/rrs/metadata.xml b/app-shells/rrs/metadata.xml
new file mode 100644
index 000000000000..b9fc2b9c6f11
--- /dev/null
+++ b/app-shells/rrs/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>dragonheart@gentoo.org</email>
+ <name>Daniel Black</name>
+ <description>A user ebuild that I felt obliged to include. Please take over if you want
+it</description>
+</maintainer>
+<longdescription></longdescription>
+</pkgmetadata>
diff --git a/app-shells/rrs/rrs-1.50.ebuild b/app-shells/rrs/rrs-1.50.ebuild
new file mode 100644
index 000000000000..3d736ae1688f
--- /dev/null
+++ b/app-shells/rrs/rrs-1.50.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rrs/rrs-1.50.ebuild,v 1.1 2004/05/13 04:32:47 dragonheart Exp $
+
+DESCRIPTION="Reverse Remote Shell"
+HOMEPAGE="http://www.cycom.se/dl/rrs"
+SRC_URI="http://www.cycom.se/uploads/36/17/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PV}-include-string.h.patch
+}
+
+src_compile() {
+ local target=""
+ use ssl || target="-nossl"
+
+ emake generic${target} \
+ LDEXTRA="-lstdc++" \
+ CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin rrs
+ dodoc CHANGES README
+ doman rrs.1
+}