summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-08-28 14:30:41 +0000
committerIan Delaney <idella4@gentoo.org>2013-08-28 14:30:41 +0000
commit2af2a04ee7bdb05ea755c0f162a605b1f67c6b7d (patch)
treef1d45a67d66d857b353be1b6a62a4ffaa75aad79 /app-shells/psh
parentx86/amd64 stable, security bug #479518 wrt Agostino Sarubbo and slepnoga. Ver... (diff)
downloadgentoo-2-2af2a04ee7bdb05ea755c0f162a605b1f67c6b7d.tar.gz
gentoo-2-2af2a04ee7bdb05ea755c0f162a605b1f67c6b7d.tar.bz2
gentoo-2-2af2a04ee7bdb05ea755c0f162a605b1f67c6b7d.zip
revbump -> EAPI 5
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-shells/psh')
-rw-r--r--app-shells/psh/ChangeLog9
-rw-r--r--app-shells/psh/psh-1.8.1-r1.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/app-shells/psh/ChangeLog b/app-shells/psh/ChangeLog
index 591bdacf02d8..170a4248cee6 100644
--- a/app-shells/psh/ChangeLog
+++ b/app-shells/psh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/psh
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/ChangeLog,v 1.30 2012/08/17 16:39:58 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/ChangeLog,v 1.31 2013/08/28 14:30:41 idella4 Exp $
+
+*psh-1.8.1-r1 (28 Aug 2013)
+
+ 28 Aug 2013; Ian Delaney <idella4@gentoo.org> +psh-1.8.1-r1.ebuild:
+ revbump -> EAPI 5
17 Aug 2012; Michael Palimaka <kensington@gentoo.org> -psh-1.8-r1.ebuild,
-psh-1.8.ebuild:
diff --git a/app-shells/psh/psh-1.8.1-r1.ebuild b/app-shells/psh/psh-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..d8e1886a5cb1
--- /dev/null
+++ b/app-shells/psh/psh-1.8.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/psh-1.8.1-r1.ebuild,v 1.1 2013/08/28 14:30:40 idella4 Exp $
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
+HOMEPAGE="http://www.focusresearch.com/gregor/sw/psh/"
+SRC_URI="http://www.focusresearch.com/gregor/download/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# Package warrants USE doc & examples
+IUSE="readline"
+
+DEPEND=""
+RDEPEND="readline? (
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/TermReadKey )"
+
+SRC_TEST="do parallel"
+myinst="SITEPREFIX=${D}/usr"
+
+src_install() {
+ perl-module_src_install
+ dodoc examples/complete-examples doc/*
+}