summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-04-16 20:50:43 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-04-16 20:50:43 +0000
commitf2eed5d26ab84a02ce3df3eb501252969ddea004 (patch)
tree8ec870ba2729b69e703be9c820ce88c7c45542bf /app-shells/pdsh
parentDrop KDE 4.2.1 (diff)
downloadgentoo-2-f2eed5d26ab84a02ce3df3eb501252969ddea004.tar.gz
gentoo-2-f2eed5d26ab84a02ce3df3eb501252969ddea004.tar.bz2
gentoo-2-f2eed5d26ab84a02ce3df3eb501252969ddea004.zip
Bump pdsh-2.18 (#263993). Remove patches that are applied upstream. Add support for building extra modules with PDSH_MODULE_LIST.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/pdsh')
-rw-r--r--app-shells/pdsh/ChangeLog8
-rw-r--r--app-shells/pdsh/pdsh-2.18.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/app-shells/pdsh/ChangeLog b/app-shells/pdsh/ChangeLog
index 1e0b5d495031..f459ca53cd60 100644
--- a/app-shells/pdsh/ChangeLog
+++ b/app-shells/pdsh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/pdsh
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/ChangeLog,v 1.13 2009/02/05 00:24:58 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/ChangeLog,v 1.14 2009/04/16 20:50:43 jsbronder Exp $
+
+*pdsh-2.18 (16 Apr 2009)
+
+ 16 Apr 2009; Justin Bronder <jsbronder@gentoo.org> +pdsh-2.18.ebuild:
+ Bump pdsh-2.18 (#263993). Remove patches that are applied upstream. Add
+ support for building extra modules with PDSH_MODULE_LIST.
*pdsh-2.17 (05 Feb 2009)
diff --git a/app-shells/pdsh/pdsh-2.18.ebuild b/app-shells/pdsh/pdsh-2.18.ebuild
new file mode 100644
index 000000000000..1cd9874f31e5
--- /dev/null
+++ b/app-shells/pdsh/pdsh-2.18.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/pdsh-2.18.ebuild,v 1.1 2009/04/16 20:50:43 jsbronder Exp $
+
+inherit eutils
+
+DESCRIPTION="A high-performance, parallel remote shell utility."
+HOMEPAGE="https://computing.llnl.gov/linux/pdsh.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt readline rsh"
+RDEPEND="crypt? ( net-misc/openssh )
+ rsh? ( net-misc/netkit-rsh )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}"
+
+# Feel free to debug the test suite. Running the tests
+# by hand instead of using pdsh.exp seems to print out
+# what is expected, so the error is most likely in the
+# testsuite itself.
+# You'll also need dev-util/dejagnu
+RESTRICT="test"
+
+pkg_setup() {
+ local m
+ local valid_modules=":xcpu:ssh:exec:qshell:genders:nodeupdown:mrsh:mqshell:dshgroups:netgroup:"
+
+ PDSH_MODULE_LIST="${PDSH_MODULE_LIST:-netgroup}"
+ MODULE_CONFIG=""
+ for m in ${PDSH_MODULE_LIST}; do
+ if [[ "${valid_modules}" == *:${m}:* ]]; then
+ MODULE_CONFIG="${MODULE_CONFIG} --with-${m}"
+ fi
+ done
+
+ elog "Building ${PF} with the following modules:"
+ elog " ${PDSH_MODULE_LIST}"
+ elog "This list can be changed in /etc/make.conf by setting"
+ elog "PDSH_MODULE_LIST=\"module1 module2...\""
+}
+
+src_compile() {
+ econf ${MODULE_CONFIG} \
+ --with-machines \
+ $(use_with crypt ssh) \
+ $(use_with rsh) \
+ $(use_with readline) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}