summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-22 17:08:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-22 17:08:14 +0000
commit795478e4ccd5a18f9f10951be7986a13de0438de (patch)
tree114c338b49f8b170ab35eb58c7daf22c69a936da /app-shells/pdsh
parentStable for HPPA (bug #312979). (diff)
downloadgentoo-2-795478e4ccd5a18f9f10951be7986a13de0438de.tar.gz
gentoo-2-795478e4ccd5a18f9f10951be7986a13de0438de.tar.bz2
gentoo-2-795478e4ccd5a18f9f10951be7986a13de0438de.zip
amd64 stable and punt vulnerable versions
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/pdsh')
-rw-r--r--app-shells/pdsh/ChangeLog5
-rw-r--r--app-shells/pdsh/files/pdsh-2.14-gcc-4.3-unistd.h.patch13
-rw-r--r--app-shells/pdsh/files/pdsh-2.14-glibc-2.8-ARG_MAX.patch41
-rw-r--r--app-shells/pdsh/pdsh-2.14.ebuild40
-rw-r--r--app-shells/pdsh/pdsh-2.16.ebuild40
-rw-r--r--app-shells/pdsh/pdsh-2.17.ebuild43
-rw-r--r--app-shells/pdsh/pdsh-2.18-r1.ebuild8
-rw-r--r--app-shells/pdsh/pdsh-2.18.ebuild57
8 files changed, 8 insertions, 239 deletions
diff --git a/app-shells/pdsh/ChangeLog b/app-shells/pdsh/ChangeLog
index d73d5fbbe28b..ff5d75c74012 100644
--- a/app-shells/pdsh/ChangeLog
+++ b/app-shells/pdsh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-shells/pdsh
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/ChangeLog,v 1.16 2010/04/08 07:22:11 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/ChangeLog,v 1.17 2010/04/22 17:08:14 ssuominen Exp $
+
+ 22 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> pdsh-2.18-r1.ebuild:
+ amd64 stable wrt #252398
08 Apr 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> pdsh-2.18-r1.ebuild:
x86 stable wrt bug #252398
diff --git a/app-shells/pdsh/files/pdsh-2.14-gcc-4.3-unistd.h.patch b/app-shells/pdsh/files/pdsh-2.14-gcc-4.3-unistd.h.patch
deleted file mode 100644
index 03e568e7290d..000000000000
--- a/app-shells/pdsh/files/pdsh-2.14-gcc-4.3-unistd.h.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-gcc-4.3 no longer includes this by default, needed to get the ssize_t type.
-
---- pdsh-2.14/src/modules/machines.c
-+++ pdsh-2.14/src/modules/machines.c
-@@ -28,6 +28,8 @@
- # include "config.h"
- #endif
-
-+#include <unistd.h>
-+
- #include "src/pdsh/wcoll.h"
- #include "src/pdsh/mod.h"
- #include "src/common/hostlist.h"
diff --git a/app-shells/pdsh/files/pdsh-2.14-glibc-2.8-ARG_MAX.patch b/app-shells/pdsh/files/pdsh-2.14-glibc-2.8-ARG_MAX.patch
deleted file mode 100644
index 8b0de0ac138c..000000000000
--- a/app-shells/pdsh/files/pdsh-2.14-glibc-2.8-ARG_MAX.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-glibc-2.8 no longer provides the ARG_MAX macro.
-
---- pdsh-2.14/src/pdsh/xpopen.c
-+++ pdsh-2.14/src/pdsh/xpopen.c
-@@ -84,10 +84,17 @@
- struct pid *cur;
- int fds[2], read, fd;
- pid_t pid;
-- char *av[ARG_MAX + 1];
- int maxfd = sysconf(_SC_OPEN_MAX);
-+ long arg_max;
-+ char **av;
-+
-+ arg_max = sysconf(_SC_ARG_MAX);
-+ if (arg_max < 0)
-+ errx("%p: unable to get _SC_OPEN_MAX (%m)\n");
-+
-+ av = Malloc(sizeof(char *) * (arg_max + 1));
-
-- _parse_command_with_quotes(av, ARG_MAX, cmd);
-+ _parse_command_with_quotes(av, arg_max, cmd);
-
- if ((*mode != 'r' && *mode != 'w') || mode[1] != '\0') {
- errno = EINVAL;
-@@ -101,6 +106,7 @@
- if (pipe(fds) < 0) {
- close(fds[0]);
- close(fds[1]);
-+ Free((void **) &av);
- Free((void **) &cur);
- errx("%p: unable to dup stdout\n");
- }
-@@ -143,6 +149,8 @@
- cur->next = pidlist;
- pidlist = cur;
-
-+ Free((void **) &av);
-+
- return (cur->fp);
-
- }
diff --git a/app-shells/pdsh/pdsh-2.14.ebuild b/app-shells/pdsh/pdsh-2.14.ebuild
deleted file mode 100644
index 502280d5c338..000000000000
--- a/app-shells/pdsh/pdsh-2.14.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/pdsh-2.14.ebuild,v 1.5 2008/06/15 18:52:27 swegener Exp $
-
-inherit eutils
-
-DESCRIPTION="A high-performance, parallel remote shell utility."
-HOMEPAGE="https://computing.llnl.gov/linux/pdsh.html"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="crypt readline rsh"
-RDEPEND="crypt? ( net-misc/openssh )
- rsh? ( net-misc/netkit-rsh )
- readline? ( sys-libs/readline )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gcc-4.3-unistd.h.patch
- epatch "${FILESDIR}"/${P}-glibc-2.8-ARG_MAX.patch
-}
-
-src_compile() {
- econf \
- --with-machines \
- $(use_with crypt ssh) \
- $(use_with rsh) \
- $(use_with readline) \
- || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/app-shells/pdsh/pdsh-2.16.ebuild b/app-shells/pdsh/pdsh-2.16.ebuild
deleted file mode 100644
index 79aaeb81534e..000000000000
--- a/app-shells/pdsh/pdsh-2.16.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/pdsh-2.16.ebuild,v 1.1 2008/06/15 18:54:59 swegener Exp $
-
-inherit eutils
-
-DESCRIPTION="A high-performance, parallel remote shell utility."
-HOMEPAGE="https://computing.llnl.gov/linux/pdsh.html"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="crypt readline rsh"
-RDEPEND="crypt? ( net-misc/openssh )
- rsh? ( net-misc/netkit-rsh )
- readline? ( sys-libs/readline )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-2.14-gcc-4.3-unistd.h.patch
- epatch "${FILESDIR}"/${PN}-2.14-glibc-2.8-ARG_MAX.patch
-}
-
-src_compile() {
- econf \
- --with-machines \
- $(use_with crypt ssh) \
- $(use_with rsh) \
- $(use_with readline) \
- || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/app-shells/pdsh/pdsh-2.17.ebuild b/app-shells/pdsh/pdsh-2.17.ebuild
deleted file mode 100644
index 372058f61c6e..000000000000
--- a/app-shells/pdsh/pdsh-2.17.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/pdsh-2.17.ebuild,v 1.1 2009/02/05 00:24:58 jsbronder Exp $
-
-inherit eutils
-
-DESCRIPTION="A high-performance, parallel remote shell utility."
-HOMEPAGE="https://computing.llnl.gov/linux/pdsh.html"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="crypt readline rsh"
-RDEPEND="crypt? ( net-misc/openssh )
- rsh? ( net-misc/netkit-rsh )
- readline? ( sys-libs/readline )"
-DEPEND="${RDEPEND}"
-
-# Feel free to debug the test suite.
-RESTRICT="test"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-2.14-gcc-4.3-unistd.h.patch
- epatch "${FILESDIR}"/${PN}-2.14-glibc-2.8-ARG_MAX.patch
-}
-
-src_compile() {
- econf \
- --with-machines \
- $(use_with crypt ssh) \
- $(use_with rsh) \
- $(use_with readline) \
- || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/app-shells/pdsh/pdsh-2.18-r1.ebuild b/app-shells/pdsh/pdsh-2.18-r1.ebuild
index 72273720bc48..294ea127620d 100644
--- a/app-shells/pdsh/pdsh-2.18-r1.ebuild
+++ b/app-shells/pdsh/pdsh-2.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/pdsh-2.18-r1.ebuild,v 1.2 2010/04/08 07:22:11 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/pdsh-2.18-r1.ebuild,v 1.3 2010/04/22 17:08:14 ssuominen Exp $
EAPI="2"
@@ -11,7 +11,7 @@ HOMEPAGE="https://computing.llnl.gov/linux/pdsh.html"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 x86"
+KEYWORDS="amd64 x86"
IUSE="crypt readline rsh"
RDEPEND="crypt? ( net-misc/openssh )
rsh? ( net-misc/netkit-rsh )
@@ -44,8 +44,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/pdsh-2.18-unbundle-libtool.patch || die
- eautoreconf || die
+ epatch "${FILESDIR}"/pdsh-2.18-unbundle-libtool.patch
+ eautoreconf
}
src_configure() {
diff --git a/app-shells/pdsh/pdsh-2.18.ebuild b/app-shells/pdsh/pdsh-2.18.ebuild
deleted file mode 100644
index 0ec3780b7d1f..000000000000
--- a/app-shells/pdsh/pdsh-2.18.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/pdsh-2.18.ebuild,v 1.2 2009/04/16 22:27:34 mr_bones_ Exp $
-
-inherit eutils
-
-DESCRIPTION="A high-performance, parallel remote shell utility."
-HOMEPAGE="https://computing.llnl.gov/linux/pdsh.html"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="crypt readline rsh"
-RDEPEND="crypt? ( net-misc/openssh )
- rsh? ( net-misc/netkit-rsh )
- readline? ( sys-libs/readline )"
-DEPEND="${RDEPEND}"
-
-# Feel free to debug the test suite. Running the tests
-# by hand instead of using pdsh.exp seems to print out
-# what is expected, so the error is most likely in the
-# testsuite itself.
-# You'll also need dev-util/dejagnu
-RESTRICT="test"
-
-pkg_setup() {
- local m
- local valid_modules=":xcpu:ssh:exec:qshell:genders:nodeupdown:mrsh:mqshell:dshgroups:netgroup:"
-
- PDSH_MODULE_LIST="${PDSH_MODULE_LIST:-netgroup}"
- MODULE_CONFIG=""
- for m in ${PDSH_MODULE_LIST}; do
- if [[ "${valid_modules}" == *:${m}:* ]]; then
- MODULE_CONFIG="${MODULE_CONFIG} --with-${m}"
- fi
- done
-
- elog "Building ${PF} with the following modules:"
- elog " ${PDSH_MODULE_LIST}"
- elog "This list can be changed in /etc/make.conf by setting"
- elog "PDSH_MODULE_LIST=\"module1 module2...\""
-}
-
-src_compile() {
- econf ${MODULE_CONFIG} \
- --with-machines \
- $(use_with crypt ssh) \
- $(use_with rsh) \
- $(use_with readline) \
- || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}