summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2009-09-06 19:05:42 +0000
committerChristian Ruppert <idl0r@gentoo.org>2009-09-06 19:05:42 +0000
commit575c737407d274423d80bb9666b44909832e3e7f (patch)
tree59d99d792be733bd84feec7ecf75849f890fad2d /app-shells/ksh/ksh-93.20081104.ebuild
parentVersion bump (diff)
downloadgentoo-2-575c737407d274423d80bb9666b44909832e3e7f.tar.gz
gentoo-2-575c737407d274423d80bb9666b44909832e3e7f.tar.bz2
gentoo-2-575c737407d274423d80bb9666b44909832e3e7f.zip
Remove unused patches. Fix repoman complains.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/ksh/ksh-93.20081104.ebuild')
-rw-r--r--app-shells/ksh/ksh-93.20081104.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-shells/ksh/ksh-93.20081104.ebuild b/app-shells/ksh/ksh-93.20081104.ebuild
index 41e1c1722c18..91c5bae17223 100644
--- a/app-shells/ksh/ksh-93.20081104.ebuild
+++ b/app-shells/ksh/ksh-93.20081104.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20081104.ebuild,v 1.1 2008/11/10 23:30:03 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20081104.ebuild,v 1.2 2009/09/06 19:05:41 idl0r Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -20,51 +20,52 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="nls"
DEPEND="!app-shells/pdksh"
+RDEPEND=""
S=${WORKDIR}
src_unpack() {
# the AT&T build tools look in here for packages.
- mkdir -p ${S}/lib/package/tgz
+ mkdir -p "${S}"/lib/package/tgz
# move the packages into place.
- cp ${DISTDIR}/ast-ksh.${RELEASE}.tgz ${S}/lib/package/tgz/ || die
+ cp "${DISTDIR}"/ast-ksh.${RELEASE}.tgz "${S}"/lib/package/tgz/ || die
if use nls; then
- cp ${DISTDIR}/ast-ksh-locale.${LOCALE_RELEASE}.tgz ${S}/lib/package/tgz/ || die
+ cp "${DISTDIR}"/ast-ksh-locale.${LOCALE_RELEASE}.tgz "${S}"/lib/package/tgz/ || die
fi
# INIT provides the basic tools to start building.
unpack INIT.${INIT_RELEASE}.tgz
# `package read` will unpack any tarballs put in place.
- ${S}/bin/package read || die
+ "${S}"/bin/package read || die
}
src_compile() {
strip-flags; export CCFLAGS="${CFLAGS}"
- cd ${S}; ./bin/package only make ast-ksh CC="$(tc-getCC)" || die
+ cd "${S}"; ./bin/package only make ast-ksh CC="$(tc-getCC)" || die
# install the optional locale data.
if use nls; then
- cd ${S}; ./bin/package only make ast-ksh-locale CC="$(tc-getCC)"
+ cd "${S}"; ./bin/package only make ast-ksh-locale CC="$(tc-getCC)"
fi
}
src_install() {
exeinto /bin
- doexe ${S}/arch/linux.*/bin/ksh || die
+ doexe "${S}"/arch/linux.*/bin/ksh || die
- newman ${S}/arch/linux.*/man/man1/sh.1 ksh.1
+ newman "${S}"/arch/linux.*/man/man1/sh.1 ksh.1
dodoc lib/package/LICENSES/ast
dohtml lib/package/ast-ksh.html
if use nls; then
dodir /usr/share
- mv ${S}/share/lib/locale ${D}/usr/share
- find ${D}/usr/share/locale -type f -name 'LC_TIME' -exec rm -rf {} \; 2>/dev/null
+ mv "${S}"/share/lib/locale "${D}"/usr/share
+ find "${D}"/usr/share/locale -type f -name 'LC_TIME' -exec rm -rf {} \; 2>/dev/null
fi
}