summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-09-11 14:27:04 +0000
committerMichał Górny <mgorny@gentoo.org>2014-09-11 14:27:04 +0000
commitd3f5975f15ab9b6bcf5c2d49d93f8122925013ef (patch)
treef5a7bb82a78fb74834457f29630fc6a228c8f191 /app-shells/gentoo-bashcomp
parentMask new version of gentoo-bashcomp aside bash-completion-2.1-r90. (diff)
downloadgentoo-2-d3f5975f15ab9b6bcf5c2d49d93f8122925013ef.tar.gz
gentoo-2-d3f5975f15ab9b6bcf5c2d49d93f8122925013ef.tar.bz2
gentoo-2-d3f5975f15ab9b6bcf5c2d49d93f8122925013ef.zip
A new version with proper bash-completion autoloading support.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-shells/gentoo-bashcomp')
-rw-r--r--app-shells/gentoo-bashcomp/ChangeLog8
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20140911.ebuild23
2 files changed, 30 insertions, 1 deletions
diff --git a/app-shells/gentoo-bashcomp/ChangeLog b/app-shells/gentoo-bashcomp/ChangeLog
index 9a62cd3ed99f..45cc9cb03933 100644
--- a/app-shells/gentoo-bashcomp/ChangeLog
+++ b/app-shells/gentoo-bashcomp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/gentoo-bashcomp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.71 2014/03/26 17:35:05 rhill Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.72 2014/09/11 14:27:04 mgorny Exp $
+
+*gentoo-bashcomp-20140911 (11 Sep 2014)
+
+ 11 Sep 2014; Michał Górny <mgorny@gentoo.org>
+ +gentoo-bashcomp-20140911.ebuild:
+ A new version with proper bash-completion autoloading support.
26 Mar 2014; Ryan Hill <rhill@gentoo.org> metadata.xml:
Remove myself from metadata.
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20140911.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20140911.ebuild
new file mode 100644
index 000000000000..24077041e860
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20140911.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/gentoo-bashcomp-20140911.ebuild,v 1.1 2014/09/11 14:27:04 mgorny Exp $
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, repoman, layman, etc)"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ completionsdir="$(get_bashcompdir)" \
+ helpersdir="$(get_bashhelpersdir)" \
+ compatdir="${EPREFIX}/etc/bash_completion.d"
+}