summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-09-28 09:30:43 +0000
committerTravis Tilley <lv@gentoo.org>2004-09-28 09:30:43 +0000
commite5f930ef7eaf3f0851b8f80f2813a657ba15cac1 (patch)
tree858b5743eae85ab483f004175873262cb329a84b /app-shells/bash
parentforgot -j1 as per prev bug report. Added inherit eutils too (Manifest recommit) (diff)
downloadgentoo-2-e5f930ef7eaf3f0851b8f80f2813a657ba15cac1.tar.gz
gentoo-2-e5f930ef7eaf3f0851b8f80f2813a657ba15cac1.tar.bz2
gentoo-2-e5f930ef7eaf3f0851b8f80f2813a657ba15cac1.zip
fixed using bash with post-20040808 glibc snapshots
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/ChangeLog7
-rw-r--r--app-shells/bash/bash-2.05b-r10.ebuild4
-rw-r--r--app-shells/bash/bash-2.05b-r9.ebuild4
-rw-r--r--app-shells/bash/bash-3.0-r5.ebuild5
-rw-r--r--app-shells/bash/bash-3.0-r6.ebuild5
-rw-r--r--app-shells/bash/files/bash-2.05b-jobs.patch27
-rw-r--r--app-shells/bash/files/bash-3.0-jobs.patch35
7 files changed, 82 insertions, 5 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 837edc4eab9a..274b01d64b47 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.51 2004/09/28 02:41:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.52 2004/09/28 09:30:43 lv Exp $
+
+ 28 Sep 2004; Travis Tilley <lv@gentoo.org> +files/bash-2.05b-jobs.patch,
+ +files/bash-3.0-jobs.patch, bash-2.05b-r10.ebuild, bash-2.05b-r9.ebuild,
+ bash-3.0-r5.ebuild, bash-3.0-r6.ebuild:
+ fixed using bash with post-20040808 glibc snapshots
*bash-3.0-r6 (27 Sep 2004)
diff --git a/app-shells/bash/bash-2.05b-r10.ebuild b/app-shells/bash/bash-2.05b-r10.ebuild
index 142458560425..0e87a279ae88 100644
--- a/app-shells/bash/bash-2.05b-r10.ebuild
+++ b/app-shells/bash/bash-2.05b-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r10.ebuild,v 1.8 2004/09/25 04:10:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r10.ebuild,v 1.9 2004/09/28 09:30:43 lv Exp $
inherit gcc eutils flag-o-matic gnuconfig
@@ -44,6 +44,8 @@ src_unpack() {
epatch ${FILESDIR}/${P}-rbash.patch
# Fix parallel make, bug #41002.
epatch ${FILESDIR}/${P}-parallel-build.patch
+ # Fix using bash with post-20040808 glibc ebuilds
+ epatch ${FILESDIR}/${P}-jobs.patch
# Enable SSH_SOURCE_BASHRC (#24762)
echo '#define SSH_SOURCE_BASHRC' >> config-top.h
diff --git a/app-shells/bash/bash-2.05b-r9.ebuild b/app-shells/bash/bash-2.05b-r9.ebuild
index 76415fabf3ce..467db50c35a0 100644
--- a/app-shells/bash/bash-2.05b-r9.ebuild
+++ b/app-shells/bash/bash-2.05b-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r9.ebuild,v 1.22 2004/09/25 04:10:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r9.ebuild,v 1.23 2004/09/28 09:30:43 lv Exp $
inherit eutils flag-o-matic gnuconfig
@@ -44,6 +44,8 @@ src_unpack() {
epatch ${FILESDIR}/${P}-rbash.patch
# Fix parallel make, bug #41002.
epatch ${FILESDIR}/${P}-parallel-build.patch
+ # Fix using bash with post-20040808 glibc ebuilds
+ epatch ${FILESDIR}/${P}-jobs.patch
# Enable SSH_SOURCE_BASHRC (#24762)
sed -e 's:^.*\(#define SSH_SOURCE_BASHRC\).*$:\1:' \
diff --git a/app-shells/bash/bash-3.0-r5.ebuild b/app-shells/bash/bash-3.0-r5.ebuild
index 361bb87e71a0..d0e0ba90c67d 100644
--- a/app-shells/bash/bash-3.0-r5.ebuild
+++ b/app-shells/bash/bash-3.0-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r5.ebuild,v 1.6 2004/09/25 04:10:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r5.ebuild,v 1.7 2004/09/28 09:30:43 lv Exp $
inherit eutils flag-o-matic gnuconfig gcc
@@ -75,6 +75,9 @@ src_unpack() {
# bug 60127 (bash 3 breaks array stripping)
epatch ${FILESDIR}/${P}-array-stripping.patch
+ # Fix using bash with post-20040808 glibc ebuilds
+ epatch ${FILESDIR}/${P}-jobs.patch
+
# Enable SSH_SOURCE_BASHRC (#24762)
echo '#define SSH_SOURCE_BASHRC' >> config-top.h
diff --git a/app-shells/bash/bash-3.0-r6.ebuild b/app-shells/bash/bash-3.0-r6.ebuild
index 1382c332d7a9..764d36f24820 100644
--- a/app-shells/bash/bash-3.0-r6.ebuild
+++ b/app-shells/bash/bash-3.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r6.ebuild,v 1.1 2004/09/28 02:41:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r6.ebuild,v 1.2 2004/09/28 09:30:43 lv Exp $
inherit eutils flag-o-matic gnuconfig gcc
@@ -52,6 +52,9 @@ src_unpack() {
# user creates a ~/.inputrc
epatch ${FILESDIR}/${P}-etc-inputrc.patch
+ # Fix using bash with post-20040808 glibc ebuilds
+ epatch ${FILESDIR}/${P}-jobs.patch
+
# Enable SSH_SOURCE_BASHRC (#24762)
echo '#define SSH_SOURCE_BASHRC' >> config-top.h
diff --git a/app-shells/bash/files/bash-2.05b-jobs.patch b/app-shells/bash/files/bash-2.05b-jobs.patch
new file mode 100644
index 000000000000..6d68059535f2
--- /dev/null
+++ b/app-shells/bash/files/bash-2.05b-jobs.patch
@@ -0,0 +1,27 @@
+diff -Nru bash-2.05b.old/jobs.c bash-2.05b/jobs.c
+--- bash-2.05b.old/jobs.c 2004-09-28 04:24:20.656378576 -0400
++++ bash-2.05b/jobs.c 2004-09-28 04:24:30.586868912 -0400
+@@ -2423,6 +2423,7 @@
+ PROCESS *child;
+ pid_t pid;
+ int call_set_current, last_stopped_job, job, children_exited, waitpid_flags;
++ static int wcontinued_not_supported = 0;
+
+ call_set_current = children_exited = 0;
+ last_stopped_job = NO_JOB;
+@@ -2436,7 +2437,15 @@
+ : 0;
+ if (sigchld || block == 0)
+ waitpid_flags |= WNOHANG;
++ retry:
++ if (wcontinued_not_supported)
++ waitpid_flags &= ~WCONTINUED;
+ pid = WAITPID (-1, &status, waitpid_flags);
++ if (pid == -1 && errno == EINVAL)
++ {
++ wcontinued_not_supported = 1;
++ goto retry;
++ }
+
+ /* The check for WNOHANG is to make sure we decrement sigchld only
+ if it was non-zero before we called waitpid. */
diff --git a/app-shells/bash/files/bash-3.0-jobs.patch b/app-shells/bash/files/bash-3.0-jobs.patch
new file mode 100644
index 000000000000..b5d1ed4c7768
--- /dev/null
+++ b/app-shells/bash/files/bash-3.0-jobs.patch
@@ -0,0 +1,35 @@
+--- bash-3.0/tests/jobs4.sub.jobs 2004-05-06 14:02:41.000000000 +0100
++++ bash-3.0/tests/jobs4.sub 2004-09-08 16:07:25.305385245 +0100
+@@ -18,5 +18,5 @@
+
+ wait
+
+-cat &
++sleep 100 &
+ kill -1 %% && echo i killed it || echo could not kill it
+--- bash-3.0/jobs.c.jobs 2004-09-08 16:07:25.081427747 +0100
++++ bash-3.0/jobs.c 2004-09-08 16:18:06.698604033 +0100
+@@ -2475,6 +2475,7 @@
+ PROCESS *child;
+ pid_t pid;
+ int call_set_current, last_stopped_job, job, children_exited, waitpid_flags;
++ static int wcontinued_not_supported = 0;
+
+ call_set_current = children_exited = 0;
+ last_stopped_job = NO_JOB;
+@@ -2488,7 +2489,15 @@
+ : 0;
+ if (sigchld || block == 0)
+ waitpid_flags |= WNOHANG;
++ retry:
++ if (wcontinued_not_supported)
++ waitpid_flags &= ~WCONTINUED;
+ pid = WAITPID (-1, &status, waitpid_flags);
++ if (pid == -1 && errno == EINVAL)
++ {
++ wcontinued_not_supported = 1;
++ goto retry;
++ }
+
+ /* The check for WNOHANG is to make sure we decrement sigchld only
+ if it was non-zero before we called waitpid. */