summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-11-30 15:02:53 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-11-30 15:02:53 +0000
commitb87d60ec9f7a4c7c0a81ae141346df98a6d6e838 (patch)
tree2427d7299d647d486e8fa5291d93367b57dcf834 /app-sci
parentRemoved from portage 6.0.0p1, explainations later. This will be brought back... (diff)
downloadgentoo-2-b87d60ec9f7a4c7c0a81ae141346df98a6d6e838.tar.gz
gentoo-2-b87d60ec9f7a4c7c0a81ae141346df98a6d6e838.tar.bz2
gentoo-2-b87d60ec9f7a4c7c0a81ae141346df98a6d6e838.zip
Adding compiler check to .50 and declaring latest as stable for x86
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/octave/ChangeLog5
-rw-r--r--app-sci/octave/octave-2.1.50.ebuild11
-rw-r--r--app-sci/octave/octave-2.1.57-r1.ebuild4
3 files changed, 16 insertions, 4 deletions
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
index e5e1ea33238b..3235227c2434 100644
--- a/app-sci/octave/ChangeLog
+++ b/app-sci/octave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/octave
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.36 2004/10/04 14:53:41 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.37 2004/11/30 15:02:53 phosphan Exp $
+
+ 30 Nov 2004; Patrick Kursawe <phosphan@gentoo.org> octave-2.1.50.ebuild:
+ Adding fortran compiler check from newest version to .50 because of bug #66193.
04 Oct 2004; Patrick Kursawe <phosphan@gentoo.org> octave-2.1.57-r1.ebuild:
Adding proper quotes to LDFLAGS, fixing bug #66111
diff --git a/app-sci/octave/octave-2.1.50.ebuild b/app-sci/octave/octave-2.1.50.ebuild
index 3be095a821e1..2da4111f6a4f 100644
--- a/app-sci/octave/octave-2.1.50.ebuild
+++ b/app-sci/octave/octave-2.1.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.50.ebuild,v 1.6 2004/07/01 11:53:45 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.50.ebuild,v 1.7 2004/11/30 15:02:53 phosphan Exp $
inherit flag-o-matic
@@ -27,6 +27,15 @@ DEPEND="virtual/libc
# http://developer.intel.com/software/products/mkl/mkl52/index.htm for
# more information
+pkg_setup() {
+ use ifc || if [ -z `which g77` ]; then
+ #if ifc is defined then the dep was already checked
+ eerror "No fortran compiler found on the system!"
+ eerror "Please add f77 to your USE flags and reemerge gcc!"
+ die
+ fi
+}
+
src_compile() {
filter-flags -ffast-math
diff --git a/app-sci/octave/octave-2.1.57-r1.ebuild b/app-sci/octave/octave-2.1.57-r1.ebuild
index cb85ae1421ce..1b6bb80d7e9a 100644
--- a/app-sci/octave/octave-2.1.57-r1.ebuild
+++ b/app-sci/octave/octave-2.1.57-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.57-r1.ebuild,v 1.9 2004/10/04 14:53:41 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.57-r1.ebuild,v 1.10 2004/11/30 15:02:53 phosphan Exp $
inherit flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~alpha ~sparc amd64"
+KEYWORDS="x86 ~ppc ~alpha ~sparc amd64"
IUSE="emacs static readline zlib tetex hdf5 mpi ifc blas"
DEPEND="virtual/libc