summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-07-20 05:22:46 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-07-20 05:22:46 +0000
commite0c838dccfd31406011b3fcfe483df1466abce54 (patch)
treecb7cadf382b40a7cb70d063de214496c7efe79dc /app-sci/tilp
parentode is in dev-games (diff)
downloadgentoo-2-e0c838dccfd31406011b3fcfe483df1466abce54.tar.gz
gentoo-2-e0c838dccfd31406011b3fcfe483df1466abce54.tar.bz2
gentoo-2-e0c838dccfd31406011b3fcfe483df1466abce54.zip
New ebuild.
Diffstat (limited to 'app-sci/tilp')
-rw-r--r--app-sci/tilp/ChangeLog8
-rw-r--r--app-sci/tilp/Manifest2
-rw-r--r--app-sci/tilp/files/digest-tilp-6.061
-rw-r--r--app-sci/tilp/tilp-6.06.ebuild44
4 files changed, 55 insertions, 0 deletions
diff --git a/app-sci/tilp/ChangeLog b/app-sci/tilp/ChangeLog
new file mode 100644
index 000000000000..2f6079c99a05
--- /dev/null
+++ b/app-sci/tilp/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-sci/tilp
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tilp/ChangeLog,v 1.1 2003/07/20 05:22:46 rphillips Exp $
+
+*tilp-6.06 (19 Jul 2003)
+
+ 19 Jul 2003; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+ Submitted by Brent Redeker and Jonathan Rogers. Fixes #18234
diff --git a/app-sci/tilp/Manifest b/app-sci/tilp/Manifest
new file mode 100644
index 000000000000..c28bc1d078e9
--- /dev/null
+++ b/app-sci/tilp/Manifest
@@ -0,0 +1,2 @@
+MD5 392c257ec08ca3328495277eb6be3d1d tilp-6.06.ebuild 1256
+MD5 e63c3a7b61cdd7c36a01a074146ec93c files/digest-tilp-6.06 61
diff --git a/app-sci/tilp/files/digest-tilp-6.06 b/app-sci/tilp/files/digest-tilp-6.06
new file mode 100644
index 000000000000..423cc3ee07fc
--- /dev/null
+++ b/app-sci/tilp/files/digest-tilp-6.06
@@ -0,0 +1 @@
+MD5 1a5ec1211b9c53fd20b1203a9b4106b4 tilp-6.06.tar.gz 754867
diff --git a/app-sci/tilp/tilp-6.06.ebuild b/app-sci/tilp/tilp-6.06.ebuild
new file mode 100644
index 000000000000..8b7011286e15
--- /dev/null
+++ b/app-sci/tilp/tilp-6.06.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tilp/tilp-6.06.ebuild,v 1.1 2003/07/20 05:22:46 rphillips Exp $
+
+DESCRIPTION="TiLP is a linking program for Texas Instruments' graphing calculators."
+HOMEPAGE="http://tilp.sourceforge.net/"
+
+# Should figure out a way to allow downloads from different server, rather than
+# forcing it to come from Time-Warner
+SRC_URI="http://twtelecom.dl.sourceforge.net/sourceforge/tilp/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+# Only tested on x86 so far...
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-libs/libticables
+ dev-libs/libticalcs
+ dev-libs/libtifiles
+ =x11-libs/gtk+-1.2*"
+
+src_compile() {
+ # Note the special option --with-fontpath-prefix below.
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-fontpath-prefix=${D}/usr/X11R6/lib/X11/fonts \
+ --enable-exit-homedir || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README* RELEASE THANKS TODO
+}
+
+pkg_postinst() {
+ # TiLP installs a font into /usr/X11R6/lib/X11/fonts/misc, so I'm running
+ # mkfontdir here to update the system
+ mkfontdir -- /usr/X11R6/lib/X11/fonts/misc
+}