summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-10-30 08:32:18 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-10-30 08:32:18 +0000
commit4fc5bd8989336703a8b6d72bf640a575ee1b8666 (patch)
treef1ae37ff6f64f47ac6f1defb688f2f8460dadcd1 /app-sci/tbass
parentcp --> mv makes it work with fakeroot (diff)
downloadgentoo-2-4fc5bd8989336703a8b6d72bf640a575ee1b8666.tar.gz
gentoo-2-4fc5bd8989336703a8b6d72bf640a575ee1b8666.tar.bz2
gentoo-2-4fc5bd8989336703a8b6d72bf640a575ee1b8666.zip
new package tbass or balsa (*not* the gnome mailer) - Asynchronous Synthesis System
Diffstat (limited to 'app-sci/tbass')
-rw-r--r--app-sci/tbass/ChangeLog16
-rw-r--r--app-sci/tbass/files/digest-tbass-200207296
-rw-r--r--app-sci/tbass/tbass-20020729.ebuild83
3 files changed, 105 insertions, 0 deletions
diff --git a/app-sci/tbass/ChangeLog b/app-sci/tbass/ChangeLog
new file mode 100644
index 000000000000..c97b55ecdacd
--- /dev/null
+++ b/app-sci/tbass/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for app-sci/tbass
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tbass/ChangeLog,v 1.1 2002/10/30 08:32:18 george Exp $
+
+*tbass-20020729 (29 Oct 2002)
+
+ 29 Oct 2002; George Shapovalov <george@gentoo.org> tbass-20020729.ebuild :
+
+ initial release.
+
+ The Balsa Asynchronous Synthesis System
+ Balsa is both a framework for synthesising asynchronous (clockless) hardware systems and the
+ language for describing such systems.
+
+ ebuild submitted by Chris Bainbridge <chrb@dcs.ed.ac.uk>,
+ updated by Dave Nellans <dnellans@cs.utah.edu>
diff --git a/app-sci/tbass/files/digest-tbass-20020729 b/app-sci/tbass/files/digest-tbass-20020729
new file mode 100644
index 000000000000..646262bccfb9
--- /dev/null
+++ b/app-sci/tbass/files/digest-tbass-20020729
@@ -0,0 +1,6 @@
+MD5 9cbb4bec407cc4e9ff6ccb17c4dc44c6 balsa-20020729.tar.gz 798139
+MD5 29607ba5259e42363ea1b86838c3743b balsa-manual.pdf 369873
+MD5 af8abda78884e905470e992f57e64534 dma-example.tar.gz 7194
+MD5 6bf0aa7eb37a33728f58221502cc7f6a examples.tar.gz 7017
+MD5 1dd3ad22d8963224e28803f6205ea0b0 balsa-tech-ams-20020402.tar.gz 40354
+MD5 6914ae07c0bd8187d9e4baa9c9fe0837 balsa-tech-verilog-20020729.tar.gz 34117
diff --git a/app-sci/tbass/tbass-20020729.ebuild b/app-sci/tbass/tbass-20020729.ebuild
new file mode 100644
index 000000000000..8b0e07418be0
--- /dev/null
+++ b/app-sci/tbass/tbass-20020729.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tbass/tbass-20020729.ebuild,v 1.1 2002/10/30 08:32:18 george Exp $
+
+Name="balsa"
+
+DESCRIPTION="Balsa is both a framework for synthesising asynchronous hardware systems and the language for describing such systems"
+HOMEPAGE="http://www.cs.man.ac.uk/amulet/projects/balsa/"
+SRC_URI="ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/snapshots/${Name}-${PV}.tar.gz ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/docs/balsa-manual.pdf
+ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/examples/dma-example.tar.gz ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/examples/examples.tar.gz
+ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/snapshots/${Name}-tech-ams-20020402.tar.gz
+ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/snapshots/${Name}-tech-verilog-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="virtual/glibc
+ sys-devel/binutils
+ app-sci/lard
+ dev-libs/gmp
+ sys-devel/perl
+ x11-libs/gtk+"
+RDEPEND="${DEPEND}
+ dev-util/guile
+ media-gfx/graphviz"
+S=${WORKDIR}/${Name}-${PV}
+
+src_unpack() {
+
+ unpack ${Name}-${PV}.tar.gz dma-example.tar.gz examples.tar.gz ${Name}-tech-ams-20020402.tar.gz ${Name}-tech-verilog-${PV}.tar.gz
+}
+
+src_compile() {
+
+ cd ${S}
+ # compile balsa
+ econf || die "./configure failed"
+
+ cd bin
+ sed -e "s: \$(bindir): \$(DESTDIR)\$(bindir):g" Makefile > Makefile.1
+ cp Makefile.1 Makefile
+ emake || die
+
+ # configure tech paths
+ cd ${WORKDIR}/balsa-tech-ams-1.0
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die "./configure of balsa-tech-ams-1.0 failed"
+
+ cd ${WORKDIR}/balsa-tech-verilog-1.0
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die "./configure balsa-tech-verilog-1.0 failed"
+
+}
+
+src_install () {
+
+ # install balsa
+ make DESTDIR=${D}/ install
+
+ # move the docs to the right directory
+ dodoc ${D}/usr/doc/*
+ rm -rf ${D}/usr/doc
+
+ # install manual and examples
+ mkdir -p ${D}/usr/share/doc/${P}/examples/dma-example
+ cp -R ${WORKDIR}/dma-example ${D}/usr/share/doc/${P}/examples
+ cp -R ${WORKDIR}/examples/* ${D}/usr/share/doc/${P}/examples
+ dodoc ${DISTDIR}/balsa-manual.pdf
+
+ # install tech
+ cd ${WORKDIR}/balsa-tech-ams-1.0
+ make DESTDIR=${D} install
+
+ cd ${WORKDIR}/balsa-tech-verilog-1.0
+ make DESTDIR=${D} install
+ }