summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2004-05-12 06:15:13 +0000
committerSteve Arnold <nerdboy@gentoo.org>2004-05-12 06:15:13 +0000
commitab0a42088639b1228fb53d27e42f193e4757625b (patch)
treea050be236c0a37d7be08ae819e0abde37c83fbb0 /app-sci/netcdf/netcdf-3.5.1.ebuild
parentThe fix-sandbox patch tweaked paths a little too much, see bug #50763 (Manife... (diff)
downloadgentoo-2-ab0a42088639b1228fb53d27e42f193e4757625b.tar.gz
gentoo-2-ab0a42088639b1228fb53d27e42f193e4757625b.tar.bz2
gentoo-2-ab0a42088639b1228fb53d27e42f193e4757625b.zip
added ~x86 ebuild for netcdf 3.5.1
Diffstat (limited to 'app-sci/netcdf/netcdf-3.5.1.ebuild')
-rw-r--r--app-sci/netcdf/netcdf-3.5.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-sci/netcdf/netcdf-3.5.1.ebuild b/app-sci/netcdf/netcdf-3.5.1.ebuild
new file mode 100644
index 000000000000..e4abfc9ef737
--- /dev/null
+++ b/app-sci/netcdf/netcdf-3.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/netcdf-3.5.1.ebuild,v 1.1 2004/05/12 06:15:12 nerdboy Exp $
+
+inherit eutils
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.Z"
+HOMEPAGE="http://www.unidata.ucar.edu/packages/netcdf/"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~sparc ~amd64 ~alpha ~ia64 ~ppc ~mips ~hppa"
+
+S=${WORKDIR}/${P}/src
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/fPIC.patch || die "fPIC patch failed"
+}
+
+src_compile() {
+ export CPPFLAGS=-Df2cFortran
+ econf || die "econf failed"
+ make || die "make failed"
+ make test || die "make test failed"
+}
+
+src_install() {
+ dodir /usr/{lib,share} /usr/share/man/man3 /usr/share/man/man3f
+ einstall MANDIR=${D}/usr/share/man
+ mv ${D}/usr/share/man/man3/netcdf.3f ${D}/usr/share/man/man3f/.
+ dodoc COMPATIBILITY COPYRIGHT MANIFEST README RELEASE_NOTES VERSION fortran/cfortran.doc
+ dohtml -r .
+}