summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-05-23 18:12:55 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-05-23 18:12:55 +0000
commitfc906accb8fa9cd134edf6de733f9cc8641beb2e (patch)
tree538ac77a4a0b612194472781eb376bfba1a4aa86 /app-portage
parentVersion bump for security bug 471098. (diff)
downloadgentoo-2-fc906accb8fa9cd134edf6de733f9cc8641beb2e.tar.gz
gentoo-2-fc906accb8fa9cd134edf6de733f9cc8641beb2e.tar.bz2
gentoo-2-fc906accb8fa9cd134edf6de733f9cc8641beb2e.zip
version bump, adds support for /etc/portage/make.conf and /etc/eixrc being directories
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog8
-rw-r--r--app-portage/eix/eix-0.28.5.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 3cb01ca1c1c8..ede352f93b39 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.448 2013/04/16 14:01:40 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.449 2013/05/23 18:12:55 axs Exp $
+
+*eix-0.28.5 (23 May 2013)
+
+ 23 May 2013; Ian Stakenvicius <axs@gentoo.org> +eix-0.28.5.ebuild:
+ version bump, adds support for /etc/portage/make.conf and /etc/eixrc being
+ directories
*eix-0.28.4 (16 Apr 2013)
diff --git a/app-portage/eix/eix-0.28.5.ebuild b/app-portage/eix/eix-0.28.5.ebuild
new file mode 100644
index 000000000000..7e291a68c9c8
--- /dev/null
+++ b/app-portage/eix/eix-0.28.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.28.5.ebuild,v 1.1 2013/05/23 18:12:55 axs Exp $
+
+EAPI=5
+
+PLOCALES="de ru"
+inherit bash-completion-r1 eutils multilib l10n
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="http://eix.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="clang debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools zsh-completion"
+
+RDEPEND="app-shells/push
+ sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ clang? ( sys-devel/clang )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ case " ${REPLACING_VERSIONS}" in
+ *\ 0.[0-9].*|*\ 0.1[0-9].*|*\ 0.2[0-4].*|*\ 0.25.0*)
+ local eixcache="${EROOT}/var/cache/${PN}"
+ test -f "${eixcache}" && rm -f -- "${eixcache}";;
+ esac
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ econf $(use_with sqlite) $(use_with doc extra-doc) \
+ $(use_with zsh-completion) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable security) $(use_enable optimization) \
+ $(use_enable strong-security) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_enable swap-remote) \
+ $(use_with prefix always-accept-keywords) \
+ $(use_with dep dep-default) \
+ $(use_with clang nongnu-cxx clang++) \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ keepdir "/var/cache/${PN}"
+ fowners portage:portage "/var/cache/${PN}"
+ fperms 775 "/var/cache/${PN}"
+}
+
+pkg_postinst() {
+ # fowners in src_install doesn't work for owner/group portage:
+ # merging changes this owner/group back to root.
+ use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+ local obs="${EROOT}var/cache/eix.previous"
+ ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
+}