summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-01-28 16:23:04 +0000
committerJeremy Olexa <darkside@gentoo.org>2012-01-28 16:23:04 +0000
commit98d4afe41802a275796da5bd6f1c59bd168697fa (patch)
treea9a20f603cb5cfffcd919bd616aab289ef93f6a4 /app-portage
parentVersion bump, fixes bug 401179 by Ondrej Grover <ondrej.grover@gmail.com> (diff)
downloadgentoo-2-98d4afe41802a275796da5bd6f1c59bd168697fa.tar.gz
gentoo-2-98d4afe41802a275796da5bd6f1c59bd168697fa.tar.bz2
gentoo-2-98d4afe41802a275796da5bd6f1c59bd168697fa.zip
Version bump from upstream
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog7
-rw-r--r--app-portage/eix/eix-0.23.9.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 28ca8d105357..faf1a773ce38 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.397 2012/01/27 21:50:09 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.398 2012/01/28 16:23:04 darkside Exp $
+
+*eix-0.23.9 (28 Jan 2012)
+
+ 28 Jan 2012; Jeremy Olexa <darkside@gentoo.org> +eix-0.23.9.ebuild:
+ Version bump from upstream
27 Jan 2012; Jeremy Olexa <darkside@gentoo.org> -eix-0.22.11.ebuild,
-eix-0.23.5.ebuild:
diff --git a/app-portage/eix/eix-0.23.9.ebuild b/app-portage/eix/eix-0.23.9.ebuild
new file mode 100644
index 000000000000..a34e60ceaffb
--- /dev/null
+++ b/app-portage/eix/eix-0.23.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.23.9.ebuild,v 1.1 2012/01/28 16:23:04 darkside Exp $
+
+EAPI=4
+
+inherit multilib bash-completion-r1
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="http://eix.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="debug doc nls optimization security strong-optimization sqlite tools zsh-completion"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )
+ zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf $(use_with sqlite) $(use_with doc extra-doc) \
+ $(use_with zsh-completion) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable security) $(use_enable optimization) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_with prefix always-accept-keywords) \
+ --without-bzip2 \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+}