summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-02-08 03:53:11 +0000
committerSebastian Pipping <sping@gentoo.org>2011-02-08 03:53:11 +0000
commit8d4c1d9e6fc5f488383e0ae26bfce95c8d0aa96b (patch)
tree9024b57b5301ef98794d16fbe5de7795477b517e /app-portage
parentVersion bump and old version cleanup (diff)
downloadgentoo-2-8d4c1d9e6fc5f488383e0ae26bfce95c8d0aa96b.tar.gz
gentoo-2-8d4c1d9e6fc5f488383e0ae26bfce95c8d0aa96b.tar.bz2
gentoo-2-8d4c1d9e6fc5f488383e0ae26bfce95c8d0aa96b.zip
app-portage/layman: Bump to 1.4.2
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/layman/ChangeLog7
-rw-r--r--app-portage/layman/layman-1.4.2.ebuild104
2 files changed, 110 insertions, 1 deletions
diff --git a/app-portage/layman/ChangeLog b/app-portage/layman/ChangeLog
index 4f18f0eb60d6..5116bf29a0e5 100644
--- a/app-portage/layman/ChangeLog
+++ b/app-portage/layman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/layman
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.121 2011/01/04 01:24:26 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.122 2011/02/08 03:53:11 sping Exp $
+
+*layman-1.4.2 (08 Feb 2011)
+
+ 08 Feb 2011; Sebastian Pipping <sping@gentoo.org> +layman-1.4.2.ebuild:
+ Bump to 1.4.2
04 Jan 2011; Michael Weber <xmw@gentoo.org> layman-1.4.1.ebuild:
sparc stable (bug 343309)
diff --git a/app-portage/layman/layman-1.4.2.ebuild b/app-portage/layman/layman-1.4.2.ebuild
new file mode 100644
index 000000000000..14259e89bc70
--- /dev/null
+++ b/app-portage/layman/layman-1.4.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-1.4.2.ebuild,v 1.1 2011/02/08 03:53:11 sping Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils distutils
+
+DESCRIPTION="Tool to manage Gentoo overlays."
+HOMEPAGE="http://layman.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bazaar cvs darcs git mercurial subversion test"
+
+COMMON_DEPS="dev-lang/python[xml]"
+DEPEND="${COMMON_DEPS}
+ test? ( dev-vcs/subversion )"
+RDEPEND="${COMMON_DEPS}
+ bazaar? ( dev-vcs/bzr )
+ cvs? ( dev-vcs/cvs )
+ darcs? ( dev-vcs/darcs )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? (
+ || (
+ >=dev-vcs/subversion-1.5.4[webdav-neon]
+ >=dev-vcs/subversion-1.5.4[webdav-serf]
+ )
+ )"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+pkg_setup() {
+ if ! has_version dev-vcs/subversion; then
+ ewarn "You do not have dev-vcs/subversion installed!"
+ ewarn "While layman does not exactly depend on this"
+ ewarn "version control system you should note that"
+ ewarn "most available overlays are offered via"
+ ewarn "dev-vcs/subversion. If you do not install it"
+ ewarn "you will be unable to use these overlays."
+ ewarn
+ fi
+}
+
+# Prevent running make
+src_compile() {
+ :
+}
+
+src_test() {
+ testing() {
+ for suite in layman/tests/{dtest,external}.py ; do
+ PYTHONPATH="." "$(PYTHON)" ${suite} \
+ || die "test suite '${suite}' failed"
+ done
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir /etc/layman
+
+ cp etc/* "${D}"/etc/layman/
+
+ doman doc/layman.8
+ dohtml doc/layman.8.html
+
+ keepdir /var/lib/layman
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo "You are now ready to add overlays into your system."
+ einfo
+ einfo " layman -L"
+ einfo
+ einfo "will display a list of available overlays."
+ einfo
+ elog "Select an overlay and add it using"
+ elog
+ elog " layman -a overlay-name"
+ elog
+ elog "If this is the very first overlay you add with layman,"
+ elog "you need to append the following statement to your"
+ elog "/etc/make.conf file:"
+ elog
+ elog " source /var/lib/layman/make.conf"
+ elog
+ elog "If you modify the 'storage' parameter in the layman"
+ elog "configuration file (/etc/layman/layman.cfg) you will"
+ elog "need to adapt the path given above to the new storage"
+ elog "directory."
+ elog
+ ewarn "Please add the 'source' statement to make.conf only AFTER "
+ ewarn "you added your first overlay. Otherwise portage will fail."
+ epause 5
+}