summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-30 11:46:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-30 11:46:54 +0000
commit4852dc4b40f4eb748041cf2bc51e3f05d426fde3 (patch)
treeb285f374747f87462a79180529922c4fa67cf6de /app-portage
parentFix building with GCC 4.4 and GLIBC 2.10+ wrt #277175. (diff)
downloadgentoo-2-4852dc4b40f4eb748041cf2bc51e3f05d426fde3.tar.gz
gentoo-2-4852dc4b40f4eb748041cf2bc51e3f05d426fde3.tar.bz2
gentoo-2-4852dc4b40f4eb748041cf2bc51e3f05d426fde3.zip
Fix building with GCC 4.4 wrt #277659.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gatt/ChangeLog6
-rw-r--r--app-portage/gatt/files/gatt-0.6.4-gcc44.patch11
-rw-r--r--app-portage/gatt/gatt-0.6.4.ebuild8
3 files changed, 23 insertions, 2 deletions
diff --git a/app-portage/gatt/ChangeLog b/app-portage/gatt/ChangeLog
index 2985cb39f1e6..bcfb4bc60d66 100644
--- a/app-portage/gatt/ChangeLog
+++ b/app-portage/gatt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-portage/gatt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gatt/ChangeLog,v 1.39 2009/07/21 07:04:53 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gatt/ChangeLog,v 1.40 2009/07/30 11:46:54 ssuominen Exp $
+
+ 30 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> gatt-0.6.4.ebuild,
+ +files/gatt-0.6.4-gcc44.patch:
+ Fix building with GCC 4.4 wrt #277659.
21 Jul 2009; Christian Faulhammer <fauli@gentoo.org>
-files/gatt-0.6.1-nonfataltests.patch, -files/gatt-0.6.1-tests.patch:
diff --git a/app-portage/gatt/files/gatt-0.6.4-gcc44.patch b/app-portage/gatt/files/gatt-0.6.4-gcc44.patch
new file mode 100644
index 000000000000..212f29c2c6db
--- /dev/null
+++ b/app-portage/gatt/files/gatt-0.6.4-gcc44.patch
@@ -0,0 +1,11 @@
+diff -ur gatt-0.6.4.orig/src/backup_system.cc gatt-0.6.4/src/backup_system.cc
+--- gatt-0.6.4.orig/src/backup_system.cc 2008-06-03 22:25:00.000000000 +0300
++++ gatt-0.6.4/src/backup_system.cc 2009-07-30 14:45:33.000000000 +0300
+@@ -22,6 +22,7 @@
+ #include "src/logger.h"
+ #include "src/util/fs_and_io.h"
+ #include <errno.h>
++#include <cstdio>
+ #include <cstring>
+ using namespace std;
+ namespace lth = libthrowable;
diff --git a/app-portage/gatt/gatt-0.6.4.ebuild b/app-portage/gatt/gatt-0.6.4.ebuild
index 7642f0296bac..77f2b49628e7 100644
--- a/app-portage/gatt/gatt-0.6.4.ebuild
+++ b/app-portage/gatt/gatt-0.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gatt/gatt-0.6.4.ebuild,v 1.1 2009/07/21 07:02:42 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gatt/gatt-0.6.4.ebuild,v 1.2 2009/07/30 11:46:54 ssuominen Exp $
inherit eutils
@@ -35,6 +35,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
src_compile() {
econf $(use_enable libpaludis) || die
emake || die