summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-06-26 23:09:25 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-06-26 23:09:25 +0000
commit9e523e63a717d75dcb31243adf517a2cdde86ebd (patch)
treed8392b915d91918cbd29c6496529567d5e148a24 /app-pda
parentadded patch to prevent segv on missing /proc/bus/usb/devices (#42378) (Manife... (diff)
downloadgentoo-2-9e523e63a717d75dcb31243adf517a2cdde86ebd.tar.gz
gentoo-2-9e523e63a717d75dcb31243adf517a2cdde86ebd.tar.bz2
gentoo-2-9e523e63a717d75dcb31243adf517a2cdde86ebd.zip
fix assert header problems (#50150)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/plptools/ChangeLog4
-rw-r--r--app-pda/plptools/files/plptools-0.12-assert.h.patch31
-rw-r--r--app-pda/plptools/plptools-0.12.ebuild21
3 files changed, 48 insertions, 8 deletions
diff --git a/app-pda/plptools/ChangeLog b/app-pda/plptools/ChangeLog
index 53ad0ce20bff..08dcdfd110c4 100644
--- a/app-pda/plptools/ChangeLog
+++ b/app-pda/plptools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/plptools
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
+ 26 Jun 2004; Alastair Tse <liquidx@gentoo.org>
+ +files/plptools-0.12-assert.h.patch, plptools-0.12.ebuild:
+ fix assert header problems (#50150)
+
*plptools-0.12 (11 Jan 2004)
11 Jan 2004; Troy Dack <tad@gentoo.org> plptools-0.11-r1.ebuild,
diff --git a/app-pda/plptools/files/plptools-0.12-assert.h.patch b/app-pda/plptools/files/plptools-0.12-assert.h.patch
new file mode 100644
index 000000000000..0ff848036758
--- /dev/null
+++ b/app-pda/plptools/files/plptools-0.12-assert.h.patch
@@ -0,0 +1,31 @@
+===================================================================
+RCS file: /cvsroot/plptools/plptools/lib/Enum.h,v
+retrieving revision 1.9
+retrieving revision 1.10
+diff -u -r1.9 -r1.10
+--- plptools/plptools/lib/Enum.h 2003/02/05 07:59:08 1.9
++++ plptools/plptools/lib/Enum.h 2004/03/13 11:15:36 1.10
+@@ -27,6 +27,7 @@
+ #include <config.h>
+ #endif
+
++#include <assert.h>
+ #include <map>
+ #include <string>
+
+@@ -276,13 +277,13 @@
+ * // declaration of enumeration; somewhere
+ * class rfsv {
+ * [...]
+- * enum PSI_ERROR_CODES { E_PSI_GEN_NONE, E_PSI_GEN_FAIL, E_PSI_GEN_ARG };
++ * enum PSI_ERROR_CODES { E_PSI_GEN_NONE, E_PSI_GEN_FAIL, E_PSI_GEN_ARG };
+ * [...]
+ * };
+ *
+ * // definition of the Enum<E> with the appropriate string representations
+ * ENUM_DEFINITION(rfsv::PSI_ERROR_CODES,
+- * rfsv::E_PSI_GEN_NONE) {
++ * rfsv::E_PSI_GEN_NONE) {
+ * stringRep.add(rfsv::E_PSI_GEN_NONE, "no error");
+ * stringRep.add(rfsv::E_PSI_GEN_FAIL, "general");
+ * stringRep.add(rfsv::E_PSI_GEN_ARG, "bad argument");
diff --git a/app-pda/plptools/plptools-0.12.ebuild b/app-pda/plptools/plptools-0.12.ebuild
index f03f7412e086..e2abc0d6d417 100644
--- a/app-pda/plptools/plptools-0.12.ebuild
+++ b/app-pda/plptools/plptools-0.12.ebuild
@@ -1,23 +1,28 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/plptools/plptools-0.12.ebuild,v 1.2 2004/06/24 21:44:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/plptools/plptools-0.12.ebuild,v 1.3 2004/06/26 23:09:25 liquidx Exp $
+
+inherit eutils
DESCRIPTION="Libraries and utilities to communicate with a Psion palmtop via serial."
HOMEPAGE="http://plptools.sourceforge.net"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/plptools/${P}.tar.gz"
-LICENSE="as-is"
+SRC_URI="mirror://sourceforge/plptools/${P}.tar.gz"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-DEPEND="virtual/glibc
- kde? ( >=kde-base/kdelibs-3.1* )"
+DEPEND="kde? ( >=kde-base/kdelibs-3.1* )"
-S="${WORKDIR}/${P}"
IUSE="kde"
-src_compile() {
- patch -p1 < ${FILESDIR}/${P}-gentoo.patch || die "Patch failed!"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ epatch ${FILESDIR}/${P}-assert.h.patch
+}
+src_compile() {
local myconf
if use kde