summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-02-08 19:07:01 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-02-08 19:07:01 +0000
commit26a216bc3603120682fafddc85b51b34605cf816 (patch)
tree594aa32e6ef7fb89df916a9dc3fa0677fde0ca69 /app-officeext
parentVersion bump, allow to use node.js for nbconvert instead of app-text/pandoc (diff)
downloadgentoo-2-26a216bc3603120682fafddc85b51b34605cf816.tar.gz
gentoo-2-26a216bc3603120682fafddc85b51b34605cf816.tar.bz2
gentoo-2-26a216bc3603120682fafddc85b51b34605cf816.zip
Version bump, bug 538910
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-officeext')
-rw-r--r--app-officeext/ooofbtools/ChangeLog8
-rw-r--r--app-officeext/ooofbtools/ooofbtools-2.32.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/app-officeext/ooofbtools/ChangeLog b/app-officeext/ooofbtools/ChangeLog
index 0934763a58a4..c1def5d18018 100644
--- a/app-officeext/ooofbtools/ChangeLog
+++ b/app-officeext/ooofbtools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-officeext/ooofbtools
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-officeext/ooofbtools/ChangeLog,v 1.15 2015/01/14 13:40:57 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-officeext/ooofbtools/ChangeLog,v 1.16 2015/02/08 19:07:01 dilfridge Exp $
+
+*ooofbtools-2.32 (08 Feb 2015)
+
+ 08 Feb 2015; Andreas K. Huettel <dilfridge@gentoo.org>
+ +ooofbtools-2.32.ebuild:
+ Version bump, bug 538910
*ooofbtools-2.31 (14 Jan 2015)
diff --git a/app-officeext/ooofbtools/ooofbtools-2.32.ebuild b/app-officeext/ooofbtools/ooofbtools-2.32.ebuild
new file mode 100644
index 000000000000..2689c3482535
--- /dev/null
+++ b/app-officeext/ooofbtools/ooofbtools-2.32.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-officeext/ooofbtools/ooofbtools-2.32.ebuild,v 1.1 2015/02/08 19:07:01 dilfridge Exp $
+
+EAPI=5
+
+MY_PN="OOoFBTools"
+
+OFFICE_EXTENSIONS=(
+ "${MY_PN}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="Extension for converting and processing eBooks in FictionBook2 format with validator"
+HOMEPAGE="https://sourceforge.net/projects/fbtools/"
+SRC_URI="mirror://sourceforge/fbtools/files/release/${MY_PN}-${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/libxml2"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+OFFICE_EXTENSIONS_LOCATION="${S}"
+
+src_prepare() {
+ # Remove Windows cruft
+ pushd "${WORKDIR}/${MY_PN}.oxt" 2>/dev/null
+ rm -r win32 || die
+ popd 2>/dev/null
+}
+
+src_install() {
+ office-ext-r1_src_install
+ dodoc ChangeLog*
+}