summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2009-02-08 17:21:59 +0000
committerCarsten Lohrke <carlo@gentoo.org>2009-02-08 17:21:59 +0000
commitefd3d04dc8845e77e563aafd89b00037031004a1 (patch)
tree2613fca3169bfeec65b3e00593ae55199b1b2871 /app-office
parentBump to 2.12.8 (diff)
downloadgentoo-2-efd3d04dc8845e77e563aafd89b00037031004a1.tar.gz
gentoo-2-efd3d04dc8845e77e563aafd89b00037031004a1.tar.bz2
gentoo-2-efd3d04dc8845e77e563aafd89b00037031004a1.zip
Sync to branch plus various fixes.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kexi/ChangeLog10
-rw-r--r--app-office/kexi/kexi-1.6.3_p20090204.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/app-office/kexi/ChangeLog b/app-office/kexi/ChangeLog
index 1067e4d7c360..38195ac44ee5 100644
--- a/app-office/kexi/ChangeLog
+++ b/app-office/kexi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kexi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.87 2008/06/16 14:01:48 carlo Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.88 2009/02/08 17:21:59 carlo Exp $
+
+*kexi-1.6.3_p20090204 (08 Feb 2009)
+
+ 08 Feb 2009; Carsten Lohrke <carlo@gentoo.org>
+ +kexi-1.6.3_p20090204.ebuild:
+ Sync to branch plus various fixes.
16 Jun 2008; Carsten Lohrke <carlo@gentoo.org> kexi-1.6.3.ebuild:
Adjust libpqxx dependency.
diff --git a/app-office/kexi/kexi-1.6.3_p20090204.ebuild b/app-office/kexi/kexi-1.6.3_p20090204.ebuild
new file mode 100644
index 000000000000..0dd066d22a02
--- /dev/null
+++ b/app-office/kexi/kexi-1.6.3_p20090204.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.6.3_p20090204.ebuild,v 1.1 2009/02/08 17:21:59 carlo Exp $
+
+ARTS_REQUIRED="never"
+
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated environment for database management."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres"
+
+DEPEND="~app-office/koffice-libs-1.6.3_p20090204
+ sys-libs/readline
+ mysql? ( virtual/mysql )
+ postgres? ( =dev-libs/libpqxx-2.6* )"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoproperty lib/koproperty
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkrossmain lib/kross/main/
+ libkrossapi lib/kross/api/"
+
+KMEXTRACTONLY="lib/"
+
+need-kde 3.5
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql) --enable-kexi-reports"
+
+ kde-meta_src_compile
+}