summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-01-27 11:42:33 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-01-27 11:42:33 +0000
commitd8f5d817774b273dc395f0a83ca1d085e3b8872d (patch)
treed2d6f91af702733013dc2656326c169963fa2f37 /app-office
parentFix building with linux-2.6.24 #207594 by Eric Bosch. (diff)
downloadgentoo-2-d8f5d817774b273dc395f0a83ca1d085e3b8872d.tar.gz
gentoo-2-d8f5d817774b273dc395f0a83ca1d085e3b8872d.tar.bz2
gentoo-2-d8f5d817774b273dc395f0a83ca1d085e3b8872d.zip
* bump to 1.8.1
(Portage version: 2.1.4)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog8
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-1.8.13
-rw-r--r--app-office/gnumeric/gnumeric-1.8.1.ebuild81
3 files changed, 91 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 0bcc051fa3c5..4868c2982e76 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gnumeric
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.153 2008/01/16 22:48:19 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.154 2008/01/27 11:42:33 eva Exp $
+
+*gnumeric-1.8.1 (27 Jan 2008)
+
+ 27 Jan 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnumeric-1.8.1.ebuild:
+ bump to 1.8.1
16 Jan 2008; Gilles Dartiguelongue <eva@gentoo.org> gnumeric-1.8.0.ebuild:
remove libgnomeprint{,ui} dependencies (bug #206095)
diff --git a/app-office/gnumeric/files/digest-gnumeric-1.8.1 b/app-office/gnumeric/files/digest-gnumeric-1.8.1
new file mode 100644
index 000000000000..e24ac044981c
--- /dev/null
+++ b/app-office/gnumeric/files/digest-gnumeric-1.8.1
@@ -0,0 +1,3 @@
+MD5 a80ae52484b07d772297dcde6c0dab47 gnumeric-1.8.1.tar.bz2 14061489
+RMD160 dca5b88bb135ec37c8a06d48fbebe7fb6bf7deaf gnumeric-1.8.1.tar.bz2 14061489
+SHA256 966acc8b4b175abce4d0c3144daceb11f2f94371755a83db1e2cf4a4405c3486 gnumeric-1.8.1.tar.bz2 14061489
diff --git a/app-office/gnumeric/gnumeric-1.8.1.ebuild b/app-office/gnumeric/gnumeric-1.8.1.ebuild
new file mode 100644
index 000000000000..3f04cd55f1be
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.8.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.8.1.ebuild,v 1.1 2008/01/27 11:42:33 eva Exp $
+
+inherit gnome2 flag-o-matic
+
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+HOMEPAGE="http://www.gnome.org/projects/gnumeric/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="gnome perl python"
+# bonobo libgda mono (experimental)
+
+# lots of missing files, wait for next release
+RESTRICT="test"
+
+RDEPEND="sys-libs/zlib
+ app-arch/bzip2
+ >=dev-libs/glib-2.6
+ >=gnome-extra/libgsf-1.14.6
+ >=x11-libs/goffice-0.5.5
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.8.1
+
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libglade-2.3.6
+ >=media-libs/libart_lgpl-2.3.11
+
+ gnome? (
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libbonobo-2.2
+ >=gnome-base/libbonoboui-2.2 )
+ perl? ( dev-lang/perl )
+ python? (
+ >=dev-lang/python-2
+ >=dev-python/pygtk-2 )"
+ # libgda? (
+ # >=gnome-extra/libgda-3.1.1
+ # >=gnome-extra/libgnomedb-3.0.1 )
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.29
+ >=dev-util/pkgconfig-0.18
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS BEVERAGES BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-ssindex
+ --enable-static
+ --without-mono
+ $(use_with perl)
+ $(use_with python)
+ $(use_with gnome)"
+
+ if use gnome && ! built_with_use gnome-extra/libgsf gnome; then
+ eerror "libgsf needs to be compiled with gnome in USE"
+ eerror "for this version of gnumeric to work. Rebuild"
+ eerror "libgsf first like this :"
+ eerror "USE=gnome emerge libgsf -vp"
+ die "libgsf was built without gnome support..."
+ fi
+
+ # gcc bug (http://bugs.gnome.org/show_bug.cgi?id=128834)
+ replace-flags "-Os" "-O2"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # make gnumeric find its help
+ dosym \
+ /usr/share/gnome/help/gnumeric \
+ /usr/share/${PN}/${PV}/doc
+}