summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-30 04:13:02 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-30 04:13:02 +0000
commitd63e047923293840437b216f12efb9478df7e220 (patch)
tree11c20f54b620767e9baa7f239cb6d8596310134e /app-office
parentuse slightly different syntax for ebuild checking for build or bootstrap (diff)
downloadgentoo-2-d63e047923293840437b216f12efb9478df7e220.tar.gz
gentoo-2-d63e047923293840437b216f12efb9478df7e220.tar.bz2
gentoo-2-d63e047923293840437b216f12efb9478df7e220.zip
new version and schema fix
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog8
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-1.1.51
-rw-r--r--app-office/gnumeric/gnumeric-1.1.5.ebuild88
3 files changed, 96 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index c31ca5077185..963d7abbc802 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gnumeric
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.9 2002/05/23 00:11:06 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.10 2002/05/30 04:13:01 spider Exp $
+
+*gnumeric-1.1.5.ebuild (29 May 2002)
+ 29 May 2002; Spider <spider@gentoo.org> gnumeric-1.1.5.ebuild :
+ schema installations now happen properly
+ update to latest version
+
*gnumeric-1.1.3-r1.ebuild (22 May 2002)
22 May 2002; Spider <spider@gentoo.org> gnumeric-1.1.3-r1.ebuild :
diff --git a/app-office/gnumeric/files/digest-gnumeric-1.1.5 b/app-office/gnumeric/files/digest-gnumeric-1.1.5
new file mode 100644
index 000000000000..2f766ce6f86d
--- /dev/null
+++ b/app-office/gnumeric/files/digest-gnumeric-1.1.5
@@ -0,0 +1 @@
+MD5 622c1a3188dcaef82e0088924ab17255 gnumeric-1.1.5.tar.bz2 6424714
diff --git a/app-office/gnumeric/gnumeric-1.1.5.ebuild b/app-office/gnumeric/gnumeric-1.1.5.ebuild
new file mode 100644
index 000000000000..ec8048df588c
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.1.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.1.5.ebuild,v 1.1 2002/05/30 04:13:02 spider Exp $
+
+#provide Xmake and Xemake
+. /usr/portage/eclass/inherit.eclass
+inherit virtualx
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+SLOT="1.2"
+LICENSE="GPL-2"
+
+
+#Eye Of Gnome (media-gfx/eog) is for image support.
+RDEPEND="=x11-libs/gtk+-2.0*
+ =dev-libs/glib-2.0*
+ >=gnome-base/libgnome-1.105.0
+ >=gnome-base/libgnomeui-1.106.0
+ >=gnome-base/libbonobo-1.106.0
+ >=gnome-base/libbonoboui-1.106.0
+ >=gnome-extra/libgnomeprint-1.106.0
+ >=gnome-extra/libgnomeprintui-1.106.0
+ >=gnome-extra/gal2-0.0.3
+ >=gnome-base/libglade-1.99.10
+ dev-libs/libxml2
+ perl? ( >=sys-devel/perl-5.6 )
+ python? ( >=dev-lang/python-2.0 )
+ gb? ( ~gnome-extra/gb-0.0.17 )
+ libgda? ( >=gnome-extra/libgda-0.2.91
+ >=gnome-base/bonobo-1.0.17 )
+ evo? ( >=net-mail/evolution-0.13 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fix the relink bug, and invalid paths in .ls files.
+ libtoolize --copy --force
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ use gb && myconf="${myconf} --with-gb" || myconf="${myconf} --without-gb"
+
+ use guile && myconf="${myconf} --with-guile" || myconf="${myconf} --without-guile"
+ use perl && myconf="${myconf} --with-perl" || myconf="${myconf} --without-perl"
+ use python && yconf="${myconf} --with-python" || myconf="${myconf} --without-python"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ #'gnumeric --dump-func-defs' needs to write to ${HOME}/.gnome/, or
+ #else the build fails.
+ # addwrite "${HOME}/.gnome"
+
+ #the build process have to be able to connect to X
+ Xemake || Xmake || die
+}
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ install || die
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+}
+
+pkg_postinst() {
+ export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
+ echo ">>> updating GConf2 (modemlights)"
+ for SCHEMA in gnumeric-dialogs.schemas gnumeric-general.schemas ; do
+ echo $SCHEMA
+ /usr/bin/gconftool-2 --makefile-install-rule \
+ /etc/gconf/schemas/${SCHEMA}
+ done
+}