summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2006-07-10 16:51:51 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2006-07-10 16:51:51 +0000
commitbef17ffe89bd913ff857370587db9a1b921e46a2 (patch)
treeb107cdcff8e6f0a56906600067869a5a66fdf754 /app-office
parentMark 0.08 stable on ia64 (diff)
downloadgentoo-2-bef17ffe89bd913ff857370587db9a1b921e46a2.tar.gz
gentoo-2-bef17ffe89bd913ff857370587db9a1b921e46a2.tar.bz2
gentoo-2-bef17ffe89bd913ff857370587db9a1b921e46a2.zip
Revbump thanks to Pacho Ramos see #139823
(Portage version: 2.1-r1)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/ChangeLog7
-rw-r--r--app-office/abiword/abiword-2.4.5.ebuild86
-rw-r--r--app-office/abiword/files/digest-abiword-2.4.53
3 files changed, 95 insertions, 1 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 1df02e9010ec..520d2e8fc05d 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.152 2006/07/05 07:51:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.153 2006/07/10 16:51:51 gustavoz Exp $
+
+*abiword-2.4.5 (10 Jul 2006)
+
+ 10 Jul 2006; Gustavo Zacarias <gustavoz@gentoo.org> +abiword-2.4.5.ebuild:
+ Revbump thanks to Pacho Ramos see #139823
05 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org>
abiword-2.2.10.ebuild, abiword-2.2.11.ebuild, abiword-2.4.1.ebuild,
diff --git a/app-office/abiword/abiword-2.4.5.ebuild b/app-office/abiword/abiword-2.4.5.ebuild
new file mode 100644
index 000000000000..cf9e5bed145a
--- /dev/null
+++ b/app-office/abiword/abiword-2.4.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.4.5.ebuild,v 1.1 2006/07/10 16:51:51 gustavoz Exp $
+
+inherit eutils fdo-mime alternatives
+
+S=${WORKDIR}/${P}/abi
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com/"
+
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gnome spell xml"
+
+LICENSE="GPL-2"
+SLOT="2"
+
+RDEPEND="virtual/xft
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2.4
+ >=x11-libs/pango-1.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2
+ sys-libs/zlib
+ >=media-libs/libpng-1.2
+ dev-libs/popt
+ >=media-libs/fontconfig-2.1
+ >=app-text/wv-1
+ >=dev-libs/fribidi-0.10.4
+ xml? ( >=dev-libs/libxml2-2.4.10 )
+ !xml? ( dev-libs/expat )
+ spell? ( >=app-text/enchant-1.1 )
+ gnome? (
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-extra/gucharmap-1.4 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_compile() {
+ # this is a hack since I don't want to go hack in the gnome-vfs
+ # headerfiles. The issue is about gnome-vfs containing "long long"
+ # which makes gcc 3.3.1 balk
+ sed -i -e 's:-pedantic::g' configure
+
+ local myconf="$(use_enable gnome) \
+ $(use_enable gnome gucharmap) \
+ $(use_enable spell enchant) \
+ $(use_enable debug) \
+ $(use_with xml libxml2) \
+ --enable-threads \
+ --disable-scripting \
+ --with-sys-wv"
+
+ econf $myconf || die "./configure failed"
+
+ emake all-recursive || die "Compilation failed"
+}
+
+src_install() {
+ dodir /usr/{bin,lib}
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dosed "s:Exec=abiword:Exec=abiword-2.4:" /usr/share/applications/abiword.desktop
+
+ rm -f ${D}/usr/bin/abiword-2.4
+ rm -f ${D}/usr/bin/abiword
+ dosym AbiWord-2.4 /usr/bin/abiword-2.4
+
+ dodoc *.TXT docs/build/BUILD.TXT user/wp/readme.txt
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ alternatives_auto_makesym "/usr/bin/abiword" "/usr/bin/abiword-[0-9].[0-9]"
+
+ einfo "As of version 2.4, all abiword plugins have been moved"
+ einfo "into a seperate abiword-plugins package"
+ einfo "You can install them by running emerge abiword-plugins"
+}
diff --git a/app-office/abiword/files/digest-abiword-2.4.5 b/app-office/abiword/files/digest-abiword-2.4.5
new file mode 100644
index 000000000000..92a5bbc12741
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-2.4.5
@@ -0,0 +1,3 @@
+MD5 e018669a154164d31c768f773a1c95b4 abiword-2.4.5.tar.bz2 24930028
+RMD160 f0de27f97135f8fff9b4400b05d74a27eee348cd abiword-2.4.5.tar.bz2 24930028
+SHA256 b8e5f61697c6d796e8f9f0812886666487fd0125bc777ca093c096b4b3e31264 abiword-2.4.5.tar.bz2 24930028