summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-07-15 07:32:42 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-07-15 07:32:42 +0000
commit62cc4be6e882e7567bd3148b87d1726439a6a097 (patch)
tree6af76b74d89fa5ecb49e811a7f33a11bb1211a95 /app-office
parentRemove mask on kcpuload. (diff)
downloadgentoo-2-62cc4be6e882e7567bd3148b87d1726439a6a097.tar.gz
gentoo-2-62cc4be6e882e7567bd3148b87d1726439a6a097.tar.bz2
gentoo-2-62cc4be6e882e7567bd3148b87d1726439a6a097.zip
Add patchset 1.4.0b from koffice.org (#98803).
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/ChangeLog7
-rw-r--r--app-office/koffice/files/digest-koffice-1.4.0-r22
-rw-r--r--app-office/koffice/koffice-1.4.0-r2.ebuild74
3 files changed, 82 insertions, 1 deletions
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index beaab53b2762..02b715f9d119 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/koffice
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.107 2005/07/01 20:26:15 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.108 2005/07/15 07:32:42 greg_g Exp $
+
+*koffice-1.4.0-r2 (15 Jul 2005)
+
+ 15 Jul 2005; Gregorio Guidi <greg_g@gentoo.org> +koffice-1.4.0-r2.ebuild:
+ Add patchset 1.4.0b from koffice.org (#98803).
01 Jul 2005; Gustavo Zacarias <gustavoz@gentoo.org>
koffice-1.4.0-r1.ebuild:
diff --git a/app-office/koffice/files/digest-koffice-1.4.0-r2 b/app-office/koffice/files/digest-koffice-1.4.0-r2
new file mode 100644
index 000000000000..60cbe708324a
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.4.0-r2
@@ -0,0 +1,2 @@
+MD5 3e6fd9f92024de68e5879c22d02a33c5 koffice-1.4.0.tar.bz2 19730186
+MD5 7583370f677d4016e1bf6ab2e85967fe koffice_1.4.0_patchset_1b.diff.bz2 34483
diff --git a/app-office/koffice/koffice-1.4.0-r2.ebuild b/app-office/koffice/koffice-1.4.0-r2.ebuild
new file mode 100644
index 000000000000..8338ede3e7f0
--- /dev/null
+++ b/app-office/koffice/koffice-1.4.0-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.4.0-r2.ebuild,v 1.1 2005/07/15 07:32:42 greg_g Exp $
+
+inherit kde eutils
+
+DESCRIPTION="An integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+SRC_URI="mirror://kde/stable/koffice-1.4/src/${P}.tar.bz2
+ http://www.koffice.org/bugfixes/koffice_1.4.0_patchset_1b.diff.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc javascript mysql postgres"
+
+RDEPEND=">=media-gfx/imagemagick-5.5.2
+ >=app-text/wv2-0.1.9
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/readline
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-libs/libpqxx )
+ dev-lang/python
+ >=media-libs/lcms-1.12
+ javascript? ( kde-base/kjsembed )
+ !dev-db/kexi"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+# add blockers on split packages derived from this one
+for x in $(get-child-packages ${CATEGORY}/${PN}); do
+ DEPEND="${DEPEND} !${x}"
+ RDEPEND="${RDEPEND} !${x}"
+done
+
+need-kde 3.3
+
+# TODO: kword sql plugin needs Qt compiled with sql support
+# the dependency on python is needed for scripting support in kexi
+# and for kivio/kiviopart/kiviosdk.
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix problem when saving from koshell. Applied for 1.4.1.
+ epatch "${FILESDIR}/${P}-save.patch"
+
+ # Patchset 1.4.0b. Applied for 1.4.1.
+ epatch ${WORKDIR}/koffice_1.4.0_patchset_1b.diff
+}
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql)"
+
+ kde_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde_src_install
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+
+ dodoc changes-*
+}