summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-10-16 23:21:59 +0000
committerMarinus Schraal <foser@gentoo.org>2002-10-16 23:21:59 +0000
commit524eb9ce8ab14a7fd58e1d8898f8a4f988d37b94 (patch)
tree42866ff0d1f8bf7e478d60d22ce1a407462c8b2d /app-office
parentspace fix [lintool] for #9212 (diff)
downloadgentoo-2-524eb9ce8ab14a7fd58e1d8898f8a4f988d37b94.tar.gz
gentoo-2-524eb9ce8ab14a7fd58e1d8898f8a4f988d37b94.tar.bz2
gentoo-2-524eb9ce8ab14a7fd58e1d8898f8a4f988d37b94.zip
New version
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/ChangeLog7
-rw-r--r--app-office/abiword/abiword-1.0.3.ebuild156
-rw-r--r--app-office/abiword/files/abiword-1.0.3-aspell.patch19
-rw-r--r--app-office/abiword/files/digest-abiword-1.0.31
4 files changed, 182 insertions, 1 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 49ccca5fcce3..732870e8e412 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.15 2002/09/03 10:48:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.16 2002/10/16 23:21:59 foser Exp $
+
+*abiword-1.0.3 (17 Oct 2002)
+
+ 17 Oct 2002; foser <foser@gentoo.org> abiword-1.0.3.ebuild :
+ New version, new aspell fix
*abiword-1.0.2-r1 (02 Sep 2002)
diff --git a/app-office/abiword/abiword-1.0.3.ebuild b/app-office/abiword/abiword-1.0.3.ebuild
new file mode 100644
index 000000000000..4cfeb2b664bc
--- /dev/null
+++ b/app-office/abiword/abiword-1.0.3.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.0.3.ebuild,v 1.1 2002/10/16 23:21:59 foser Exp $
+
+IUSE="perl nls gnome build spell jpeg xml2"
+
+S=${WORKDIR}/${P}/abi
+DESCRIPTION="Text processor"
+SRC_URI="http://download.sourceforge.net/abiword/abiword-${PV}.tar.gz"
+HOMEPAGE="http://www.abisource.com"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="virtual/x11
+ media-libs/libpng
+ >=dev-libs/libunicode-0.4-r1
+ =x11-libs/gtk+-1.2*
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ perl? ( >=sys-devel/perl-5.6 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )
+ spell? ( >=app-text/aspell-0.50 )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1
+ >=gnome-extra/gal-0.13-r1
+ >=gnome-base/bonobo-1.0.9-r1 )"
+
+
+fix_perl_env() {
+ # new configure scripts is a bit broken
+ export PERL_ARCHLIB="`(perl -V:installarchlib | sed -e "s/\(.*=\|'\|;\)//g\")`"
+ export PERL_LIB="`(perl -V:installprivlib | sed -e "s/\(.*=\|'\|;\)//g\")`"
+ export POD2MAN_EXE="`which pod2man`"
+ export SITE_LIB="`(perl -V:sitelib | sed -e "s/\(.*=\|'\|;\)//g\")`"
+ export SITE_ARCHLIB="`(perl -V:sitearch | sed -e "s/\(.*=\|'\|;\)//g\")`"
+}
+
+src_unpack() {
+
+ unpack ${A}
+
+ use perl && ( \
+ fix_perl_env
+
+ # Fix perl stuff install outside sandbox, as well as a bug in
+ # Abiword's build system (Abiword.3pm did not install, and
+ # the '.packlist' was not generated properly) -- Azarah (25/02/2002).
+ cd ${S}/src/bindings/perl
+ cp GNUmakefile.am GNUmakefile.am.orig
+ sed -e "s:PERL_ARCHLIB = @PERL_ARCHLIB@:PERL_ARCHLIB = ${PERL_ARCHLIB}:" \
+ -e "s:PERL_LIB = @PERL_LIB@:PERL_LIB = ${PERL_LIB}:" \
+ -e "s:POD2MAN_EXE = @POD2MAN_EXE@:POD2MAN_EXE = ${POD2MAN_EXE}:" \
+ -e "s:SITE_LIB = @SITE_LIB@:SITE_LIB = ${SITE_LIB}:" \
+ -e "s:SITE_ARCHLIB = @SITE_ARCHLIB@:SITE_ARCHLIB = ${SITE_ARCHLIB}:" \
+ -e 's:write $(SITE_ARCHLIB)/auto:write $(PERLDEST)/$(SITE_ARCHLIB)/auto:g' \
+ -e 's:blib/lib $(SITE_LIB):blib/lib $(PERLDEST)/$(SITE_LIB):g' \
+ -e 's:blib/arch $(SITE_ARCHLIB):blib/arch $(PERLDEST)/$(SITE_ARCHLIB):g' \
+ -e 's:blib/bin /usr/bin:blib/bin $(PERLDEST)/usr/bin:g' \
+ -e 's:blib/script /usr/bin:blib/script $(PERLDEST)/usr/bin:g' \
+ -e 's:blib/man1 /usr/share/man/man1:blib/man1 $(PERLDEST)/usr/share/man/man1:g' \
+ -e 's:blib/man3 /usr/share/man/man3:blib/man3 $(PERLDEST)/usr/share/man/man3:g' \
+ -e 's:mkpath $(PERL_ARCHLIB):mkpath $(PERLDEST)/$(PERL_ARCHLIB):g' \
+ -e 's:$(PERL_ARCHLIB)/perllocal.pod:$(PERLDEST)/$(PERL_ARCHLIB)/perllocal.pod.new:' \
+ GNUmakefile.am.orig >GNUmakefile.am || die
+ mkdir -p blib/{arch,bin,lib,man1,man3,script}
+ cd ${S}
+ )
+
+ # Fix m4 macro to make it use the new aspell-0.50 instead of
+ # pspell-ispell as before. MUCH thanks to dom, the abiword project
+ # lead.
+
+ patch -d ${S} -p1 < ${FILESDIR}/abiword-1.0.3-aspell.patch
+
+ # clear invalid symlinks
+ rm -f ac-helpers/{install-sh,mkinstalldirs,missing}
+}
+
+src_compile() {
+
+ local myconf
+
+ use gnome \
+ && myconf="${myconf} --with-gnome --enable-gnome" \
+ && export ABI_OPT_BONOBO=1
+
+ use perl \
+ && myconf="${myconf} --enable-scripting"
+
+ use spell \
+ && myconf="${myconf} --with-pspell"
+
+ use xml2 \
+ && myconf="${myconf} --with-libxml2"
+
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg"
+
+ use nls \
+ && myconf="${myconf} --enable-bidi"
+
+ ./autogen.sh
+
+ echo
+ echo "*************************************************"
+ echo "* Ignore above ERROR as it does not cause build *"
+ echo "* to fail. *"
+ echo "*************************************************"
+ echo
+
+ CFLAGS="${CFLAGS} `gdk-pixbuf-config --cflags`"
+
+ econf \
+ ${myconf} || die
+
+# --enable-extra-optimization \
+
+ # Doesn't work with -j 4 (hallski)
+ make UNIX_CAN_BUILD_STATIC=0 \
+ OPTIMIZER="${CFLAGS}" || die
+}
+
+src_install() {
+
+ dodir /usr/{bin,lib}
+
+ einstall PERLDEST=${D} || die
+
+ dosed "s:${D}::g" /usr/bin/AbiWord
+
+ rm -f ${D}/usr/bin/abiword
+ dosym /usr/bin/AbiWord /usr/bin/abiword
+
+ dodoc BUILD COPYING *.txt, *.TXT
+
+ # Install icon and .desktop for menu entry
+ use gnome && ( \
+ insinto /usr/share/pixmaps
+ newins ${WORKDIR}/${P}/abidistfiles/icons/abiword_48.png AbiWord.png
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/AbiWord.desktop
+ )
+}
+
+pkg_postinst() {
+
+ # Appending installation info
+ local perlver="`perl -v | grep -e "This is perl" | cut -d ' ' -f 4`"
+ perlver=${perlver/v/}
+ local perlarch="`perl -V | grep -e " archname" | cut -d '=' -f 4`"
+ if [ -f /usr/lib/perl5/${perlver}/${perlarch}/perllocal.pod.new ] ; then
+ sed -e "s:5.6.0:${perlver}:g" \
+ /usr/lib/perl5/${perlver}/${perlarch}/perllocal.pod.new \
+ >> /usr/lib/perl5/${perlver}/${perlarch}/perllocal.pod
+ rm -rf /usr/lib/perl5/${perlver}/${perlarch}/perllocal.pod.new
+ fi
+}
+
diff --git a/app-office/abiword/files/abiword-1.0.3-aspell.patch b/app-office/abiword/files/abiword-1.0.3-aspell.patch
new file mode 100644
index 000000000000..61d611069c92
--- /dev/null
+++ b/app-office/abiword/files/abiword-1.0.3-aspell.patch
@@ -0,0 +1,19 @@
+--- abi/ac-helpers/abi-spell.m4 2002-06-06 21:44:16.000000000 +0200
++++ abi/ac-helpers/abi-spell.m4.new 2002-10-16 23:37:57.000000000 +0200
+@@ -41,12 +41,12 @@
+ if test $abi_spell = psyspell; then
+ _abi_cppflags="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS -I$ABI_PSPELL_DIR/include"
+- abi_pspell_libs="-L$ABI_PSPELL_DIR/lib -lpspell -lpspell-modules -lltdl"
++ abi_pspell_libs="-L$ABI_PSPELL_DIR/lib -laspell -lltdl"
+ else
+- abi_pspell_libs="-lpspell -lpspell-modules -lltdl"
++ abi_pspell_libs="-laspell -lltdl"
+ fi
+- AC_CHECK_HEADER(pspell/pspell.h,[
+- AC_CHECK_LIB(pspell,new_pspell_config,[
++ AC_CHECK_HEADER(aspell.h,[
++ AC_CHECK_LIB(aspell,new_aspell_config,[
+ SPELL_LIBS="$abi_pspell_libs"
+ ],[ AC_MSG_ERROR([* * * pspell not found in system location * * *])
+ ],$abi_pspell_libs)
diff --git a/app-office/abiword/files/digest-abiword-1.0.3 b/app-office/abiword/files/digest-abiword-1.0.3
new file mode 100644
index 000000000000..a1ad6f14824d
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-1.0.3
@@ -0,0 +1 @@
+MD5 01336526136b7fbc66328d80931710e3 abiword-1.0.3.tar.gz 19443331