summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-06-08 17:13:09 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-06-08 17:13:09 +0000
commit16214c4eebf6c80fe2c5aa84b197e40991c25d0e (patch)
treee6a748a8ae40d687d6043146e422b870576bbd15 /app-office
parentVersion bump (diff)
downloadgentoo-2-16214c4eebf6c80fe2c5aa84b197e40991c25d0e.tar.gz
gentoo-2-16214c4eebf6c80fe2c5aa84b197e40991c25d0e.tar.bz2
gentoo-2-16214c4eebf6c80fe2c5aa84b197e40991c25d0e.zip
Version bump.
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kexi/ChangeLog7
-rw-r--r--app-office/kexi/files/digest-kexi-1.6.33
-rw-r--r--app-office/kexi/kexi-1.6.3.ebuild46
3 files changed, 55 insertions, 1 deletions
diff --git a/app-office/kexi/ChangeLog b/app-office/kexi/ChangeLog
index 9c547fdeec8b..ee1843faafed 100644
--- a/app-office/kexi/ChangeLog
+++ b/app-office/kexi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kexi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.76 2007/05/15 19:12:11 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.77 2007/06/08 17:13:09 carlo Exp $
+
+*kexi-1.6.3 (08 Jun 2007)
+
+ 08 Jun 2007; Carsten Lohrke <carlo@gentoo.org> +kexi-1.6.3.ebuild:
+ Version bump.
*kexi-1.6.2-r2 (15 May 2007)
diff --git a/app-office/kexi/files/digest-kexi-1.6.3 b/app-office/kexi/files/digest-kexi-1.6.3
new file mode 100644
index 000000000000..0dc1fc75f716
--- /dev/null
+++ b/app-office/kexi/files/digest-kexi-1.6.3
@@ -0,0 +1,3 @@
+MD5 386d388094734f9759977c3267098e30 koffice-1.6.3.tar.bz2 56829391
+RMD160 e474ba48fa983fafb61ad58fb79cddda69ec6908 koffice-1.6.3.tar.bz2 56829391
+SHA256 c3975f0a59f50aaa5547f1709b6fad54f746fd06815859b374676b426dce12cb koffice-1.6.3.tar.bz2 56829391
diff --git a/app-office/kexi/kexi-1.6.3.ebuild b/app-office/kexi/kexi-1.6.3.ebuild
new file mode 100644
index 000000000000..28e9c9044a75
--- /dev/null
+++ b/app-office/kexi/kexi-1.6.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.6.3.ebuild,v 1.1 2007/06/08 17:13:09 carlo Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated environment for database management."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres kdeenablefinal"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ sys-libs/readline
+ mysql? ( virtual/mysql )
+ postgres? ( <dev-libs/libpqxx-2.6.9 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoproperty lib/koproperty
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkrossmain lib/kross/main/
+ libkrossapi lib/kross/api/"
+
+KMEXTRACTONLY="lib/"
+
+need-kde 3.5
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql) --enable-kexi-reports"
+
+ kde-meta_src_compile
+}