summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Kohl <citizen428@gentoo.org>2005-03-02 12:39:08 +0000
committerMichael Kohl <citizen428@gentoo.org>2005-03-02 12:39:08 +0000
commit5176eb843e0a764536fc39fae0ba5b95335f83a3 (patch)
tree61a4e0d63fe22a77d363b67b03530de2e6a863a1 /app-office/tpp
parentAdded app-office/tpp:figlet (diff)
downloadgentoo-2-5176eb843e0a764536fc39fae0ba5b95335f83a3.tar.gz
gentoo-2-5176eb843e0a764536fc39fae0ba5b95335f83a3.tar.bz2
gentoo-2-5176eb843e0a764536fc39fae0ba5b95335f83a3.zip
Initial import. Requested by Adrian Fruehwirth <fruehwia@spengergasse.at> in bug #73938
(Portage version: 2.0.51.18)
Diffstat (limited to 'app-office/tpp')
-rw-r--r--app-office/tpp/ChangeLog11
-rw-r--r--app-office/tpp/Manifest3
-rw-r--r--app-office/tpp/files/digest-tpp-1.1.11
-rw-r--r--app-office/tpp/files/tpp-1.1.1-Makefile.patch24
-rw-r--r--app-office/tpp/metadata.xml5
-rw-r--r--app-office/tpp/tpp-1.1.1.ebuild35
6 files changed, 79 insertions, 0 deletions
diff --git a/app-office/tpp/ChangeLog b/app-office/tpp/ChangeLog
new file mode 100644
index 000000000000..7a8f66ac6a85
--- /dev/null
+++ b/app-office/tpp/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-office/tpp
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/tpp/ChangeLog,v 1.1 2005/03/02 12:39:08 citizen428 Exp $
+
+*tpp-1.1.1 (02 Mar 2005)
+
+ 02 Mar 2005; Michael Kohl <citizen428@gentoo.org> +metadata.xml,
+ +files/tpp-1.1.1-Makefile.patch, +tpp-1.1.1.ebuild:
+ Initial import. Requested by Adrian Fruehwirth <fruehwia@spengergasse.at> in
+ bug #73938
+
diff --git a/app-office/tpp/Manifest b/app-office/tpp/Manifest
new file mode 100644
index 000000000000..f6146ca04b76
--- /dev/null
+++ b/app-office/tpp/Manifest
@@ -0,0 +1,3 @@
+MD5 1f368c948a85f4b38614367d86f51e03 tpp-1.1.1.ebuild 610
+MD5 b522b82d2c47bc548a6607f0f577ab5e metadata.xml 158
+MD5 88742db74aaaa305de59c9405e8f39c5 files/digest-tpp-1.1.1 60
diff --git a/app-office/tpp/files/digest-tpp-1.1.1 b/app-office/tpp/files/digest-tpp-1.1.1
new file mode 100644
index 000000000000..9d58a92167e8
--- /dev/null
+++ b/app-office/tpp/files/digest-tpp-1.1.1
@@ -0,0 +1 @@
+MD5 6fe56942af5e4e8c795994ba19a2cd08 tpp-1.1.1.tar.gz 26822
diff --git a/app-office/tpp/files/tpp-1.1.1-Makefile.patch b/app-office/tpp/files/tpp-1.1.1-Makefile.patch
new file mode 100644
index 000000000000..564e08290456
--- /dev/null
+++ b/app-office/tpp/files/tpp-1.1.1-Makefile.patch
@@ -0,0 +1,24 @@
+--- Makefile 2005-03-02 12:46:07.000000000 +0100
++++ Makefile.new 2005-03-02 13:12:56.657585504 +0100
+@@ -3,15 +3,17 @@
+ #################################################
+
+ BIN = tpp
+-prefix=/usr/local
+-INSPATH= $(prefix)/bin/
+-DOCPATH = $(prefix)/share/doc/tpp
+-MANPATH = $(prefix)/man/man1
++prefix=/usr
++INSPATH= $(DESTDIR)$(prefix)/bin/
++DOCPATH = $(DESTDIR)$(prefix)/share/doc/tpp
++MANPATH = $(DESTDIR)$(prefix)/man/man1
+
+ install :
+ mkdir -p $(DOCPATH)
+ install -m644 CHANGES COPYING README THANKS $(DOCPATH)
++ mkdir -p $(MANPATH)
+ install -m644 doc/tpp.1 $(MANPATH)
++ mkdir -p $(INSPATH)
+ install tpp.rb $(INSPATH)$(BIN)
+ mkdir -p $(DOCPATH)/contrib
+ mkdir -p $(DOCPATH)/examples
diff --git a/app-office/tpp/metadata.xml b/app-office/tpp/metadata.xml
new file mode 100644
index 000000000000..0040b1162894
--- /dev/null
+++ b/app-office/tpp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+</pkgmetadata>
diff --git a/app-office/tpp/tpp-1.1.1.ebuild b/app-office/tpp/tpp-1.1.1.ebuild
new file mode 100644
index 000000000000..673ab9257e3b
--- /dev/null
+++ b/app-office/tpp/tpp-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/tpp/tpp-1.1.1.ebuild,v 1.1 2005/03/02 12:39:08 citizen428 Exp $
+
+inherit eutils ruby
+
+DESCRIPTION="An ncurses-based presentation tool."
+HOMEPAGE="http://synflood.at/tpp.html"
+SRC_URI="http://synflood.at/tpp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="figlet"
+
+USE_RUBY="ruby18"
+
+RDEPEND="virtual/ruby
+ dev-ruby/ncurses-ruby
+ figlet? ( app-misc/figlet )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-Makefile.patch
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}