summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-03 10:51:38 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-03 10:51:38 +0000
commit1cdc02ab47e63ac7af2be90faaf599b341faa035 (patch)
tree2d2035da783ad8d66f8381c3555aed4608182409 /app-office/texmaker
parentFix missing library (bug #489112). Thanks for reporting mgorny (diff)
downloadgentoo-2-1cdc02ab47e63ac7af2be90faaf599b341faa035.tar.gz
gentoo-2-1cdc02ab47e63ac7af2be90faaf599b341faa035.tar.bz2
gentoo-2-1cdc02ab47e63ac7af2be90faaf599b341faa035.zip
app-office/texmaker: Version BUmp, #490220
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-4.1-unbundle.patch105
-rw-r--r--app-office/texmaker/texmaker-4.1.ebuild85
3 files changed, 197 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 12516c29e3f8..4c65511650bd 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.136 2013/10/26 09:47:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.137 2013/11/03 10:51:38 jlec Exp $
+
+*texmaker-4.1 (03 Nov 2013)
+
+ 03 Nov 2013; Justin Lecher <jlec@gentoo.org> +texmaker-4.1.ebuild,
+ +files/texmaker-4.1-unbundle.patch:
+ Version BUmp, #490220
*texmaker-4.0.4-r1 (26 Oct 2013)
diff --git a/app-office/texmaker/files/texmaker-4.1-unbundle.patch b/app-office/texmaker/files/texmaker-4.1-unbundle.patch
new file mode 100644
index 000000000000..1e7e152b6d55
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-4.1-unbundle.patch
@@ -0,0 +1,105 @@
+ configdialog.cpp | 2 +-
+ texmaker.cpp | 4 ++--
+ texmaker.pro | 42 +-----------------------------------------
+ 3 files changed, 4 insertions(+), 44 deletions(-)
+
+diff --git a/configdialog.cpp b/configdialog.cpp
+index e596a2c..3660429 100644
+--- a/configdialog.cpp
++++ b/configdialog.cpp
+@@ -220,7 +220,7 @@ void ConfigDialog::browseAspell()
+ QDir spelldir(QCoreApplication::applicationDirPath());
+ #else
+ #ifdef DEBIAN_SPELLDIR
+-QDir spelldir(PREFIX"/share/myspell/dicts");
++QDir spelldir(PREFIX"/share/myspell");
+ #else
+ QDir spelldir(PREFIX"/share/texmaker");
+ #endif
+diff --git a/texmaker.cpp b/texmaker.cpp
+index 51d2082..607f66e 100644
+--- a/texmaker.cpp
++++ b/texmaker.cpp
+@@ -4363,7 +4363,7 @@ geometry_options=config->value("Quick/GeometryOptions","left=2cm,right=2cm,top=2
+ QString dicDir=QCoreApplication::applicationDirPath() + "/";
+ #else
+ #ifdef DEBIAN_SPELLDIR
+-QString dicDir=PREFIX"/share/myspell/dicts/";
++QString dicDir=PREFIX"/share/myspell/";
+ #else
+ QString dicDir=PREFIX"/share/texmaker/";
+ #endif
+@@ -10835,4 +10835,4 @@ if (singlemode && currentEditorView())
+ UpdateBibliography();
+ }
+ }
+-}
+\ No newline at end of file
++}
+diff --git a/texmaker.pro b/texmaker.pro
+index bce8dd4..2f205bb 100644
+--- a/texmaker.pro
++++ b/texmaker.pro
+@@ -95,29 +95,6 @@ HEADERS += texmaker.h \
+ unicodedialog.h \
+ unicodeview.h \
+ quickbeamerdialog.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell \
+- hunspell/filemgr.hxx \
+- hunspell/hunzip.hxx \
+- hunspell/replist.hxx \
+- hunspell/w_char.hxx \
+- singleapp/qtlocalpeer.h \
+- singleapp/qtlockedfile.h \
+- singleapp/qtsingleapplication.h \
+- singleapp/qtsinglecoreapplication.h \
+ encodingprober/CharDistribution.h \
+ encodingprober/ChineseGroupProber.h \
+ encodingprober/ctype_test_p.h \
+@@ -204,22 +181,6 @@ SOURCES += main.cpp \
+ unicodedialog.cpp \
+ unicodeview.cpp \
+ quickbeamerdialog.cpp \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx \
+- hunspell/filemgr.cxx \
+- hunspell/replist.cxx \
+- hunspell/hunzip.cxx \
+- singleapp/qtlocalpeer.cpp \
+- singleapp/qtlockedfile.cpp \
+- singleapp/qtsingleapplication.cpp \
+- singleapp/qtsinglecoreapplication.cpp \
+ encodingprober/CharDistribution.cpp \
+ encodingprober/ChineseGroupProber.cpp \
+ encodingprober/JapaneseGroupProber.cpp \
+@@ -328,8 +289,7 @@ icon.path = $${ICONDIR}
+
+ INSTALLS = target
+ HEADERS += x11fontdialog.h
+-SOURCES += x11fontdialog.cpp \
+- singleapp/qtlockedfile_unix.cpp
++SOURCES += x11fontdialog.cpp
+ FORMS += x11fontdialog.ui
+
+ utilities.files = doc/doc1.png \
diff --git a/app-office/texmaker/texmaker-4.1.ebuild b/app-office/texmaker/texmaker-4.1.ebuild
new file mode 100644
index 000000000000..9a3afdedb178
--- /dev/null
+++ b/app-office/texmaker/texmaker-4.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-4.1.ebuild,v 1.1 2013/11/03 10:51:38 jlec Exp $
+
+EAPI=5
+
+inherit qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+MY_P="${P}"
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ dev-qt/qtsingleapplication
+ dev-qt/qtwebkit:4
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-i18n/ibus-qt
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-unbundle.patch )
+
+DOCS=( utilities/AUTHORS utilities/CHANGELOG.txt )
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ find singleapp hunspell -delete || die
+
+ qt4-r2_src_prepare
+
+ cat >> ${PN}.pro <<- EOF
+ exists(texmakerx_my.pri):include(texmakerx_my.pri)
+ EOF
+ cp "${FILESDIR}"/texmakerx_my.pri . || die
+
+ sed \
+ -e '/^#include/s:hunspell/::g' \
+ -e '/^#include/s:singleapp/::g' \
+ -i *.cpp *.h || die
+}
+
+src_configure() {
+ eqmake4 \
+ ${PN}.pro \
+ PREFIX="${EPREFIX}/usr" \
+ DESKTOPDIR="${EPREFIX}/usr/share/applications" \
+ ICONDIR="${EPREFIX}/usr/share/pixmaps"
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}