summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2011-11-20 22:18:27 +0000
committerVlastimil Babka <caster@gentoo.org>2011-11-20 22:18:27 +0000
commitfb8ed29e3d4e014792703dce7729163fe03a65e7 (patch)
tree334c852e72bd07812045ae45b5786561d98d5165 /app-office/taskcoach
parentBlargh. Undid that again, the patch belongs to another ebuild. :| (diff)
downloadgentoo-2-fb8ed29e3d4e014792703dce7729163fe03a65e7.tar.gz
gentoo-2-fb8ed29e3d4e014792703dce7729163fe03a65e7.tar.bz2
gentoo-2-fb8ed29e3d4e014792703dce7729163fe03a65e7.zip
Version bump.
(Portage version: 2.2.0_alpha68/cvs/Linux x86_64)
Diffstat (limited to 'app-office/taskcoach')
-rw-r--r--app-office/taskcoach/ChangeLog7
-rw-r--r--app-office/taskcoach/taskcoach-1.2.31.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index 73442dbc94a0..6ca98251d2df 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.79 2011/11/04 23:23:25 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.80 2011/11/20 22:18:27 caster Exp $
+
+*taskcoach-1.2.31 (20 Nov 2011)
+
+ 20 Nov 2011; Vlastimil Babka <caster@gentoo.org> +taskcoach-1.2.31.ebuild:
+ Version bump.
*taskcoach-1.2.30 (04 Nov 2011)
diff --git a/app-office/taskcoach/taskcoach-1.2.31.ebuild b/app-office/taskcoach/taskcoach-1.2.31.ebuild
new file mode 100644
index 000000000000..19f5ddbf7c3a
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-1.2.31.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.2.31.ebuild,v 1.1 2011/11/20 22:18:27 caster Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+PYTHON_MODNAME="buildlib taskcoachlib"
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org http://pypi.python.org/pypi/TaskCoach"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}
+ libnotify? ( dev-python/notify-python )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt"
+
+src_install() {
+ distutils_src_install
+
+ # a bit ugly but...
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ for file in "${D}"/usr/bin/taskcoach.py-*; do
+ dir=$(dirname ${file})
+ ver=$(basename ${file})
+ ver=${ver#taskcoach.py-}
+ mv "${file}" "${dir}/taskcoach-${ver}" || die
+ done
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}