summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-07-12 07:48:13 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-07-12 07:48:13 +0000
commit0bb655bb0833924952ec39d9fdf4c30e8dcf33af (patch)
tree520d3afa3f757a9539a4326f04c6f72043622cb5 /app-office/sc
parentAdded to ~ppc (diff)
downloadgentoo-2-0bb655bb0833924952ec39d9fdf4c30e8dcf33af.tar.gz
gentoo-2-0bb655bb0833924952ec39d9fdf4c30e8dcf33af.tar.bz2
gentoo-2-0bb655bb0833924952ec39d9fdf4c30e8dcf33af.zip
Bump to a version that's only two and a half years old. This appears unmaintained and I intend to leave it that way for now, so please kick me if I'm wrong.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-office/sc')
-rw-r--r--app-office/sc/ChangeLog10
-rw-r--r--app-office/sc/files/digest-sc-7.161
-rw-r--r--app-office/sc/files/sc-7.16-amd64.patch13
-rw-r--r--app-office/sc/sc-7.16.ebuild42
4 files changed, 65 insertions, 1 deletions
diff --git a/app-office/sc/ChangeLog b/app-office/sc/ChangeLog
index 07f311348206..eadd5f2ba8d7 100644
--- a/app-office/sc/ChangeLog
+++ b/app-office/sc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-office/sc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/sc/ChangeLog,v 1.12 2005/04/21 20:00:24 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/sc/ChangeLog,v 1.13 2005/07/12 07:48:13 spyderous Exp $
+
+*sc-7.16 (12 Jul 2005)
+
+ 12 Jul 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/sc-7.16-amd64.patch, +sc-7.16.ebuild:
+ Bump to a version that's only two and a half years old. This appears
+ unmaintained and I intend to leave it that way for now, so please kick me if
+ I'm wrong.
21 Apr 2005; Simon Stelling <blubb@gentoo.org> sc-7.12.ebuild:
stable on amd64
diff --git a/app-office/sc/files/digest-sc-7.16 b/app-office/sc/files/digest-sc-7.16
new file mode 100644
index 000000000000..c104db34fee3
--- /dev/null
+++ b/app-office/sc/files/digest-sc-7.16
@@ -0,0 +1 @@
+MD5 1db636e9b2dc7cd73c40aeece6852d47 sc-7.16.tar.gz 210809
diff --git a/app-office/sc/files/sc-7.16-amd64.patch b/app-office/sc/files/sc-7.16-amd64.patch
new file mode 100644
index 000000000000..2133ed42e325
--- /dev/null
+++ b/app-office/sc/files/sc-7.16-amd64.patch
@@ -0,0 +1,13 @@
+--- xmalloc.c.orig 2004-07-11 22:34:48.681076912 +0200
++++ xmalloc.c 2004-07-11 22:34:57.150789320 +0200
+@@ -6,8 +6,8 @@
+ #include <curses.h>
+ #include "sc.h"
+
+-extern char *malloc();
+-extern char *realloc();
++extern void *malloc(size_t size);
++extern void *realloc();
+ extern void free();
+ void fatal();
+
diff --git a/app-office/sc/sc-7.16.ebuild b/app-office/sc/sc-7.16.ebuild
new file mode 100644
index 000000000000..b4c8b9a97036
--- /dev/null
+++ b/app-office/sc/sc-7.16.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/sc/sc-7.16.ebuild,v 1.1 2005/07/12 07:48:13 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="sc is a free curses-based spreadsheet program that uses key bindings similar to vi and less."
+SRC_URI="ftp://ibiblio.org/pub/Linux/apps/financial/spreadsheet/${P}.tar.gz"
+HOMEPAGE="http://ibiblio.org/pub/Linux/apps/financial/spreadsheet/"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4.0.5
+ >=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-amd64.patch
+}
+
+src_compile() {
+ make CFLAGS="-DSYSV3 $CFLAGS" prefix=/usr || die
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ dodir /usr/lib/sc
+ make prefix=${D}/usr MANDIR=${D}/usr/share/man/man1 install || die
+
+ sed -i "s:${D}::g" sc.1
+ doman sc.1 psc.1
+
+ dodoc CHANGES README sc.doc psc.doc tutorial.sc
+ dodoc VMS_NOTES ${P}.lsm TODO SC.MACROS
+}
+
+# vim: ai et sw=4 ts=4