summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-09-24 09:58:29 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-09-24 09:58:29 +0000
commit16cdb99790eb27a4c7ca19b66c9e079d768d0fe4 (patch)
treee99bc983f82439f2cd933afb2558214a0b351ec2 /app-office/magicpoint
parentVersion bump (diff)
downloadgentoo-2-16cdb99790eb27a4c7ca19b66c9e079d768d0fe4.tar.gz
gentoo-2-16cdb99790eb27a4c7ca19b66c9e079d768d0fe4.tar.bz2
gentoo-2-16cdb99790eb27a4c7ca19b66c9e079d768d0fe4.zip
version bump, a lot of bugfixes; on Gentoo side we have better Emacs support; in total fixing bugs 150312, 83313 and 186754
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-office/magicpoint')
-rw-r--r--app-office/magicpoint/ChangeLog9
-rw-r--r--app-office/magicpoint/files/50magicpoint-gentoo.el5
-rw-r--r--app-office/magicpoint/files/digest-magicpoint-1.12a3
-rw-r--r--app-office/magicpoint/magicpoint-1.12a.ebuild115
4 files changed, 131 insertions, 1 deletions
diff --git a/app-office/magicpoint/ChangeLog b/app-office/magicpoint/ChangeLog
index e503455d746c..a5311654d7c5 100644
--- a/app-office/magicpoint/ChangeLog
+++ b/app-office/magicpoint/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/magicpoint
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/ChangeLog,v 1.24 2007/07/22 09:58:40 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/ChangeLog,v 1.25 2007/09/24 09:58:29 opfer Exp $
+
+*magicpoint-1.12a (24 Sep 2007)
+
+ 24 Sep 2007; Christian Faulhammer <opfer@gentoo.org>
+ +files/50magicpoint-gentoo.el, +magicpoint-1.12a.ebuild:
+ version bump, a lot of bugfixes; on Gentoo side we have better Emacs
+ support; in total fixing bugs 150312, 83313 and 186754
22 Jul 2007; Denis Dupeyron <calchan@gentoo.org> magicpoint-1.11b.ebuild:
Drop virtual/x11 dependency.
diff --git a/app-office/magicpoint/files/50magicpoint-gentoo.el b/app-office/magicpoint/files/50magicpoint-gentoo.el
new file mode 100644
index 000000000000..27b88da7be9f
--- /dev/null
+++ b/app-office/magicpoint/files/50magicpoint-gentoo.el
@@ -0,0 +1,5 @@
+;;; magicpoint site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'mgp-mode "mgp-mode" "MagicPoint editor mode" t)
+(setq auto-mode-alist (cons '("\\.mgp$" . mgp-mode) auto-mode-alist))
diff --git a/app-office/magicpoint/files/digest-magicpoint-1.12a b/app-office/magicpoint/files/digest-magicpoint-1.12a
new file mode 100644
index 000000000000..6387a6588b95
--- /dev/null
+++ b/app-office/magicpoint/files/digest-magicpoint-1.12a
@@ -0,0 +1,3 @@
+MD5 fc2cb825098c70e7ad649eb0572e7732 magicpoint-1.12a.tar.gz 884584
+RMD160 a01f835a63a9e93d377861f472990e3f3a70b724 magicpoint-1.12a.tar.gz 884584
+SHA256 8b999e76d569d31830c9a54ee2c9a2e1004e7c04b0ad3ea8d0d7f47518d58198 magicpoint-1.12a.tar.gz 884584
diff --git a/app-office/magicpoint/magicpoint-1.12a.ebuild b/app-office/magicpoint/magicpoint-1.12a.ebuild
new file mode 100644
index 000000000000..401d67a87796
--- /dev/null
+++ b/app-office/magicpoint/magicpoint-1.12a.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/magicpoint-1.12a.ebuild,v 1.1 2007/09/24 09:58:29 opfer Exp $
+
+inherit autotools elisp-common eutils fixheadtails
+
+DESCRIPTION="an X11 based presentation tool"
+SRC_URI="ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/${P}.tar.gz
+ ftp://ftp.mew.org/pub/MagicPoint/${P}.tar.gz"
+HOMEPAGE="http://member.wide.ad.jp/wg/mgp/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~sparc ~ppc ~amd64"
+IUSE="cjk nls m17n-lib emacs truetype gif imlib"
+
+MY_DEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXrender
+ x11-libs/libXmu
+ gif? ( >=media-libs/giflib-4.0.1 )
+ imlib? ( media-libs/imlib )
+ truetype? ( virtual/xft )
+ emacs? ( virtual/emacs )
+ m17n-lib? ( dev-libs/m17n-lib )
+ g? ( media-libs/libmng )"
+DEPEND="${MY_DEPEND}
+ sys-devel/autoconf
+ x11-proto/xextproto
+ x11-libs/libxkbfile
+ app-text/rman
+ x11-misc/imake"
+RDEPEND="${MY_DEPEND}
+ nls? ( sys-devel/gettext )
+ truetype? ( cjk? ( media-fonts/sazanami ) )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.11b-gentoo.diff"
+
+ # bug #85720
+ sed -i -e "s/ungif/gif/g" configure.in || die "sed failed"
+ ht_fix_file configure.in
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable gif) \
+ $(use_enable imlib) \
+ $(use_enable nls locale) \
+ $(use_enable truetype xft2) \
+ $(use_with m17n-lib) \
+ --disable-vflib \
+ --disable-freetype \
+ --x-libraries=/usr/X11R6/lib \
+ --x-includes=/usr/X11R6/include || die "econf failed"
+
+ xmkmf || die "xmkmf failed"
+ # no parallel make possible!
+ make -j1 Makefiles || die "emake failed"
+ make clean || die "emake clean failed"
+ make BINDIR=/usr/bin LIBDIR=/etc/X11 || die "emake failed"
+ use emacs && cp contrib/*.el "${S}" && \
+ elisp-compile *.el || die "elisp-compile failed"
+}
+
+src_install() {
+ make \
+ DESTDIR="${D}" \
+ BINDIR=/usr/bin \
+ LIBDIR=/etc/X11 \
+ install || die "make install"
+
+ make \
+ DESTDIR="${D}" \
+ DOCHTMLDIR=/usr/share/doc/${PF} \
+ MANPATH=/usr/share/man \
+ MANSUFFIX=1 \
+ install.man || die "emake install.man failed"
+
+ exeinto /usr/bin
+ doexe contrib/{mgp2html.pl,mgp2latex.pl}
+
+ if use emacs ; then
+ elisp-install ${PN} *.el *.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ dodoc COPYRIGHT* FAQ README* RELNOTES SYNTAX TODO* USAGE*
+
+ insinto /usr/share/${PF}/sample
+ cd sample
+ doins README* cloud.jpg dad.* embed*.mgp gradation*.mgp \
+ mgp-old*.jpg mgp.mng mgp3.xbm mgprc-sample \
+ multilingual.mgp sample*.mgp sendmail6*.mgp \
+ tutorial*.mgp v6*.mgp v6header.* || die
+}
+
+pkg_postinst() {
+ elog
+ elog "If you enabled xft2 support (default) you may specify xfont directive by"
+ elog "font name and font registry."
+ elog "e.g.)"
+ elog '%deffont "standard" xfont "sazanami mincho" "jisx0208.1983"'
+ elog
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}