summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-06-13 10:27:42 +0000
committerPacho Ramos <pacho@gentoo.org>2014-06-13 10:27:42 +0000
commit35776e34b6389a335cdf84a860593211842169cf (patch)
tree8e51a573ece7979f227d8525c4529f7b78a99d8f /app-office/gnumeric
parentVersion bump, drop -ffast-math filtering as it was added for 0.2.x versions y... (diff)
downloadgentoo-2-35776e34b6389a335cdf84a860593211842169cf.tar.gz
gentoo-2-35776e34b6389a335cdf84a860593211842169cf.tar.bz2
gentoo-2-35776e34b6389a335cdf84a860593211842169cf.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/ChangeLog7
-rw-r--r--app-office/gnumeric/gnumeric-1.12.17.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 74c8e575c051..9646d3ab30c6 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnumeric
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.273 2014/05/31 09:41:46 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.274 2014/06/13 10:27:42 pacho Exp $
+
+*gnumeric-1.12.17 (13 Jun 2014)
+
+ 13 Jun 2014; Pacho Ramos <pacho@gentoo.org> +gnumeric-1.12.17.ebuild:
+ Version bump
*gnumeric-1.12.16 (31 May 2014)
diff --git a/app-office/gnumeric/gnumeric-1.12.17.ebuild b/app-office/gnumeric/gnumeric-1.12.17.ebuild
new file mode 100644
index 000000000000..131d4c86150c
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.17.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.12.17.ebuild,v 1.1 2014/06/13 10:27:42 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection libgda perl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.38.0:2
+ >=gnome-extra/libgsf-1.14.24:=
+ >=x11-libs/goffice-0.10.14:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+ libgda? ( gnome-extra/libgda:5[gtk] )
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}