summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-04 21:03:13 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-04 21:03:13 +0000
commit022ec5e8723955bf3117bdd83d3d568d6b2f2e0f (patch)
tree84d50cb2cf797168c91d13ca168415f3a7f4259b /app-office/gnumeric
parentExport typechecker internals for haddock (alpha, ia64, ppc64). Allow ghc-ia64... (diff)
downloadgentoo-2-022ec5e8723955bf3117bdd83d3d568d6b2f2e0f.tar.gz
gentoo-2-022ec5e8723955bf3117bdd83d3d568d6b2f2e0f.tar.bz2
gentoo-2-022ec5e8723955bf3117bdd83d3d568d6b2f2e0f.zip
Version bump. Improved interoperability with OOo. Allow user-defined templates and various other fixes.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/ChangeLog9
-rw-r--r--app-office/gnumeric/gnumeric-1.10.11.ebuild76
-rw-r--r--app-office/gnumeric/gnumeric-1.8.4-r2.ebuild102
3 files changed, 84 insertions, 103 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 7282b1ac1498..9fcfeec0ca2e 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/gnumeric
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.209 2010/09/13 07:14:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.210 2010/10/04 21:03:13 eva Exp $
+
+*gnumeric-1.10.11 (04 Oct 2010)
+
+ 04 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ -gnumeric-1.8.4-r2.ebuild, +gnumeric-1.10.11.ebuild:
+ Version bump. Improved interoperability with OOo. Allow user-defined
+ templates and various other fixes.
13 Sep 2010; Joseph Jezak <josejx@gentoo.org> gnumeric-1.10.6.ebuild:
Marked ppc stable for bug #326503.
diff --git a/app-office/gnumeric/gnumeric-1.10.11.ebuild b/app-office/gnumeric/gnumeric-1.10.11.ebuild
new file mode 100644
index 000000000000..1fdf12603da4
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.10.11.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.10.11.ebuild,v 1.1 2010/10/04 21:03:13 eva Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2:2.4"
+
+inherit gnome2 flag-o-matic python
+
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+HOMEPAGE="http://www.gnome.org/projects/gnumeric/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="gnome perl python"
+# libgda
+
+# lots of missing files, wait for next release
+# also fails tests due to 80-bit long story
+RESTRICT="test"
+
+RDEPEND="sys-libs/zlib
+ app-arch/bzip2
+ >=dev-libs/glib-2.12
+ >=gnome-extra/libgsf-1.14.19[gnome?]
+ >=x11-libs/goffice-0.8.10:0.8
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.12
+
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/cairo[svg]
+ >=gnome-base/libglade-2.3.6
+
+ gnome? (
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libbonobo-2.2
+ >=gnome-base/libbonoboui-2.2 )
+ perl? ( dev-lang/perl )
+ python? ( >=dev-python/pygtk-2 )
+"
+# libgda? (
+# >=gnome-extra/libgda-4.1.1:4.0
+# >=gnome-extra/libgnomedb-3.99.6:4.0 )
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.25
+ >=dev-util/pkgconfig-0.18
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS BEVERAGES BUGS ChangeLog HACKING MAINTAINERS NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-ssindex
+ --disable-static
+ --without-gda
+ --with-zlib
+ $(use_with perl)
+ $(use_with python)
+ $(use_with gnome)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Remove useless .la files
+ find "${ED}" -name "*.la" -delete || die
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+}
diff --git a/app-office/gnumeric/gnumeric-1.8.4-r2.ebuild b/app-office/gnumeric/gnumeric-1.8.4-r2.ebuild
deleted file mode 100644
index 437564979dc0..000000000000
--- a/app-office/gnumeric/gnumeric-1.8.4-r2.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.8.4-r2.ebuild,v 1.9 2010/07/20 16:32:43 jer Exp $
-
-EAPI="2"
-
-inherit gnome2 flag-o-matic python autotools
-
-DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
-HOMEPAGE="http://www.gnome.org/projects/gnumeric/"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
-IUSE="gnome perl python"
-# bonobo guile libgda mono (experimental)
-
-# lots of missing files, wait for next release
-RESTRICT="test"
-
-RDEPEND="sys-libs/zlib
- app-arch/bzip2
- >=dev-libs/glib-2.6
- >=gnome-extra/libgsf-1.14.6[gnome?]
- >=x11-libs/goffice-0.6.3:0.6
- >=dev-libs/libxml2-2.4.12
- >=x11-libs/pango-1.8.1
-
- >=x11-libs/gtk+-2.16
- x11-libs/cairo[svg]
- >=gnome-base/libglade-2.3.6
- >=media-libs/libart_lgpl-2.3.11
-
- gnome? (
- >=gnome-base/gconf-2
- >=gnome-base/libgnome-2
- >=gnome-base/libgnomeui-2
- >=gnome-base/libbonobo-2.2
- >=gnome-base/libbonoboui-2.2 )
- perl? ( dev-lang/perl )
- python? (
- >=dev-lang/python-2
- >=dev-python/pygtk-2 )"
- # libgda? (
- # >=gnome-extra/libgda-3.1.1
- # >=gnome-extra/libgnomedb-3.0.1 )
-
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.29
- >=dev-util/pkgconfig-0.18
- app-text/scrollkeeper"
-
-DOCS="AUTHORS BEVERAGES BUGS ChangeLog HACKING MAINTAINERS NEWS README"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --enable-ssindex
- --disable-static
- --without-gda
- --without-guile
- --without-mono
- --with-zlib
- $(use_with perl)
- $(use_with python)
- $(use_with gnome)"
-
- # gcc bug (http://bugs.gnome.org/show_bug.cgi?id=128834)
- replace-flags "-Os" "-O2"
-}
-
-src_prepare() {
- # Fix for CVE-2009-0318, bug #257012
- epatch "${FILESDIR}/${P}-CVE-2009-0318.patch"
-
- # Fix gtk+ 2.16 ABI changs wrt spinbuttons
- epatch "${FILESDIR}/${P}-gtk216-abi-spinbuttons.patch"
-
- # Fix gtk+-2.16 semantic changes, bug #278502
- epatch "${FILESDIR}/${P}-gtk216-im-block.patch"
-
- # Fix #275352 (the sed expression didn't work !)
- intltoolize --automake --copy --force || die "intltoolize failed"
- eautoreconf
-}
-
-src_install() {
- gnome2_src_install
-
- # Remove useless .la files
- find "${D}" -name "*.la" -delete
-
- # make gnumeric find its help
- dosym \
- /usr/share/gnome/help/gnumeric \
- /usr/share/${PN}/${PV}/doc
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- python_need_rebuild
-}