summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-07-28 17:57:50 +0000
committerMarinus Schraal <foser@gentoo.org>2003-07-28 17:57:50 +0000
commitf44086d36a80626daf44c042b0786e91a06a38ba (patch)
treead06c06bd01d19a26133e57981d38cf6cc36bff2 /app-office/abiword
parentnew dev version (diff)
downloadgentoo-2-f44086d36a80626daf44c042b0786e91a06a38ba.tar.gz
gentoo-2-f44086d36a80626daf44c042b0786e91a06a38ba.tar.bz2
gentoo-2-f44086d36a80626daf44c042b0786e91a06a38ba.zip
new dev version
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/ChangeLog7
-rw-r--r--app-office/abiword/Manifest6
-rw-r--r--app-office/abiword/abiword-1.99.3.ebuild96
-rw-r--r--app-office/abiword/files/digest-abiword-1.99.32
4 files changed, 107 insertions, 4 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 1206534cc20f..fb385eb1bbce 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.43 2003/07/27 18:17:43 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.44 2003/07/28 17:57:40 foser Exp $
+
+*abiword-1.99.3 (28 Jul 2003)
+
+ 28 Jul 2003; foser <foser@gentoo.org> abiword-1.99.3.ebuild :
+ New version, use enchant for spell USE flag, now really fix #24705
*abiword-1.99.2 (27 Jul 2003)
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
index 3f22388febde..a9172a0a9bde 100644
--- a/app-office/abiword/Manifest
+++ b/app-office/abiword/Manifest
@@ -1,10 +1,10 @@
MD5 144371398dbe030e96f2e320cf8470c2 abiword-1.0.6-r1.ebuild 1930
MD5 1abe03d14ed3a4064bb061324361cab9 abiword-1.0.2-r1.ebuild 4687
-MD5 56175a6fc3b7ce8d983391c23a3dd5de abiword-1.99.2.ebuild 2122
+MD5 3b84d70d93e5ce1d6172306a35d2543e abiword-1.99.2.ebuild 2121
MD5 1ac8b02dd63859b53ddf415ebbbcd0bf abiword-1.99.1.ebuild 2478
-MD5 aef277562cb783d352f8898b17926e16 ChangeLog 7075
+MD5 28859c02fd60a59cd9bb232ad074aa9a ChangeLog 7240
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
-MD5 9706c7f51f0c127f398353d911c3745f abiword-1.99.3.ebuild 2119
+MD5 725be60608c2f5340e9d1b746654a47d abiword-1.99.3.ebuild 2150
MD5 d9c89710f2f6df8316f4506ee7d9f542 files/digest-abiword-1.99.1 68
MD5 f080426cc26d779158e955db2b3a57af files/digest-abiword-1.99.2 143
MD5 e25e0ea2de22ec54cf1acec686b99e9f files/digest-abiword-1.99.3 144
diff --git a/app-office/abiword/abiword-1.99.3.ebuild b/app-office/abiword/abiword-1.99.3.ebuild
new file mode 100644
index 000000000000..9c757e0d2e4b
--- /dev/null
+++ b/app-office/abiword/abiword-1.99.3.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.99.3.ebuild,v 1.1 2003/07/28 17:57:40 foser Exp $
+
+inherit eutils debug
+
+IUSE="spell jpeg xml2 gnome"
+
+S=${WORKDIR}/${P}/abi
+S_P=${WORKDIR}/${PN}-plugins-${PV}
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://sourceforge/${PN}/${PN}-plugins-${PV}.tar.gz"
+
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+LICENSE="GPL-2"
+SLOT="2"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=media-libs/fontconfig-2.1
+ >=dev-libs/libunicode-0.4-r1
+ media-libs/libpng
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=app-text/wv-0.7.6
+ >=dev-libs/fribidi-0.10.4
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ ( xml2? >=dev-libs/libxml2-2.4.10 : dev-libs/expat )
+ spell? ( >=app-text/enchant-0.1 )
+ gnome? ( >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=gnome-extra/gal-1.99 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# >=dev-libs/libole2-0.2.4-r1
+# perl? ( >=dev-lang/perl-5.6 )
+# perl seems broken
+
+# FIXME : do 'real' use switching, add gucharmap support
+# switches do not work by the looks of it
+
+src_compile() {
+
+ ./autogen.sh
+
+ econf \
+ `use_enable gnome` \
+ `use_with xml2 libxml2` \
+ `use_enable spell enchant` \
+ --enable-bidi \
+ --with-sys-wv || die
+
+ emake all-recursive || die
+
+ # Build plugins
+
+ cd ${S_P}
+
+ ./nextgen.sh
+ econf --enable-all --with-abiword=${S} || die
+ emake || die
+
+}
+
+src_install() {
+ dodir /usr/{bin,lib}
+
+ einstall PERLDEST=${D} || die
+
+ dosed "s:${D}::g" /usr/bin/AbiWord-2.0
+
+ rm -f ${D}/usr/bin/abiword-2.0
+ rm -f ${D}/usr/bin/abiword
+ dosym AbiWord-2.0 /usr/bin/abiword-2.0
+
+ dodoc COPYING *.TXT docs/build/BUILD.TXT user/wp/readme.txt
+
+ # install plugins
+
+ cd ${S_P}
+
+ make DESTDIR=${D} install || die
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ newins ${WORKDIR}/${P}/abidistfiles/icons/abiword_48.png AbiWord.png
+ insinto /usr/share/applications/
+ doins ${FILESDIR}/AbiWord2.desktop
+
+}
diff --git a/app-office/abiword/files/digest-abiword-1.99.3 b/app-office/abiword/files/digest-abiword-1.99.3
new file mode 100644
index 000000000000..2ebedeb5bb58
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-1.99.3
@@ -0,0 +1,2 @@
+MD5 b5637c9bc95ae77aafdac24249787264 abiword-1.99.3.tar.bz2 14417825
+MD5 59c8b607a55a4b5329d4fbf116ef8ea2 abiword-plugins-1.99.3.tar.gz 1274469