summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-04-03 21:20:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-04-03 21:20:38 +0000
commitea1ed904b4f800c8f9fbcb2ca93653161a0a5356 (patch)
tree5ca9713dc1229b35682c3372101df1f8a84c0291 /app-office/abiword
parentVersion bump to KDE 4.0.3. This is still not intended for mainstream so DO NO... (diff)
downloadgentoo-2-ea1ed904b4f800c8f9fbcb2ca93653161a0a5356.tar.gz
gentoo-2-ea1ed904b4f800c8f9fbcb2ca93653161a0a5356.tar.bz2
gentoo-2-ea1ed904b4f800c8f9fbcb2ca93653161a0a5356.zip
bump to 2.6.0
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/ChangeLog9
-rw-r--r--app-office/abiword/abiword-2.6.0.ebuild88
2 files changed, 95 insertions, 2 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index bc48690517a5..d11cf565d28b 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.186 2007/09/08 11:30:22 eva Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.187 2008/04/03 21:20:38 eva Exp $
+
+*abiword-2.6.0 (03 Apr 2008)
+
+ 03 Apr 2008; Gilles Dartiguelongue <eva@gentoo.org> +abiword-2.6.0.ebuild:
+ bump to 2.6.0
08 Sep 2007; Gilles Dartiguelongue <eva@gentoo.org>
-files/16_fcfini_crash.dpatch, -abiword-2.4.5.ebuild,
diff --git a/app-office/abiword/abiword-2.6.0.ebuild b/app-office/abiword/abiword-2.6.0.ebuild
new file mode 100644
index 000000000000..cc1743ab1f7c
--- /dev/null
+++ b/app-office/abiword/abiword-2.6.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.6.0.ebuild,v 1.1 2008/04/03 21:20:38 eva Exp $
+
+inherit alternatives eutils gnome2 versionator
+
+MY_MAJORV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gnome spell xml"
+
+# FIXME: gsf could probably we conditional
+
+RDEPEND="virtual/xft
+ dev-libs/popt
+ sys-libs/zlib
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2
+ >=x11-libs/goffice-0.4
+ >=media-libs/libpng-1.2
+ >=x11-libs/libXft-2.0
+ >=media-libs/fontconfig-2.1
+ >=media-libs/freetype-2.1
+ >=x11-libs/pango-1.2
+ >=app-text/wv-1.2
+ >=dev-libs/fribidi-0.10.4
+ xml? ( >=dev-libs/libxml2-2.4.10 )
+ !xml? ( dev-libs/expat )
+ spell? ( >=app-text/enchant-1.2 )
+ gnome? (
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-extra/gucharmap-1.4
+ >=gnome-base/gnome-vfs-2.2 )
+ >=gnome-extra/libgsf-1.12.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+# FIXME: --enable-libabiword fails to compile
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_enable debug symbols)
+ $(use_enable gnome gnomeui)
+ $(use_enable gnome gucharmap)
+ $(use_enable gnome gnomevfs)
+ $(use_enable spell spellcheck)
+ $(use_with xml libxml2)
+ $(use_with !xml expat)
+ --disable-libabiword
+ --enable-printing
+ --enable-threads
+ --disable-scripting
+ --enable-symbols"
+}
+
+src_install() {
+ gnome2_src_install
+
+ sed -i "s:Exec=abiword:Exec=abiword-${MY_MAJORV}:" "${D}"/usr/share/applications/abiword.desktop
+
+ mv "${D}/usr/bin/abiword" "${D}/usr/bin/Abiword-${MY_MAJORV}"
+ dosym AbiWord-${MY_MAJORV} /usr/bin/abiword-${MY_MAJORV}
+
+ dodoc *.TXT user/wp/readme.txt
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ alternatives_auto_makesym "/usr/bin/abiword" "/usr/bin/abiword-[0-9].[0-9]"
+
+ elog "As of version 2.4, all abiword plugins have been moved"
+ elog "into a seperate app-office/abiword-plugins package"
+ elog "You can install them by running emerge abiword-plugins"
+}