summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-02-15 19:21:01 +0000
committerPacho Ramos <pacho@gentoo.org>2013-02-15 19:21:01 +0000
commitfe98236dc3553639ed893fba140b8d5791b9c572 (patch)
treeb7b618c72bf39828bbaa85a83ba922a927e340e6 /app-mobilephone
parentMigrate to distutils-r1. (diff)
downloadgentoo-2-fe98236dc3553639ed893fba140b8d5791b9c572.tar.gz
gentoo-2-fe98236dc3553639ed893fba140b8d5791b9c572.tar.bz2
gentoo-2-fe98236dc3553639ed893fba140b8d5791b9c572.zip
Don't show elog messages always (#457596)
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/qtadb/ChangeLog8
-rw-r--r--app-mobilephone/qtadb/qtadb-0.8.1.ebuild48
2 files changed, 30 insertions, 26 deletions
diff --git a/app-mobilephone/qtadb/ChangeLog b/app-mobilephone/qtadb/ChangeLog
index 7d1c5642c119..5d81aaacbba3 100644
--- a/app-mobilephone/qtadb/ChangeLog
+++ b/app-mobilephone/qtadb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-mobilephone/qtadb
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/qtadb/ChangeLog,v 1.3 2011/11/15 23:13:48 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/qtadb/ChangeLog,v 1.4 2013/02/15 19:21:01 pacho Exp $
+
+ 15 Feb 2013; Pacho Ramos <pacho@gentoo.org> qtadb-0.8.1.ebuild:
+ Don't show elog messages always (#457596)
15 Nov 2011; Markos Chandras <hwoarang@gentoo.org> qtadb-0.8.1.ebuild:
Add missing x11-libs/qt-declarative dependency. Fix DEPEND variable. Bug
@@ -15,4 +18,3 @@
+metadata.xml:
Initial commit. Thanks to Marios Andreopoulos <opensource@andmarios.com>. Bug
#390331
-
diff --git a/app-mobilephone/qtadb/qtadb-0.8.1.ebuild b/app-mobilephone/qtadb/qtadb-0.8.1.ebuild
index 1592f4ef0c9a..ea3e35cf8ae9 100644
--- a/app-mobilephone/qtadb/qtadb-0.8.1.ebuild
+++ b/app-mobilephone/qtadb/qtadb-0.8.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/qtadb/qtadb-0.8.1.ebuild,v 1.3 2011/11/15 23:13:48 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/qtadb/qtadb-0.8.1.ebuild,v 1.4 2013/02/15 19:21:01 pacho Exp $
EAPI="4"
-inherit eutils qt4-r2
+inherit eutils readme.gentoo qt4-r2
MY_PN="QtADB"
MY_P="${MY_PN}_${PV}_src"
@@ -25,29 +25,31 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/trunk"
+pkg_setup() {
+ DISABLE_AUTOFORMATTING="yes"
+ DOC_CONTENTS="
+You will need a working Android SDK installation (adb and aapt executables)
+You can install Android SDK a) through portage (emerge android-sdk-update-manager
+and run android to download the actual sdk), b) manually from
+http://developer.android.com/sdk/index.html or c) just grab the adb, aapt linux
+binaries from http://qtadb.wordpress.com/download/
+adb and aapt executables are in the platform-tools subdir of Android SDK
+
+Also you will need to have ROOT access to your phone along with busybox
+The latter can be found in the Android market
+
+Last, if you want to use the SMS manager of QtADB, you have to install
+QtADB.apk to your device, available here: http://qtadb.wordpress.com/download/
+
+If you have trouble getting your phone connected through usb (driver problem),
+try adbWireless from Android market to get connected through WiFi
+"
+}
+
src_install() {
newicon images/android.png ${PN}.png
make_desktop_entry ${MY_PN} "${MY_PN}" ${PN} \
"Qt;PDA;Utility;" || die "Desktop entry creation failed"
dobin ${MY_PN}
-}
-
-pkg_postinst() {
- echo
- elog "You will need a working Android SDK installation (adb and aapt executables)"
- elog "You can install Android SDK a) through portage (emerge android-sdk-update-manager"
- elog "and run android to download the actual sdk), b) manually from"
- elog "http://developer.android.com/sdk/index.html or c) just grab the adb, aapt linux"
- elog "binaries from http://qtadb.wordpress.com/download/"
- elog "adb and aapt executables are in the platform-tools subdir of Android SDK"
- echo
- elog "Also you will need to have ROOT access to your phone along with busybox"
- elog "The latter can be found in the Android market"
- echo
- elog "Last, if you want to use the SMS manager of QtADB, you have to install"
- elog "QtADB.apk to your device, available here: http://qtadb.wordpress.com/download/"
- echo
- elog "If you have trouble getting your phone connected through usb (driver problem),"
- elog "try adbWireless from Android market to get connected through WiFi"
- echo
+ readme.gentoo_create_doc
}