summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-06-01 12:18:38 +0000
committerAlin Năstac <mrness@gentoo.org>2008-06-01 12:18:38 +0000
commit237d42d115393729f6c011c459bbd02f9ab2cb9a (patch)
tree71d2f393b4388892cbfadc6bb2a3d1d72fe5a14a /app-mobilephone/gnokii
parentfix mod_ssl memory leak wrt #222643 (diff)
downloadgentoo-2-237d42d115393729f6c011c459bbd02f9ab2cb9a.tar.gz
gentoo-2-237d42d115393729f6c011c459bbd02f9ab2cb9a.tar.bz2
gentoo-2-237d42d115393729f6c011c459bbd02f9ab2cb9a.zip
Version bump (#215378).
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-mobilephone/gnokii')
-rw-r--r--app-mobilephone/gnokii/ChangeLog7
-rw-r--r--app-mobilephone/gnokii/gnokii-0.6.26.ebuild111
2 files changed, 117 insertions, 1 deletions
diff --git a/app-mobilephone/gnokii/ChangeLog b/app-mobilephone/gnokii/ChangeLog
index 5085f2964c1e..079e7a3bac37 100644
--- a/app-mobilephone/gnokii/ChangeLog
+++ b/app-mobilephone/gnokii/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/gnokii
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.73 2008/05/21 15:52:49 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.74 2008/06/01 12:18:38 mrness Exp $
+
+*gnokii-0.6.26 (01 Jun 2008)
+
+ 01 Jun 2008; Alin Năstac <mrness@gentoo.org> +gnokii-0.6.26.ebuild:
+ Version bump (#215378).
21 May 2008; Tiziano Müller <dev-zero@gentoo.org>
gnokii-0.6.14-r2.ebuild, gnokii-0.6.18-r1.ebuild, gnokii-0.6.19.ebuild,
diff --git a/app-mobilephone/gnokii/gnokii-0.6.26.ebuild b/app-mobilephone/gnokii/gnokii-0.6.26.ebuild
new file mode 100644
index 000000000000..b09ecc4b1927
--- /dev/null
+++ b/app-mobilephone/gnokii/gnokii-0.6.26.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/gnokii-0.6.26.ebuild,v 1.1 2008/06/01 12:18:38 mrness Exp $
+
+WANT_AUTOMAKE="none"
+
+inherit eutils linux-info
+
+DESCRIPTION="user space driver and tools for use with mobile phones"
+HOMEPAGE="http://www.gnokii.org/"
+SRC_URI="http://www.gnokii.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls bluetooth ical irda sms postgres mysql usb X debug"
+
+RESTRICT="test" #test fails; maybe it will work in the future, but till then...
+
+RDEPEND="X? ( >=x11-libs/gtk+-2.8.19 )
+ bluetooth? ( >=net-wireless/bluez-libs-2.25 )
+ sms? ( >=dev-libs/glib-2.10.3
+ postgres? ( >=virtual/postgresql-server-8.0 )
+ mysql? ( >=virtual/mysql-4.1 )
+ )
+ ical? ( >=dev-libs/libical-0.26.6 )
+ usb? ( >=dev-libs/libusb-0.1.11 )"
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( >=sys-devel/gettext-0.14.5 )"
+
+CONFIG_CHECK="UNIX98_PTYS"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" cs de et fi fr it nl pl pt sk sl sv zh_CN"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ strip-linguas ${MY_AVAILABLE_LINGUAS}
+}
+
+src_compile() {
+ config_xdebug="--disable-xdebug"
+ use X && use debug && config_xdebug="--enable-xdebug"
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable ical libical) \
+ $(use_enable usb libusb) \
+ $(use_enable irda) \
+ $(use_enable bluetooth) \
+ $(use_with X x) \
+ $(use_enable debug) \
+ ${config_xdebug} \
+ $(use_enable debug rlpdebug) \
+ --enable-security \
+ --disable-unix98test \
+ || die "configure failed"
+
+ emake -j1 || die "make failed"
+
+ if use sms; then
+ pushd "${S}/smsd"
+ emake || die "smsd make install failed"
+ popd
+ fi
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ if use X; then
+ insinto /usr/share/pixmaps
+ newins Docs/sample/logo/gnokii.xpm xgnokii.xpm
+ fi
+
+ insinto /etc
+ doins Docs/sample/gnokiirc
+ sed -i -e 's:/usr/local:/usr:' "${D}/etc/gnokiirc"
+
+ doman Docs/man/*
+
+ dodir "/usr/share/doc/${PF}"
+ cp -r Docs/sample "${D}/usr/share/doc/${PF}/sample"
+ cp -r Docs/protocol "${D}/usr/share/doc/${PF}/protocol"
+ rm -rf Docs/man Docs/sample Docs/protocol
+ dodoc Docs/* ChangeLog TODO MAINTAINERS
+
+ # only one file needs suid root to make a pseudo device
+ fperms 4755 /usr/sbin/mgnokiidev
+
+ if use sms; then
+ pushd "${S}/smsd"
+ einstall || die "smsd make install failed"
+ insinto /usr/share/doc/${PF}/smsd
+ use mysql && doins sms.tables.mysql.sql README.MySQL
+ use postgres && doins sms.tables.pq.sql
+ doins README ChangeLog README.Tru64 action
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "Make sure the user that runs gnokii has read/write access to the device"
+ elog "which your phone is connected to."
+ elog "The simple way of doing that is to add your user to the uucp group."
+}