summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-01-10 09:48:47 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-01-10 09:48:47 +0000
commit9edf24036411b95ff537e9398b851d660d743164 (patch)
treecf748485d3a7b03ae497804cec2491ab33828ea5 /app-misc
parentTransfer Prefix keywords (diff)
downloadgentoo-2-9edf24036411b95ff537e9398b851d660d743164.tar.gz
gentoo-2-9edf24036411b95ff537e9398b851d660d743164.tar.bz2
gentoo-2-9edf24036411b95ff537e9398b851d660d743164.zip
Bug #251859: fix pre-stripped files. Thanks to Kevin Pyle <gentoo.8eaf7cd8e5128d8191fe@spamgourmet.com> for the patch.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fdutils/ChangeLog10
-rw-r--r--app-misc/fdutils/fdutils-5.5-r1.ebuild43
2 files changed, 51 insertions, 2 deletions
diff --git a/app-misc/fdutils/ChangeLog b/app-misc/fdutils/ChangeLog
index 66ca4dbe6aa1..7ad53306bce2 100644
--- a/app-misc/fdutils/ChangeLog
+++ b/app-misc/fdutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/fdutils
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/fdutils/ChangeLog,v 1.22 2008/09/03 08:50:52 opfer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fdutils/ChangeLog,v 1.23 2010/01/10 09:48:47 robbat2 Exp $
+
+*fdutils-5.5-r1 (10 Jan 2010)
+
+ 10 Jan 2010; Robin H. Johnson <robbat2@gentoo.org> +fdutils-5.5-r1.ebuild:
+ Bug #251859: fix pre-stripped files. Thanks to Kevin Pyle
+ <gentoo.8eaf7cd8e5128d8191fe@spamgourmet.com> for the patch.
03 Sep 2008; Christian Faulhammer <opfer@gentoo.org>
fdutils-5.4.20020222-r1.ebuild, fdutils-5.5.ebuild:
diff --git a/app-misc/fdutils/fdutils-5.5-r1.ebuild b/app-misc/fdutils/fdutils-5.5-r1.ebuild
new file mode 100644
index 000000000000..13cfe04641ad
--- /dev/null
+++ b/app-misc/fdutils/fdutils-5.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fdutils/fdutils-5.5-r1.ebuild,v 1.1 2010/01/10 09:48:47 robbat2 Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="utilities for configuring and debugging the Linux floppy driver"
+HOMEPAGE="http://fdutils.linux.lu/"
+SRC_URI="http://fdutils.linux.lu/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="doc"
+
+DEPEND=">=sys-fs/mtools-3
+ doc? ( virtual/texi2dvi )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # the man 4 fd manpage is better in the man-pages package, so stop it
+ # from installing
+ epatch "${FILESDIR}/${PN}-no-fd.4-manpage.diff"
+ epatch "${FILESDIR}/${P}-destdirfix.patch"
+ sed -i -e '/\$(INSTALL) -c/s/ -s / /' src/Makefile.in || die "Failed to sed upstream src/Makefile.in to prevent premature strip"
+}
+
+src_compile() {
+ econf --enable-fdmount-floppy-only || die
+
+ if use doc;
+ then
+ make || die
+ else
+ make compile || die
+ fi
+}
+
+src_install() {
+ dodoc Changelog
+ use doc && dodir /usr/share/info/
+ emake -j1 DESTDIR="${D}" install || die
+}