summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-14 08:40:31 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-14 08:40:31 +0000
commit73e5b98d827eb532fe198f320e93415e1fe58e59 (patch)
tree1fa7fdadd8feca158babd24f83987e3403b562c8 /app-misc
parentEbuild cleanup and libpng recompile (diff)
downloadgentoo-2-73e5b98d827eb532fe198f320e93415e1fe58e59.tar.gz
gentoo-2-73e5b98d827eb532fe198f320e93415e1fe58e59.tar.bz2
gentoo-2-73e5b98d827eb532fe198f320e93415e1fe58e59.zip
use shadow if PAM is not in USE
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/xlockmore/ChangeLog10
-rw-r--r--app-misc/xlockmore/files/digest-xlockmore-5.03-r41
-rw-r--r--app-misc/xlockmore/xlockmore-5.03-r4.ebuild93
3 files changed, 102 insertions, 2 deletions
diff --git a/app-misc/xlockmore/ChangeLog b/app-misc/xlockmore/ChangeLog
index 74da88a42dad..094e6878dd8e 100644
--- a/app-misc/xlockmore/ChangeLog
+++ b/app-misc/xlockmore/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for app-misc/xlockmore
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xlockmore/ChangeLog,v 1.5 2002/03/27 21:32:33 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xlockmore/ChangeLog,v 1.6 2002/04/14 08:40:31 seemant Exp $
-*xlockmore-5.03-r2 (27 Mar 2002)
+*xlockmore-5.03-r4 (14 Apr 2002)
+
+ 14 Apr 2002; Seemant Kulleen <seemant@gentoo.org> xlockmore-5.03-r4.ebuild :
+
+ If PAM is not in USE, cause it to use shadow instead for password locking.
+
+*xlockmore-5.03-r3 (27 Mar 2002)
27 Mar 2002; Seemant Kulleen <seemant@gentoo.org> xlockmore-5.03-r3.ebuild :
diff --git a/app-misc/xlockmore/files/digest-xlockmore-5.03-r4 b/app-misc/xlockmore/files/digest-xlockmore-5.03-r4
new file mode 100644
index 000000000000..0c8cf283098a
--- /dev/null
+++ b/app-misc/xlockmore/files/digest-xlockmore-5.03-r4
@@ -0,0 +1 @@
+MD5 3f3a30c92e4d241dd81c6059f2724c55 xlockmore-5.03.tar.gz 1730062
diff --git a/app-misc/xlockmore/xlockmore-5.03-r4.ebuild b/app-misc/xlockmore/xlockmore-5.03-r4.ebuild
new file mode 100644
index 000000000000..1f6bc6e7d6ed
--- /dev/null
+++ b/app-misc/xlockmore/xlockmore-5.03-r4.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: system@gentoo.org
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xlockmore/xlockmore-5.03-r4.ebuild,v 1.1 2002/04/14 08:40:31 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Just another screensaver application for X"
+SRC_URI="ftp://ftp.tux.org/pub/tux/bagleyd/xlockmore/${P}.tar.gz"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+
+DEPEND="virtual/x11 media-libs/freetype
+ opengl? ( virtual/opengl )
+ pam? ( sys-libs/pam )
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )"
+ # motif? ( >=x11-libs/openmotif-2.1.30-r1 )
+ # gtk? ( x11-libs/gtk+ )
+
+src_compile() {
+
+ local myconf
+
+ use pam \
+ && myconf="${myconf} --enable-pam" \
+ || myconf="${myconf} --disable-pam --enable-xlockrc"
+
+ use nas \
+ || myconf="${myconf} --without-nas"
+
+ use esd \
+ && myconf="${myconf} --with-esound"
+
+ use opengl \
+ || myconf="${myconf} --without-opengl"
+
+ use truetype \
+ || myconf="${myconf} --without-ttf"
+
+ use esd \
+ && myconf="${myconf} --with-esound"
+
+ #use motif || myconf="${myconf} --without-motif"
+ #use gtk || myconf="${myconf} --without-gtk"
+ # sigh... broken configure script and/or makefile...
+ myconf="${myconf} --without-motif --without-gtk"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=${prefix}/share/man/man1 \
+ --sharedstatedir=/usr/share/xlockmore \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+
+ # configure script seems to suffer braindamage and doesn't setup
+ # correct makefiles for these, so they are disabled for now until
+ # some kind soul wants to submit a patch ;)
+
+ #if [ "`use gtk`" ] ; then
+ # cd ${S}/xglock
+ # make all || die
+ #fi
+
+ #if [ "`use motif`" ] ; then
+ # cd ${S}/xmlock
+ # make all || die
+ #fi
+
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ xapploaddir=${D}/usr/X11R6/lib/X11/app-defaults \
+ install || die
+
+ exeinto /usr/bin
+
+ # known issue: how do you tell xlock where its sounds are?
+ insinto /usr/share/xlockmore
+ doins sounds/*
+
+# use motif && doexe ${S}/xmlock/xmlock
+# use gtk && doexe ${S}/xglock/xglock
+
+ dodoc docs/* README
+# use gtk && dodoc xglock/xglockrc xglock/README.xglock
+
+}