summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-02-08 02:04:27 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-02-08 02:04:27 +0000
commit430fdd8b272fd29164b1303bd28e2644840b7d77 (patch)
tree7cabf3daab6be0349df27790e8f00b70a50fcf30 /app-misc
parentFix tyop. (diff)
downloadgentoo-2-430fdd8b272fd29164b1303bd28e2644840b7d77.tar.gz
gentoo-2-430fdd8b272fd29164b1303bd28e2644840b7d77.tar.bz2
gentoo-2-430fdd8b272fd29164b1303bd28e2644840b7d77.zip
Clean up ebuild after 4 years of bitrot. Now 64-bit compile-safe and no sandbox errors.
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/egads/ChangeLog8
-rw-r--r--app-misc/egads/egads-0.9.5.ebuild31
2 files changed, 30 insertions, 9 deletions
diff --git a/app-misc/egads/ChangeLog b/app-misc/egads/ChangeLog
index 6c0e7a2f2e28..58feed65ad3d 100644
--- a/app-misc/egads/ChangeLog
+++ b/app-misc/egads/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/egads
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/egads/ChangeLog,v 1.7 2007/02/09 07:15:02 flameeyes Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/egads/ChangeLog,v 1.8 2008/02/08 02:04:27 robbat2 Exp $
+
+ 08 Feb 2008; Robin H. Johnson <robbat2@gentoo.org> egads-0.9.5.ebuild:
+ Clean up ebuild after 4 years of bitrot. Now 64-bit compile-safe and no
+ sandbox errors.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/app-misc/egads/egads-0.9.5.ebuild b/app-misc/egads/egads-0.9.5.ebuild
index 8adbda37ad3c..2e816ab95f3d 100644
--- a/app-misc/egads/egads-0.9.5.ebuild
+++ b/app-misc/egads/egads-0.9.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/egads/egads-0.9.5.ebuild,v 1.6 2005/07/21 17:17:26 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/egads/egads-0.9.5.ebuild,v 1.7 2008/02/08 02:04:27 robbat2 Exp $
DESCRIPTION="Entropy Gathering And Distribution System"
HOMEPAGE="http://www.securesoftware.com/download_${PN}.htm"
@@ -8,22 +8,39 @@ SRC_URI="http://www.securesoftware.com/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~ppc x86"
+KEYWORDS="~ppc x86 ~amd64"
IUSE=""
DEPEND="virtual/libc"
egadsdatadir=/var/run/egads
+src_unpack() {
+ unpack "${A}"
+ sed -i \
+ -e '/^BINDIR/d' \
+ -e '/^LIBDIR/d' \
+ -e '/^INCLUDEDIR/d' \
+ ${S}/Makefile.in || die "Failed to fix Makefile.in"
+}
+
src_compile() {
- econf --with-egads-datadir="${egadsdatadir}" --with-bindir=/usr/sbin || die
- emake || die
+ econf \
+ --with-egads-datadir="${egadsdatadir}" \
+ --with-bindir=/usr/sbin \
+ || die
+ emake LIBDIR="/usr/$(get_libdir)" || die
}
src_install() {
keepdir ${egadsdatadir}
- fperm +t ${egadsdatadir}
- einstall BINDIR=${D}/usr/sbin || die
+ fperms +t ${egadsdatadir}
+ # NOT parallel safe, and no DESTDIR support
+ emake -j1 install \
+ BINDIR="${D}"/usr/sbin \
+ LIBDIR="${D}"/usr/$(get_libdir) \
+ INCLUDEDIR="${D}"/usr/include \
+ || die
dodoc README* doc/*.txt
dohtml doc/*.html
}