summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-11-11 19:21:56 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-11-11 19:21:56 +0000
commit20f048fe8109f6f75a6ead784240a044dd3597b7 (patch)
treec4fa0b6dfe37e351f114a9018d653b9b7474c989 /app-misc
parentAdded myself to metadata.xml (diff)
downloadgentoo-2-20f048fe8109f6f75a6ead784240a044dd3597b7.tar.gz
gentoo-2-20f048fe8109f6f75a6ead784240a044dd3597b7.tar.bz2
gentoo-2-20f048fe8109f6f75a6ead784240a044dd3597b7.zip
Version bump. Fix build with gtk+-2.22, fix titles and keywords in various situations. Translation updates.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gnote/ChangeLog9
-rw-r--r--app-misc/gnote/gnote-0.7.2.ebuild4
-rw-r--r--app-misc/gnote/gnote-0.7.3.ebuild58
3 files changed, 68 insertions, 3 deletions
diff --git a/app-misc/gnote/ChangeLog b/app-misc/gnote/ChangeLog
index 0f7f14bb61fa..a44b5cc5cf02 100644
--- a/app-misc/gnote/ChangeLog
+++ b/app-misc/gnote/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/gnote
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.8 2010/10/20 13:55:37 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.9 2010/11/11 19:21:56 eva Exp $
+
+*gnote-0.7.3 (11 Nov 2010)
+
+ 11 Nov 2010; Gilles Dartiguelongue <eva@gentoo.org> gnote-0.7.2.ebuild,
+ +gnote-0.7.3.ebuild:
+ Version bump. Fix build with gtk+-2.22, fix titles and keywords in various
+ situations. Translation updates.
20 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
-files/gnote-0.6.1-dbus-switch.patch, -gnote-0.6.3.ebuild,
diff --git a/app-misc/gnote/gnote-0.7.2.ebuild b/app-misc/gnote/gnote-0.7.2.ebuild
index f922cb608532..771b839b6eb5 100644
--- a/app-misc/gnote/gnote-0.7.2.ebuild
+++ b/app-misc/gnote/gnote-0.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.7.2.ebuild,v 1.2 2010/10/20 13:55:37 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.7.2.ebuild,v 1.3 2010/11/11 19:21:56 eva Exp $
EAPI="2"
@@ -55,5 +55,5 @@ src_prepare() {
src_install() {
gnome2_src_install
- find -name "${D}" -name "*.la" -delete || die "la file removal failed"
+ find "${D}" -name "*.la" -delete || die "la file removal failed"
}
diff --git a/app-misc/gnote/gnote-0.7.3.ebuild b/app-misc/gnote/gnote-0.7.3.ebuild
new file mode 100644
index 000000000000..59b614e6b9f6
--- /dev/null
+++ b/app-misc/gnote/gnote-0.7.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.7.3.ebuild,v 1.1 2010/11/11 19:21:56 eva Exp $
+
+EAPI="3"
+
+inherit gnome2
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="http://live.gnome.org/Gnote"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="applet debug" # dbus
+
+RDEPEND=">=x11-libs/gtk+-2.20:2
+ >=dev-cpp/glibmm-2
+ >=dev-cpp/gtkmm-2.12
+ >=dev-libs/libxml2-2
+ dev-libs/libxslt
+ >=gnome-base/gconf-2
+ >=dev-libs/libpcre-7.8[cxx]
+ >=app-text/gtkspell-2.0.9
+ >=dev-libs/boost-1.34
+ sys-libs/e2fsprogs-libs
+ applet? (
+ >=gnome-base/gnome-panel-2
+ >=dev-cpp/libpanelappletmm-2.26 )"
+# Build with dbus is currently not implemented
+# dbus? ( >=dev-libs/dbus-glib-0.70 )"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ app-text/gnome-doc-utils
+ app-text/docbook-xml-dtd:4.1.2"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-dbus
+ --disable-static
+ $(use_enable applet)
+ $(use_enable debug)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not set idiotic defines in a released tarball, bug #311979
+ sed 's/-DG.*_DISABLE_DEPRECATED//g' -i libtomboy/Makefile.am \
+ libtomboy/Makefile.in || die "sed failed"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die "la file removal failed"
+}