summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-02-14 23:42:49 +0000
committerMichael Weber <xmw@gentoo.org>2012-02-14 23:42:49 +0000
commit1449ed62f4ffc59b63340f30f81324b5c9692698 (patch)
tree970a03f7d854f3e14922f59a0e7a6cafa18e1bb4 /app-misc
parentInstall documentation and configs (thanks Timothy Messier for the report, bug... (diff)
downloadgentoo-2-1449ed62f4ffc59b63340f30f81324b5c9692698.tar.gz
gentoo-2-1449ed62f4ffc59b63340f30f81324b5c9692698.tar.bz2
gentoo-2-1449ed62f4ffc59b63340f30f81324b5c9692698.zip
Adding sys-libs/zlib dependency and revbump to fix CXXFLAGS, thanks Agostino Sarubbo (bug 403573)
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/golly/ChangeLog9
-rw-r--r--app-misc/golly/golly-2.3-r1.ebuild46
-rw-r--r--app-misc/golly/golly-2.3.ebuild3
3 files changed, 56 insertions, 2 deletions
diff --git a/app-misc/golly/ChangeLog b/app-misc/golly/ChangeLog
index 8187ab250c4c..4b896bf22ba3 100644
--- a/app-misc/golly/ChangeLog
+++ b/app-misc/golly/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/golly
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/ChangeLog,v 1.10 2012/02/14 14:22:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/ChangeLog,v 1.11 2012/02/14 23:42:49 xmw Exp $
+
+*golly-2.3-r1 (14 Feb 2012)
+
+ 14 Feb 2012; Michael Weber <xmw@gentoo.org> golly-2.3.ebuild,
+ +golly-2.3-r1.ebuild:
+ Adding sys-libs/zlib dependency and revbump to fix CXXFLAGS, thanks Agostino
+ Sarubbo (bug 403573)
14 Feb 2012; Agostino Sarubbo <ago@gentoo.org> golly-2.3.ebuild:
Stable for amd64, wrt bug #403411
diff --git a/app-misc/golly/golly-2.3-r1.ebuild b/app-misc/golly/golly-2.3-r1.ebuild
new file mode 100644
index 000000000000..fb9aaf6a6d6a
--- /dev/null
+++ b/app-misc/golly/golly-2.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/golly-2.3-r1.ebuild,v 1.1 2012/02/14 23:42:49 xmw Exp $
+
+EAPI=4
+PYTHON_DEPEND=2
+WX_GTK_VER=2.8
+
+inherit eutils python toolchain-funcs wxwidgets
+
+MY_P=${P}-src
+DESCRIPTION="simulator for Conway's Game of Life and other cellular automata"
+HOMEPAGE="http://golly.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ sys-libs/zlib
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -e 's:-O2::' -i configure Makefile.{am,in} || die
+}
+
+src_configure() {
+ econf \
+ --with-perl-shlib="libperl.so" \
+ --with-python-shlib="$(python_get_library)"
+}
+
+src_install() {
+ emake docdir= DESTDIR="${D}" install
+ dodoc README
+}
diff --git a/app-misc/golly/golly-2.3.ebuild b/app-misc/golly/golly-2.3.ebuild
index a8ae11dcf213..645da1c2f822 100644
--- a/app-misc/golly/golly-2.3.ebuild
+++ b/app-misc/golly/golly-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/golly-2.3.ebuild,v 1.2 2012/02/14 14:22:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/golly-2.3.ebuild,v 1.3 2012/02/14 23:42:49 xmw Exp $
EAPI=2
PYTHON_DEPEND=2
@@ -19,6 +19,7 @@ KEYWORDS="amd64 ~x86"
IUSE=""
DEPEND="dev-lang/perl
+ sys-libs/zlib
x11-libs/wxGTK:${WX_GTK_VER}[X]"
RDEPEND="${DEPEND}"