summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-15 13:06:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-15 13:06:35 +0000
commit663039cce3e226ab04f19e097987dfcf3cfeafc7 (patch)
tree82207bd5b8c4db858a5ce1ecfce3bb42be133718 /app-misc/wyrd
parentBuild QtScriptTools bindings. Fixes bug 279945 (diff)
downloadgentoo-2-663039cce3e226ab04f19e097987dfcf3cfeafc7.tar.gz
gentoo-2-663039cce3e226ab04f19e097987dfcf3cfeafc7.tar.bz2
gentoo-2-663039cce3e226ab04f19e097987dfcf3cfeafc7.zip
USE deps instead of built_with_use
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/wyrd')
-rw-r--r--app-misc/wyrd/wyrd-1.4.4.ebuild26
1 files changed, 8 insertions, 18 deletions
diff --git a/app-misc/wyrd/wyrd-1.4.4.ebuild b/app-misc/wyrd/wyrd-1.4.4.ebuild
index 90d84c1071fd..16fbaab653dc 100644
--- a/app-misc/wyrd/wyrd-1.4.4.ebuild
+++ b/app-misc/wyrd/wyrd-1.4.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/wyrd-1.4.4.ebuild,v 1.2 2008/10/26 19:09:28 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/wyrd-1.4.4.ebuild,v 1.3 2009/08/15 13:06:35 ssuominen Exp $
-inherit eutils
+EAPI=2
DESCRIPTION="Text-based front-end to Remind"
HOMEPAGE="http://pessimization.com/software/wyrd/"
@@ -14,27 +14,17 @@ KEYWORDS="amd64 ~ppc ~sparc x86"
IUSE="unicode"
DEPEND=">=dev-lang/ocaml-3.08
- sys-libs/ncurses
+ sys-libs/ncurses[unicode?]
>=x11-misc/remind-03.01"
RDEPEND=${DEPEND}
-pkg_setup() {
- use unicode || return 0
- if ! built_with_use sys-libs/ncurses unicode ; then
- eerror "To use unicode in wyrd you must build sys-libs/ncurses"
- eerror "with unicode support."
- die "Please rebuilt sys-libs/ncurses with unicode in USE!"
- fi
-}
-
-src_compile() {
- econf $(use_enable unicode utf8 ) || die "configure failed"
- emake || die "make failed"
+src_configure() {
+ econf \
+ $(use_enable unicode utf8)
}
src_install() {
- make DESTDIR="${D}" install || die "install died"
-
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog || die "dodoc failed"
dohtml doc/manual.html || die "dohtml failed"
}